Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-25-06, 08:28 AM   #1
karthanistyr
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Performance artifacts on GeForce 4 440Go driver 9629 and some hopefully useful hints

Hi,

It's been a long way to finally get my card to work properly (laptop Toshiba Satellite 5100-503).

NV17 Geforce 4 440Go 32MB
Pentium 4M 1,8GHz
512MB DDR

X.org 7.1.1
nvidia 1.0-9629
KDE 3.5.5

At first, I got the black screen issue described in many threads here, and I found out that the card was detecting a ghost CRT monitor, and assumed it was the primary display to use (which was wrong because only the DFP is connected).
The only workaround I found to be effective was to add to the Device Section:

Option "UseDisplayDevice" "DFP-0"

Then, the specified modes/resolutions were all discarded, the driver assuming that everything above 1400x1050 was incorrect, which was wrong, as the optimal mode for my screen was 1600x1200.
Until 96xx, the nvidia driver was defaulting to 1600x1200 if it was the only mode specified, though it left a black bar on the right edge of the screen. Since 96xx, any attempt to display anything above 1400x1050 was resulting in a black screen or in display corruption, even with EDID disabled.
The issue is that with the new drivers and with the toshiba vbios, my 440Go is unable to get the correct EDID from my monitor.
The work around was using a custom EDID and to force it with my monitor.

The edid is in this thread (bottom on the page, post by kelvin): http://www.nvnews.net/vbulletin/show...ight=nvnew.raw
Then add to the Device Section:

Option "CustomEDID" "DFP-0:/etc/X11/nvnew.raw"

assuming you called the file nvnew.raw and placed it in /etc/X11 .

The the card displayed everything right, 1600x1200 and no black bar.

My current issue, now is 3D acceleration performance. When I launch glxgears, I get an overall 1300+ FPS. But every 5 seconds or so, the gears seem to stutter for about 1 second, then go back to normal fluidity. I doesn't seem to be related to the FPS display in the terminal, since Penguin Racer has the same issue, but at a different frequency (every 20sec or so). It's quite annoying, and I couldn't figure out why it was doing this. It's not a matter of resolution either, it does the same in 640x480...

Attached: X.org log and xorg.conf
Attached Files
File Type: log Xorg.0.log (24.9 KB, 96 views)
File Type: txt xorg.conf.txt (3.1 KB, 114 views)
karthanistyr is offline   Reply With Quote
Old 11-25-06, 01:56 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Performance artifacts on GeForce 4 440Go driver 9629 and some hopefully useful hints

The stutter problem is a mysterious one. People have reported it before, search these forums for "stutter".
whig is offline   Reply With Quote
Old 11-25-06, 03:05 PM   #3
HankNV
Registered User
 
Join Date: Nov 2006
Posts: 23
Default Re: Performance artifacts on GeForce 4 440Go driver 9629 and some hopefully useful hi

I'm guessing it might be AGP related.

Try
Option "NvAgp" "0"
This will slow it down even more. But if it works, at least the developers should know that it's related to the AGP code.

Hank
HankNV is offline   Reply With Quote
Old 11-25-06, 03:16 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Performance artifacts on GeForce 4 440Go driver 9629 and some hopefully useful hints

@karthanistyr: are there any Xid messages in the output of `dmesg` after the stuttering?
zander is offline   Reply With Quote
Old 11-25-06, 09:36 PM   #5
karthanistyr
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: Performance artifacts on GeForce 4 440Go driver 9629 and some hopefully useful hi

@HankNV: NvAGP "0" does exactly the same... :/


@zander:

$ dmesg | grep Xid

Nothing comes, I guess there isn't any Xid message...
karthanistyr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.