Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-21-06, 11:39 AM   #1
grover
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Dell i8100 with Geforce2 Go not working

Hi forum members,

I am very near to giving up.

In the past I never had any problems with setting up the 3d NVIDIA driver with
my old SuSE versions.

But for 2 years my notebook was dead, and I only have it running again since a few month.

Since then I have not been able to get it to work again with the current latest nvidia drivers.

I have tested many different drivers, I have read manuals and howtos for days and days, I have googled again and again.

I have tried SuSE 10.1, 10.0, and xubuntu dapper drake without any success.

The things that happen change from time to time (when I change something in my xorg.conf) but generally X11 flickers a few times and then just stays black.

I have to reboot then to get any console back.

Currently I am using dapper drake and the package NVIDIA-Linux-x86-1.0-8776-pkg1.run

My xorg.conf looks like this:

Quote:
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "de"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Monitor"
Identifier "Dell i8100"
HorizSync 30.0 - 70
VertRefresh 50.0 - 75.0
Option "DPMS"
Modeline "1400x1050_60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -HSync +Vsync

EndSection

Section "Device"
Identifier "NVidia Geforce Go"
Driver "nvidia"
Option "backingstore"
# Option "NvAGP" "0"
Option "RenderAccel" "1"
Option "UseEDID" "1"
Option "ConnectedMonitor" "DFP-0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVidia Geforce Go"
Monitor "Dell i8100"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1400x1050_60"
EndSubSection
EndSection


The output of Xorg.0.log looks like this: (had to shorten it a bit)

Quote:

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.15.7 i686
Current Operating System: Linux cordulia 2.6.15-26-386 #1 PREEMPT Thu Aug 3 02:52:00 UTC 2006 i686
Build Date: 16 March 2006
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 21 16:37:01 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Dell i8100"
(**) | |-->Device "NVidia Geforce Go"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "Synaptics Touchpad"
(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(**) FontPath set to "/usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.2
X.Org Video Driver: 0.8
X.Org XInput driver : 0.5
X.Org Server Extension : 0.2
X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.8
(--) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,1130 card 0000,0000 rev 04 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,1131 card 0000,0000 rev 04 class 06,04,00 hdr 01
(II) PCI: 00:1e:0: chip 8086,2448 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,244c card 0000,0000 rev 03 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,244a card 8086,4541 rev 03 class 01,01,80 hdr 00
(II) PCI: 00:1f:2: chip 8086,2442 card 8086,4541 rev 03 class 0c,03,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0112 card 1028,00e6 rev b2 class 03,00,00 hdr 00
(II) PCI: 02:03:0: chip 125d,1998 card 1028,00e6 rev 10 class 04,01,00 hdr 00
(II) PCI: 02:06:0: chip 1668,0100 card 0000,0000 rev 11 class 06,04,00 hdr 01
(II) PCI: 02:0f:0: chip 104c,ac42 card d000,0000 rev 00 class 06,07,00 hdr 82
(II) PCI: 02:0f:1: chip 104c,ac42 card d800,0000 rev 00 class 06,07,00 hdr 82
(II) PCI: 02:0f:2: chip 104c,8027 card 1028,00e6 rev 00 class 0c,00,10 hdr 80
(II) PCI: 08:04:0: chip 8086,1229 card 1668,1100 rev 08 class 02,00,00 hdr 00
(II) PCI: 08:08:0: chip 11c1,0448 card 1668,2400 rev 01 class 07,80,00 hdr 00
(II) PCI: End of PCI scan
(II) Intel Bridge workaround enabled
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,13), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000c (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xfc000000 - 0xfdffffff (0x2000000) MX[b]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xe0000000 - 0xe7ffffff (0x8000000) MX[b]
(II) Subtractive PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:30:0), (0,2,16), BCTRL: 0x0006 (VGA_EN is cleared)
(II) Bus 2 I/O range:

(II) Bus 2 non-prefetchable memory range:
[0] -1 0 0xf2000000 - 0xfbffffff (0xa000000) MX[b]
(II) Bus 2 prefetchable memory range:
[0] -1 0 0x20000000 - 0x23ffffff (0x4000000) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) PCI-to-PCI bridge:
(II) Bus 8: bridge is at (2:6:0), (2,8,8), BCTRL: 0x0006 (VGA_EN is cleared)
(II) Bus 8 I/O range:
[0] -1 0 0x0000e000 - 0x0000e0ff (0x100) IX[b]
[1] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[b]
[2] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[b]
[3] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[b]
(II) Bus 8 non-prefetchable memory range:
[0] -1 0 0xf8000000 - 0xf9ffffff (0x2000000) MX[b]
(II) PCI-to-CardBus bridge:
(II) Bus 9: bridge is at (2:15:0), (2,9,12), BCTRL: 0x05c0 (VGA_EN is cleared)
(II) Bus 9 I/O range:
[0] -1 0 0x0000d000 - 0x0000d0ff (0x100) IX[b]
[1] -1 0 0x0000d400 - 0x0000d4ff (0x100) IX[b]
(II) Bus 9 non-prefetchable memory range:
[0] -1 0 0xf2000000 - 0xf3ffffff (0x2000000) MX[b]
(II) Bus 9 prefetchable memory range:
[0] -1 0 0x20000000 - 0x21ffffff (0x2000000) MX[b]
(II) PCI-to-CardBus bridge:
(II) Bus 13: bridge is at (2:15:1), (2,13,16), BCTRL: 0x05c0 (VGA_EN is cleared)
(II) Bus 13 I/O range:
[0] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[b]
[1] -1 0 0x0000f000 - 0x0000f0ff (0x100) IX[b]
(II) Bus 13 non-prefetchable memory range:
[0] -1 0 0xf4000000 - 0xf5ffffff (0x2000000) MX[b]
(II) Bus 13 prefetchable memory range:
[0] -1 0 0x22000000 - 0x23ffffff (0x2000000) MX[b]
(--) PCI:*(1:0:0) nVidia Corporation NV11 [GeForce2 Go] rev 178, Mem @ 0xfc000000/24, 0xe0000000/27

(II) PCI Memory resource overlap reduced 0xe8000000 from 0xebffffff to 0xe7ffffff
(II) Active PCI resource ranges:

(II) LoadModule: "bitmap"
(II) Reloading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Loading font Bitmap
(II) LoadModule: "ddc"
(II) Loading /usr/lib/xorg/modules/libddc.so
(II) Module ddc: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 7.0.0, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.8776
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "type1"
(II) Loading /usr/lib/xorg/modules/fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.2
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.1.0
ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.8776
Module class: X.Org Video Driver
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.3
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
compiled for 4.3.99.902, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(II) NVIDIA dlloader X Driver 1.0-8776 Mon Oct 16 21:57:32 PDT 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/lib/xorg/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 0.1.0
ABI class: X.Org Video Driver, version 0.8
(II) resource ranges after xf86ClaimFixedResources() call:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "UseEDID" "1"
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP-0"
(**) NVIDIA(0): Option "RenderAccel" "1"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): ConnectedMonitor string: "DFP-0"

Any Ideas what I can do ???
grover is offline   Reply With Quote
Old 11-28-06, 05:22 PM   #2
grover
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: Dell i8100 with Geforce2 Go not working

I have gone back to SuSE 10.1 and tried the new nvidia driver from 7. Nov.

And: Everything works fine and setup is easy.
It seems the version before was just broken.

What did I do:

Downloaded http://download.nvidia.com/XFree86/L...-9629-pkg1.run

Run: sh NVIDIA-Linux-x86-1.0-9629-pkg1.run -q

And then removed the current /etc/X11/xorg.conf and started sax2 -r -m 0=nvidia

That's it.

Thanks guys, Problem solved.

Bye
grover is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tony Hawk devs working on Call of Duty News Gaming Headlines 0 06-15-12 11:30 AM
Anybody in here have a DELL computer? Fook Me General Hardware 53 10-06-05 11:42 PM
GeForce2 on Inspiron 4100 sjg NVIDIA Linux 8 10-07-02 03:06 PM
TV-out not working nomatter what driver.. Dr_Gigolo NVIDIA Windows Graphics Drivers 11 09-11-02 12:11 PM
TNT + geforce2 GTS w/ TV-OUT tim_wilson NVIDIA Linux 3 08-01-02 06:25 PM

All times are GMT -5. The time now is 05:05 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.