Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-23-03, 05:20 PM   #1
gabor
Registered User
 
Join Date: Sep 2002
Posts: 3
Default gnome-terminal is slower with "nvidia" than with "nv"

hi,

if i open gnome-terminal, maximize it and open a text file, and begin to scroll in the file up and down, it's slow. by slow i mean it jumps to the next line in around 0.5 seconds.
this happens when using the newest (4349) nvidia binary drivers ( "nvidia" in XF86Config ).

if i switch to the xfree driver ("nv") it's a lot faster.

and if i switch to the 3xxx nvidia drivers, gnome-terminal becomes the fastest.

why?

i've read somewhere that gnome uses some calls that got rewritten when nvidia drivers went from 3xxx => 4xxx..

i tried RenderAccel=true, nothing changed.
i tried to switch to agpgart or to nvidia agp, nothing ..


athlon-tbird, 1Ghz
motherboard with sis735 chipset
cat /proc/driver/nvidia/cards/0:
-----------------------------------------
Model: GeForce4 Ti 4400
IRQ: 5
Video BIOS: 04.25.00.22.44
Card Type: AGP
-----------------------------------------
geforce4 with 128mb ram
xfree 4.3
gentoo linux
nvidia drivers:4349

thanks
gabor is offline   Reply With Quote
Old 04-23-03, 05:56 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Out of curiosity, what did you do to "set RenderAccel=true"? From the way you said that, it almost sounds like you tried to set an environment variable... is this the case?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-23-03, 06:42 PM   #3
gabor
Registered User
 
Join Date: Sep 2002
Posts: 3
Default

no

from my XF86Config:

Section "Device"
Identifier "nvidia-generic"
Driver "nvidia"
Option "NvAGP" "1"
Option "RenderAccel" "true"
EndSection


btw. is renderaccel-true working for you? it helps?
gabor is offline   Reply With Quote
Old 04-23-03, 09:44 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

I don't know about whether or not it helps (seeing as I don't use either Gnome or KDE, being a twm and Eterm person myself, I haven't ever seen what you're talking about happen), but I am using "RenderAccel" "true", yes.

I'm wondering if it isn't just bloat in gnome-terminal. Does Eterm do the same thing (if you have it), or xterm if you don't?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-23-03, 09:59 PM   #5
gabor
Registered User
 
Join Date: Sep 2002
Posts: 3
Default

well, xterm is a lot faster than gnome-terminal when using the 4349 drivers.

the point is:

1. with 3123 drivers gnome-terminal is as fast (maybe faster) as xterm

2. with xfree's nvidia driver ('nv') gnome-terminal is faster than with the 4349 drivers.

i think this shouldn't happen.

of course i can go and fill a bugreport at gnome.org but i thought that maybe this is a driver issue.

before you ask:
i want transparency+utf8. that's why i can't use xterm(no transparency) or eterm(no utf8)
gabor is offline   Reply With Quote
Old 04-24-03, 07:55 AM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Yeah, Gnome will probably tell you it's a driver problem...

Don't know what to say.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.