Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-06, 01:00 PM   #1
marioncobretti
Registered User
 
Join Date: Dec 2006
Posts: 2
Default (EE) end of block range

im having issues with a new machine. installed FreeBSD 6.1R [im more experienced w/ 4.11 stable] and have not worked with PCI-E/SLI cards w/ BSD. However I have with linux distros and didnt see many differences.

with an out of the box install of 6.1, including the installation of NVIDIA-FreeBSD-x86-1.0-9631 and nvidia-settings-1.0.

i ran an nvidia-xconfig which made the /etc/X11/xorg.conf file.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder24.nvidia.com)  Thu Nov  9 18:02:12 PST 2006

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic/"
    FontPath        "/usr/X11R6/lib/X11/fonts/TTF/"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
when i startx as a user im getting the following errors:

Code:
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0xfb < begin 0xfffffffc
(EE) end of block range 0x77ff < begin 0xfffff800
(EE) end of block range 0x77ff < begin 0xfffff800
a bunch of (II) overlaps
and of course:
Code:
(EE) No devices detected.

Fatal server error:
no screens found
any insight or possibly a suggestion of something i just missed would be appreciated. ive never run into the end of block range errors before and google didnt yield many results.



thank you for your time.

~marion
marioncobretti is offline   Reply With Quote
Old 12-08-06, 01:02 PM   #2
marioncobretti
Registered User
 
Join Date: Dec 2006
Posts: 2
Default Re: (EE) end of block range

oddities that i forgot to mention.

without making any changes i did get X to start once. though a second attempt failed. randomly it will either return with the error upon startx or lock up so that the machine needs reset.

also i have:

/boot/loader.conf
nvidia_load="YES"
linux_load="YES"

and in /etc/rc.conf
compat5x_enable="YES"

in dmesg im seeing the nvidia0 lines come up, but after boot there arent any nvidia* in /dev

Hardware:
supermicro pdsba E6000/4000 core 2 duo,
2.4Ghz Intel E6600 @1066Mhz Corse 2 Duo chip
4gig ddr2 800 dual channel memory
nvidia 7950GT

Code:
#dmesg > dmesg.txt ; grep "irq 16" dmesg.txt
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0
nvidia: <GeForce 7950 GT> port 0x4000-0x407f mem 0xd1000000-0xd1ffffff,0xc0000000-0xcfffffff,0xd0000000-0xd0ffffff irq 16 at device 0.0 on pci1
pcib2: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
added: im starting to believe the issue is mainly an IRQ or PCI IRQ routing error. I can not move the card as it is the only PCI-E16x slot on the mobo. I have not been able to find a way to change the IRQ for the card either.

Last edited by marioncobretti; 12-08-06 at 04:35 PM.
marioncobretti is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 12:23 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM
NVIDIA drivers and linux-2.5.31 eltarvag NVIDIA Linux 6 08-14-02 02:19 PM

All times are GMT -5. The time now is 06:58 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.