Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-23-03, 06:41 PM   #1
ranmakun
Registered User
 
Join Date: Apr 2003
Posts: 2
Unhappy Performance problem with driver 1.0.4349-r1

I have an AthlonXP 1600+ with an ASUS A7A266, 768mb RAM, and a Geforce4MX440 64MB Ram. Gentoo linux with xfree 4.3 (also happened with xfree 4.2)
glxgears gives 1800fps with 1.0.3123-r2 driver
and with 1.0.4349-r1 I get less that 1300fps

I dont even know if 1800fps is ok for my setup, can anyone confirm this?
Also if I change between nvidia Opengl and xfree opengl performance is exactly the same, shouldnt be better with nvidia glx?

Any ideas?, need more info?

Here it goes my XF86Config-4:
Quote:
# ************************************************** ********************
# Module section -- this section is used to specify
# which dynamically loadable modules to load.
# ************************************************** ********************

Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the GLX module
Load "glx"

#para que un juego pueda cambiar resoluciones y eso...
Load "extmod"

EndSection


# ************************************************** ********************
# Files section. This allows default font and rgb paths to be set
# ************************************************** ********************

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
# If you don't have a floating point coprocessor and emacs, Mosaic or other
# programs take long to start up, try moving the Type1 and Speedo directory
# to the end of this list (or comment them out).
#

FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
# FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

FontPath "Unix/:7100"

# The module search path. The default path is shown here.

# ModulePath "/usr/X11R6/lib/modules"

EndSection


# ************************************************** ********************
# Server flags section.
# ************************************************** ********************


Section "ServerFlags"

Option "BlankTime" "3"
Option "StandbyTime" "5"
Option "SuspendTime" "10"
Option "OffTime" "15"

EndSection


# ************************************************** ********************
# Input devices
# ************************************************** ********************

# ************************************************** ********************
# Core keyboard's InputDevice section
# ************************************************** ********************

Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"

Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us_intl"

EndSection


# ************************************************** ********************
# Core Pointer's InputDevice section
# ************************************************** ********************

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mouse0"
Option "ZAxisMapping" "4 5"
Option "Buttons" "7"

EndSection


# ************************************************** ********************
# Monitor section
# ************************************************** ********************

Section "Monitor"

Identifier "Philips 109S"
HorizSync 30 - 92
VertRefresh 50 - 160
Option "dpms"

#mame
Modeline "296x224@152d" 30.00 296 328 384 416 224 227 233 244 doublescan
Modeline "304x228@157d" 32.00 304 336 392 424 228 231 237 248 doublescan
Modeline "344x258@119d" 30.00 344 376 432 464 258 262 267 279 doublescan
Modeline "384x288@140d" 45.00 384 416 496 528 288 292 299 311 doublescan


ModeLine "1384x1038@85" 173.73 1384 1448 1768 1896 1038 1040 1052 1078
ModeLine "1384x1038" 179.52 1384 1456 1808 1952 1038 1041 1054 1082 #85Hz
# ModeLine "1280x960" 167.31 1280 1352 1688 1824 960 963 977 1008 #91Hz
ModeLine "1368x1026" 186.92 1368 1456 1872 2040 1026 1029 1045 1078 #85Hz
ModeLine "1456x1092" 188.96 1456 1536 1920 2072 1092 1095 1109 1140 #80Hz
ModeLine "1480x1110" 183.26 1480 1544 1864 1992 1110 1112 1124 1154 #80Hz


EndSection


# ************************************************** ********************
# Graphics device section
# ************************************************** ********************


Section "Device"
Identifier "Geforce4 MX440"
Driver "nvidia"
Option "dpms"
#VideoRam 65536
# Insert Clocks lines here if appropriate
EndSection


# ************************************************** ********************
# Screen sections
# ************************************************** ********************

Section "Screen"
Identifier "Screen 1"
Device "Geforce4 MX440"
Monitor "Philips 109S"
DefaultDepth 24
DefaultFbBpp 32

Option "NvAgp" "2"

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480" "320x240"
ViewPort 0 0
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480" "320x240"
ViewPort 0 0
EndSubsection

Subsection "Display"
Depth 24
Modes "1480x1110" "1024x768" "800x600" "640x480" "384x288@140d" "344x258@119d" "304x228@157d" "296x224@152d"
ViewPort 0 0
# Virtual 1600 1200
EndSubsection
EndSection

# ************************************************** ********************
# ServerLayout sections.
# ************************************************** ********************


Section "ServerLayout"

Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection
ranmakun is offline   Reply With Quote
Old 04-23-03, 07:19 PM   #2
how
Registered User
 
Join Date: Dec 2002
Location: Australia
Posts: 142
Default

performance problem with the drivers.
GF4 MX should be around about glxgears 2000fps and above. My GF2 MX is only 350fps. games are not even playable.
how is offline   Reply With Quote
Old 04-24-03, 09:51 AM   #3
ranmakun
Registered User
 
Join Date: Apr 2003
Posts: 2
Default

Ok, and any known solution to this?, what can be causing this problem?
Thank you.

Francisco
ranmakun is offline   Reply With Quote
Old 04-24-03, 08:17 PM   #4
how
Registered User
 
Join Date: Dec 2002
Location: Australia
Posts: 142
Default

read this thread:
http://www.nvnews.net/vbulletin/show...0&goto=newpost
others have the same problem.
I think it is todo with Athlonxp and the drivers.
more AMD bug?
I am sure no problem with P4.
Wait for Nvidia to do something.
how is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-16-12 07:35 AM
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-13-12 07:58 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Problem with Ethernet (nvnet) driver for RH 7.3 bernz NVIDIA Linux 4 08-05-02 10:18 AM
download problem with linux NVIDIA driver packages Timo NVIDIA Linux 7 07-31-02 09:22 AM

All times are GMT -5. The time now is 05:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.