Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-15-06, 05:03 AM   #1
filmil
Registered User
 
Join Date: Jun 2005
Posts: 7
Default NVidia Screen Flicker in X

Greets.

I am using the 9629 drivers, and more than ever I get the screen flickering issue in X.

The problem is that, once in a while as I work within an X session, the screen flickers for a fraction of a second (e.g. 0.5s or such) --- it turns completely black, stays like that for a short while and then restores.

This happens only once in a while when I am using the machine for text entry, but becomes frequent and very annoying during video playback.

I googled around and could find several old threads at various places where people were complaining about old driver versions, and even one that mentions a solution for Windows systems.

I use FC6 on a Dell Inspiron 8200 with GeForce4 440 Go.

Help or advice how to remove the flicker issue is appreciated.
f
filmil is offline   Reply With Quote
Old 12-11-06, 09:31 AM   #2
filmil
Registered User
 
Join Date: Jun 2005
Posts: 7
Default Re: NVidia Screen Flicker in X

I upgraded to 9631, and the flicker issue occurs more often and is getting not only annoying but rather tiring for the eyes.

Is there anything I should do to stop the flicker? Can someone recognize this as a symptom of imminent hardware failure? Or anything else, for that matter?

f
filmil is offline   Reply With Quote
Old 12-11-06, 12:23 PM   #3
cillian
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: NVidia Screen Flicker in X

I just got a notebook with a 7300 Go and I'm using the 9631 driver and am also getting this very annoying intermittant flicker. It seems to occur about once a minute.
I only got a couple of Xid errors for a whole days usage:
NVRM: Xid (0002:00): 6, PE0000 1f08 80000000 0000fdfc 00ffffff 00000000
NVRM: Xid (0002:00): 6, PE0000 1f10 00000000 0000fde0 00f987ff 03200000

I also tried the 7942 and it seems to flicker even more.
I've only tried with vesa and nvidia drivers and didn't have this problem with vesa.
I'm also using this Beryl 0.1.2 and Aiglx enabled Xorg 7.1 and haven't tried without Beryl yet and my system is dual core 64bit Amd x2 (tl-52)

I've got the following in xorg.conf
under device
VideoRam 262144
Option "NvAGP" "1"
Option "AddARGBGLXVisuals" "true"
Option "AllowGLXWithComposite" "true"

under monitor:
Option "DPMS"

Section "Extensions"
Option "Composite" "Enable"
EndSection

dri and glcore are disabled and glx is enabled.

I'm considering returning my notebook as I had the 'X freeze/mouse still moving bug' before and found no solution and this is too annoying to live with.
cillian is offline   Reply With Quote
Old 12-11-06, 12:50 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVidia Screen Flicker in X

See:
http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 12-12-06, 06:04 AM   #5
cillian
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: NVidia Screen Flicker in X

Hi netlama,
Thanks for your response and sorry for not providing the logs.
I tried again today with some other options. This time the 9742 driver and a patched kernel with the following boot options:
kernel /kernel-2.6.19-suspend2 init=/linuxrc ramdisk=8192 root=/dev/hdc9 pci=assign-busses reboot=cold resume2=swap:/dev/hdc5

I can see from cat /proc/interrupts that eth0 and nvidia are sharing an IRQ which can hardly be correct. I looked yesterday and this wasn't the case so perhaps this is something I can change in the BIOS? I also ran glxgears for about an hour without any issues.

So what happens is, after a while the screen freezes momentarily, although I can still move the mouse. Then it works again but flashes intermittantly. After the temporary freeze the following appears in /var/log/messages:
Dec 12 11:46:02 localhost NVRM: Xid (0002:00): 6, PE0000 0e80 fff0ece7 0000fdfc ffede9e4 ffeeebe5
Dec 12 11:46:02 localhost NVRM: Xid (0002:00): 30, L1 -> L0

in dmesg:
NVRM: Xid (0002:00): 6, PE0000 0e80 fff0ece7 0000fdfc ffede9e4 ffeeebe5
NVRM: Xid (0002:00): 30, L1 -> L0

I'll try to search the forums for suggestions a bit more later. Perhaps the IRQ issue is the culprit.

BTW I've followed the instructions on
http://gentoo-wiki.com/HARDWARE_Asus_A6T except the make menuconfig won't let me disable agppart in the kernel. It is just listed as:
--- /dev/agpgart (AGP Support)
and seleting Y/N/M make no difference

Thanks,
Cillian
Attached Files
File Type: log vanilla-2-6-19-nvidia-bug-report.log (138.2 KB, 115 views)
File Type: log suspend2-2-6-19-nvidia-bug-report.log (138.9 KB, 109 views)
cillian is offline   Reply With Quote
Old 12-12-06, 06:24 AM   #6
cillian
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: NVidia Screen Flicker in X

I just had a look in the bios and there are no options for PnP or for setting IRQ. And eth0 and nvidia are still sharing an

The following post looks like it has some potential:
http://www.nvnews.net/vbulletin/show...&highlight=irq
It suggests setting:
IRQ.PerfLevelSrc=

Last edited by cillian; 12-12-06 at 06:40 AM.
cillian is offline   Reply With Quote
Old 12-12-06, 10:12 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVidia Screen Flicker in X

There's nothing explicitly wrong with IRQ sharing. Does disabling eth0 eliminate the problem?

Does the flickering only reproduce when you're using the Composite extension?
Have you verified that you're using the latest BIOS?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-12-06, 10:28 AM   #8
cillian
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: NVidia Screen Flicker in X

I've tried the recommendation in that post i.e.:
before starting X I insert the nvidia module with
modprobe nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

Luckily I hadn't blitzed the windows installation so I was able to confirm this by running:
find /mnt/windows -iname "*.inf" -exec grep PerfLevelSrc {} \;
and it showed up as 0x2222

eth0 and nvidia are still IRQ sharing but I haven't had any Xid errors, or blinking or otherwise odd behaviour for the last 4 hours.
I've added this option to /etc/modules.d/nvidia so I'll see if that also does the magic.

::update
While I was writing this post it happened again Xid messages followed by the blinking
I may be able to return this laptop since I haven't had it for a week yet. I won't try to flash the bios, and I'm afraid I can't realistically use this for a couple of hours without network access to test if that's a contributing factor.
I can try for a while without the composite extension and see if it runs better. If there's anything else I can test before I return it please let me know.

Thanks for your help Lonni,
Cillian
cillian is offline   Reply With Quote

Old 12-15-06, 04:05 AM   #9
cillian
Registered User
 
Join Date: Jun 2006
Posts: 5
Thumbs up Re: NVidia Screen Flicker in X

I thought I'd just try everything I could find that pointed in the right direction as a last resort and something seems to have worked. I haven't seen a blink for 3 days so I'm keeping this laptop
I will try to remove these options over the next few weeks and see what has made the difference:
boot options with the gentoo suspend2-sources kernel:
kernel /kernel-2.6.19-suspend2 init=/linuxrc ramdisk=8192 root=/dev/hdc9 pci=assign-busses reboot=cold resume2=swap:/dev/hdc5 idle=poll pci=routeirq

eth0 and nvidia still share an IRQ btw

I've also put the following in /etc/modules.d/nvidia
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222" NVreg_Mobile=3

This is an Asus A6Tc-AP027H

Cheers,
Cillian
cillian is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 03:27 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.