Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-09-03, 07:28 PM   #1
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Lightbulb KT400 workaround

From ftp://download.nvidia.com/XFree86/Li...a-1.0-4349.txt -

o Starting X with AGP 8x video cards on systems with KT400 AGP
chipsets cause system hangs.

Solution: this problem can be worked around by disabling AGP
(Option "NvAGP" "0") in your XF86Config file.

Alternatively, you may be able to enable AGP 8x on your KT400 based
system by overriding the default NVreg_EnableAGPSBA registry key.
To do this you can either:

- set the value on the modprobe command line; for example:
modprobe nvidia NVreg_EnableAGPSBA=1

- add an options line to your module configuration file,
usually /etc/modules.conf; for example:
options nvidia NVreg_EnableAGPSBA=1

and use NVIDIA's AGP (Option "NvAGP" "1" in the Screen section
of your XF86Config file).

Let me know if this works.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-09-03, 11:56 PM   #2
Vwracer69
Registered User
 
Join Date: Apr 2003
Location: USA
Posts: 2
Default KT400 workaround

ok, as far as i can tell it worked for me. Since im new to linux i did what u said and redhat 9 booted up sweat! I also got a dif in glxgears. I went from about 3000fps to 5000+ fps. Is there anyway to make sure this fix is working properly, or if i actualy enabled what u segested?

Thnx!
Vwracer69 is offline   Reply With Quote
Old 04-10-03, 10:24 AM   #3
Dibbler
Registered User
 
Join Date: Feb 2003
Posts: 9
Default KT400

Well, options nvidia NVreg_EnableAGPSBA=1 worked fine for me also, but however I can not have NVreg_EnableAGPFW=1 or it disables SBA?

However having said that, even tho it reports the following:-

Status: Enabled
Driver: NVIDIA
AGP Rate: 8x
Fast Writes: Disabled
SBA: Enabled

Performance has not increased one iota, a tad disapointing to only get 2200fps in glxgears in default window.

Any ideas Andy?
__________________
There is No Spoon!
Dibbler is offline   Reply With Quote
Old 04-10-03, 11:55 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Are you putting FW and SBA on different "options" lines in modules.conf? They have to be on the same line, or the second one will override the first.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-10-03, 12:18 PM   #5
Dibbler
Registered User
 
Join Date: Feb 2003
Posts: 9
Default

That was it, but unfortunately it is unstable. Thanks for the tip tho!!
__________________
There is No Spoon!
Dibbler is offline   Reply With Quote
Old 04-10-03, 01:34 PM   #6
Miss Netzen
Registered User
 
Join Date: Apr 2003
Location: Germany Bremen
Posts: 5
Default

Works also on my system thx Andy. But why it is a workaround? Witch effects comes up with this option?

Now NWN runs very fine with linux (more fps than in Win**** ) *grin*
Miss Netzen is offline   Reply With Quote
Old 04-10-03, 03:15 PM   #7
Dibbler
Registered User
 
Join Date: Feb 2003
Posts: 9
Default

Side band addressing (SBA) enables AGP to use 8 extra (Side band) address lines in addition to the 32 main ones to transmit requests for data, which should further improve AGP performance.

Sadly this has not been the case here, in fact I see absolutely no increase in performace whatsoever, over and above "NvAGP" "0", i.e disabling AGP altogether. If anybody has any ideas as to how I can improve the situation I'd be grateful.


For reference I have the following hardware:-

ASUS A7V8X Motherboard
Geforce 4 MX 440 64 GPU

cat /driver/nvidia/agp/status

Status: Enabled
Driver: NVIDIA
AGP Rate: 8x
Fast Writes: Disabled
SBA: Enabled
__________________
There is No Spoon!
Dibbler is offline   Reply With Quote
Old 04-26-03, 04:02 PM   #8
Clight2200
Registered User
 
Join Date: Apr 2003
Posts: 3
Question X hanging until I ssh in

Hi

I am using the KT400 workaround. Specifically:-

I've added an options line to my module configuration file, /etc/modules.conf, "options nvidia NVreg_EnableAGPSBA=1", and used the NVIDIA's AGP (Option "NvAGP" "1" in the Screen section of my XF86Config file).

Before when I used to have Option "NvAGP" set to 0 everything was OK, but now KDE occasionally hangs and when I ssh into my box from an external computer the process /etc/X11/X -deferglyphs 16 -auth /var/run/xauth ... is taking all of the CPU time? How can I stop the computer hanging? Anyone got any idea what's happening here?

Help appreciated

Cheers
Ian
Computer Spec
AMD XP 2200+
Gigabyte GA-7VAX (KT 400)
DDR 512MB
GeForce Ti4200 128Mb

Last edited by Clight2200; 04-26-03 at 04:11 PM.
Clight2200 is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone benchmark KT266, KT266A, KT333 and KT400? Needa916 CPUs, Motherboards And Memory 7 10-09-02 08:34 AM
Soltek KT400 board... something's just not right... Switch CPUs, Motherboards And Memory 8 09-17-02 03:03 PM
The worst part of the KT400... Cotita CPUs, Motherboards And Memory 13 09-10-02 07:31 AM
VIA's KT400... StealthHawk CPUs, Motherboards And Memory 18 08-20-02 02:03 PM

All times are GMT -5. The time now is 03:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.