Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-23-06, 10:39 PM   #1
buckley
Registered User
 
Join Date: Dec 2006
Posts: 2
Exclamation Can not get video to work with Suse 10.2

I just want to say off the bat that I am a total noob to Linux. I am very proficient with windows, but I am just starting with Linux.

I have a 7800gt and whenever I try to boot Suse I get a cursor but the screen stays black. I have tried to install ubuntu but I get horrible graphics corruption that freezes my computer.

I am trying to install the latest drivers in failsafe mode but I am having no luck. I'm attaching a log that the installer created in hopes that someone out there can help me out.

Like I said, I know squat about Linux. Hopefully someone can help me!

Justin

http://thisride.net/nvidia-installer.log
buckley is offline   Reply With Quote
Old 12-24-06, 12:58 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can not get video to work with Suse 10.2

For SuSE specific installation instructions, please see http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html.
zander is offline   Reply With Quote
Old 12-24-06, 01:40 PM   #3
pepsi_max2k
Registered User
 
Join Date: Dec 2006
Posts: 10
Default Re: Can not get video to work with Suse 10.2

i just set up a 7800gs on suse 10.2. clearly the experience could have gone a little better, and i did learn that you shouldn't take any individual set of instructions alone as a guide, but try a number of different methods.

that said, here's what i did:

right from the off, clean install wouldn't load a gui as it was putting out an unsupported refresh rate and my monitor just turned itself off when it tried.

firstly, make sure you can actually get in to a gui. i did this by getting to a command line (ctrl-F1) and typing "sax2 -m 0=vesa", configuring this to settings i know work, then hitting save (do NOT hit test...).

"startx" would then get me in to a gui.


as an aside, you may want to make sure the "gcc" package is installed at this point, as the error log below showed that as a problem. you may also want to get "smart" installed and use that as your package manager, it's much better than YOU. basically, install these three packages (preferably with ZEN) and then open smart from start menu.
http://ftp.gwdg.de/pub/linux/misc/su...se102.i686.rpm
http://ftp.gwdg.de/pub/linux/misc/su...se102.i686.rpm
http://ftp.gwdg.de/pub/linux/misc/su...se102.i686.rpm


now, get http://download.nvidia.com/opensuse/10.2/ added as an RPM MD channel. then, search for "nvidia-gfx-kmp-kernel-default" and "x11-video-nvidia" in the package manager and install them.

now go back to a command sheel (ctrl-F1) and run "sax2 -r -m 0=nvidia". if everything's gone ok, you should see an nvidia logo pop up before the sax program. if not, err... hmm... anyway, configure again and save it, then you'll prolly have to reboot.

hopefully it'll all have your refresh rate and stuff set up properly. the kde control panel will give you dumb info, use the nvidia settings program to change that kinda thing.

any other problems (specifically dpi) see this thread :

http://www.suseforums.net/index.php?showtopic=28532


i'm sure you'll agree that by now you've found linux to be a much more easy to use and more satisfying experience than windows. damn those double clicking exe's that do all the above for you in 20 seconds. damn you all.


PS. if anyone has any idea how to install on suse 10.1 after changing from / removing ati drivers, lemme know. currently i get corrupted yellowy lines after installing from command line and sax2-anything, don't really know what to do...
pepsi_max2k is offline   Reply With Quote
Old 12-24-06, 07:23 PM   #4
buckley
Registered User
 
Join Date: Dec 2006
Posts: 2
Default Re: Can not get video to work with Suse 10.2

thank you pepsi, that was exactly what I needed to get everything running.

buckley is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 05:40 PM
John Carmack is making a virtual reality headset, $500 kits available soon, video int News Archived News Items 0 06-06-12 09:30 AM
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
My SuSE 8.0 just totally BROKE. Help please!!! sephiroth762 NVIDIA Linux 6 10-09-02 02:30 PM
Best video card for running dual displays? nutsnbolts NVIDIA GeForce 7, 8, And 9 Series 10 09-03-02 02:02 PM

All times are GMT -5. The time now is 05:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.