Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-26-03, 11:00 AM   #1
Peddy
Registered User
 
Join Date: Apr 2003
Location: UK
Posts: 12
Send a message via ICQ to Peddy Send a message via AIM to Peddy Send a message via Yahoo to Peddy
Default Custom Modeline

When using NVidia drivers instead of generic drivers, I'm unable to run Xfree at 1280x1024, and to force Xfree to run at this resolution, I need to use a custom modeline made my 'gtf' but I'm unsure how to run gtf. Would it be possible for someone to write a custom modeline that will force Xfree at this resolution for me?

1280x1024
vSync: 60.8
hSync: 64.1

Any help would be appreciated,
Peddy
Peddy is offline   Reply With Quote
Old 04-26-03, 01:06 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

gtf 1280 1024 60 will do that for you.

However, seeing as you have gtf to begin with, you therefore have X 4.3.0. Right?

If so (well heck, even if not), you can just tell it to use 1280x1024, and then make sure your HorizSync and VertRefresh lines have the correct ranges for your monitor (check the monitor documentation for the correct ranges to use), and it'll use the highest refresh rate it knows about.

Hang on... what happens when you try 1280x1024? It may very well not be the case that you need to write a modeline, but it depends on the reason that mode is getting thrown out -- what's in your X log when you try to use that resolution?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-27-03, 07:40 AM   #3
Peddy
Registered User
 
Join Date: Apr 2003
Location: UK
Posts: 12
Send a message via ICQ to Peddy Send a message via AIM to Peddy Send a message via Yahoo to Peddy
Default

Ok, I've done what you said, but X wont start and I get an error, I've attached my config and the xfree log so you can take a look.

Cheers
Attached Files
File Type: zip xfree.zip (6.1 KB, 119 views)
Peddy is offline   Reply With Quote
Old 04-27-03, 09:21 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

The problem is that none of the possible modes are actually valid. They're either outside the VertRefresh range, or outside the HorizSync range.

This might be because both of those ranges are being adjusted based on EDID information; if this EDID information is incorrect (check your monitor's manual), then use Option "IgnoreEDIDs" (and make sure that you raise your VertRefresh -- having a maximum of 60Hz is very likely WAY too low).
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-27-03, 10:08 AM   #5
Peddy
Registered User
 
Join Date: Apr 2003
Location: UK
Posts: 12
Send a message via ICQ to Peddy Send a message via AIM to Peddy Send a message via Yahoo to Peddy
Default

Oh, I forgot to say I'm using a 17" TFT, and its runs best at these low refresh rates, but I'll give it a try.
Peddy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sapphire flexes custom 7-series Radeons News Archived News Items 0 06-10-12 02:30 AM
nvidia: The drives that they're using are custom designed for the rover they built (i News Archived News Items 0 05-17-12 10:40 PM
Custom Titles? McBane Feedback Forum 15 08-03-02 12:06 AM
Custom Refresh Rates, DPI, and Other Display Tweaking Phyre NVIDIA Linux 3 08-02-02 03:32 AM
Custom Watercooling Sucks Why? DoinkyBottoms CPUs, Motherboards And Memory 8 08-01-02 02:42 PM

All times are GMT -5. The time now is 11:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.