Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-08-07, 09:35 AM   #1
kaczasty
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Resolution Problem Geforce 7600 GS on Suse 10.2 x64

Hello,
I have a problem with Nvidia drivers on Suse linux 10.2 x64. When I install driver my resolution changes to 800x600 at 60Hz and there is no way to change it. Can somebody help?

My xorg.conf file:
Code:
# /.../
# SaX generated X11 config file
# Created on: 2007-01-08T15:06:16+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  FontPath     "unix/:7100"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
EndSection

Section "Module"
  Load         "glx"
  Load         "type1"
  Load         "extmod"
  Load         "dbe"
  Load         "freetype"
  Load         "v4l"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "pl"
  Option       "XkbModel" "pc104"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "9"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImExPS/2 Generic Explorer Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  DisplaySize  310 230
  HorizSync    29-96
  Identifier   "Monitor[0]"
  ModelName    "FLATRON 795FT"
  Option       "DPMS"
  VendorName   "LG"
  VertRefresh  50-160
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1024x768" 100.19 1024 1088 1200 1376 768 769 772 809
  Modeline 	"1024x768" 88.50 1024 1088 1200 1376 768 769 772 804
  Modeline 	"1024x768" 76.16 1024 1080 1192 1360 768 769 772 800
  Modeline 	"1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
  Modeline 	"1024x600" 77.36 1024 1080 1192 1360 600 601 604 632
  Modeline 	"1024x600" 67.63 1024 1080 1184 1344 600 601 604 629
  Modeline 	"1024x600" 58.10 1024 1072 1176 1328 600 601 604 625
  Modeline 	"1024x600" 48.96 1024 1064 1168 1312 600 601 604 622
  Modeline 	"800x600" 60.07 800 840 928 1056 600 601 604 632
  Modeline 	"800x600" 53.14 800 840 928 1056 600 601 604 629
  Modeline 	"800x600" 45.50 800 840 920 1040 600 601 604 625
  Modeline 	"800x600" 38.22 800 832 912 1024 600 601 604 622
  Modeline 	"768x576" 55.94 768 816 896 1024 576 577 580 607
  Modeline 	"768x576" 48.71 768 808 888 1008 576 577 580 604
  Modeline 	"768x576" 41.66 768 800 880 992 576 577 580 600
  Modeline 	"768x576" 34.96 768 792 872 976 576 577 580 597
  Modeline 	"640x480" 37.89 640 672 736 832 480 481 484 506
  Modeline 	"640x480" 33.48 640 672 736 832 480 481 484 503
  Modeline 	"640x480" 28.56 640 664 728 816 480 481 484 500
  Modeline 	"640x480" 23.86 640 656 720 800 480 481 484 497
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "GeForce 7600 GS"
  BusID        "2:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Option       "NoLogo"
  Screen       0
  VendorName   "NVidia"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (29.7 KB, 103 views)

Last edited by kaczasty; 01-08-07 at 10:18 AM.
kaczasty is offline   Reply With Quote
Old 01-08-07, 10:44 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Resolution Problem Geforce 7600 GS on Suse 10.2 x64

It looks like the EDID being returned from your CRT is bogus:
(--) NVIDIA(0): --- EDID for @@@ (CRT-1) ---
(--) NVIDIA(0): Maximum Image Size : 65535mm x 65535mm
(--) NVIDIA(0): Valid HSync Range : 4294967 kHz - 0 kHz
(--) NVIDIA(0): Valid VRefresh Range : -1 Hz - 0 Hz
(--) NVIDIA(0): EDID maximum pixel clock : 0.0 MHz

Unless this problem wasn't present in an older driver version, you can workaround this by setting UseEDID to false in xorg.conf.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-08-07, 01:53 PM   #3
kaczasty
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: Resolution Problem Geforce 7600 GS on Suse 10.2 x64

It works now, thank you very much!
kaczasty is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
Geforce 4 Go and X-Server Problem with shutdown rapljenovic NVIDIA Linux 2 08-30-02 10:11 AM

All times are GMT -5. The time now is 12:58 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.