Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-08-07, 09:31 AM   #1
derbuffer
Registered User
 
Join Date: Dec 2006
Posts: 10
Default Black screen on Xorg-Restart / switch to console via CTRL alt F1

Hi

When i boot my machine, everything runs fine (init 5, with Xorg 7.2/kdm/kde)

BUT:
If I log off and the login-manager should appear (kdm), the screen just goes black. Same thing if I try to switch from KDE to console via CTRL + alt + F1.

When the screen is black, a few seconds later my machine does a single "beep".
The keyboard works, so I can do a reboot with CTRL + alt + del

Machine is reachable via ssh, so I started nvidia-bug-report.sh after the screen went black. I even could get some messages from /var/log/messages and /var/log/Xorg.0.log at the time the error occoured:

/var/log/messages:
Quote:
Jan 8 15:22:18 sonne kernel: NVRM: RmInitAdapter failed! (0x25:0x38:1011)
Jan 8 15:22:18 sonne kernel: NVRM: rm_init_adapter(0) failed
Jan 8 15:22:19 sonne kdm: :0[15019]: IO Error in XOpenDisplay
Jan 8 15:22:19 sonne kdm[5339]: Display :0 cannot be opened
Jan 8 15:22:19 sonne kdm[5339]: Unable to fire up local display :0; disabling.
/var/log/Xorg.0.log:
Quote:
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0): additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
This is very strange to me, because the black screen only appears if I leave X/restart X.

Would be nice if I get some feedback on this problem...

I attached the nvidia-bug-report.log

What I forgot: I even tried the latest stable vanilla Kernel 2.6.19.1-default (compiled it with my config ("make oldconfig...")). The problem stays.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (28.3 KB, 122 views)

Last edited by derbuffer; 01-08-07 at 09:44 AM.
derbuffer is offline   Reply With Quote
Old 01-08-07, 10:42 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Black screen on Xorg-Restart / switch to console via CTRL alt F1

I have a few questions:
0) Does this problem persist if you set vga=normal (instead of 0x31a) in your GRUB configuration and reboot?
1) Have you verified that you're using the latest BIOS for the motherboard?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-08-07, 01:56 PM   #3
derbuffer
Registered User
 
Join Date: Dec 2006
Posts: 10
Default Re: Black screen on Xorg-Restart / switch to console via CTRL alt F1

Hi Lonni, thanks for your fast reply.

Quote:
Originally Posted by netllama
I have a few questions:
0) Does this problem persist if you set vga=normal (instead of 0x31a) in your GRUB configuration and reboot?
With vga=normal I dont get any trouble if I restart X or switch to console. Great. Thanks :-)
But why? 0x31a was set by SuSE-Installer and this parameter worked for me using Geforce 7800GT (SLI) + nvidia-driver < 97.46. Second question: Why do I see the console when machine is booting (and nvidia-module isnt loaded)?
Is it possible to get native lcd-resolution (1280x1024@60)?


Quote:
1) Have you verified that you're using the latest BIOS for the motherboard?
Yes, this is the latest (and last?) driver from Asus for my A8N-SLI Premium mainboard.
Quote:
A8N-SLI Premium Beta BIOS 1302
Latest beta BIOS.
2006/06/19
thanks,
Karsten
derbuffer is offline   Reply With Quote
Old 01-08-07, 01:59 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Black screen on Xorg-Restart / switch to console via CTRL alt F1

This looks like a known bug in 1.0-9746 when setting the console graphics/font option (with vga=).
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
First monitor is black when going to virtual console, when using twinView zeBarbu NVIDIA Linux 2 09-07-03 09:35 PM

All times are GMT -5. The time now is 07:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.