Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-29-03, 01:06 AM   #1
jfgovern
Registered User
 
Join Date: Apr 2003
Posts: 2
Unhappy Can't get nvidia driver working with Riva TNT2 - pls help!

OK, been pounding away at this for about a week, and am finally about to throw in the towel - I have run the installer for 4363 successfully, and made the changes to XF86Config as indicated - when I try to goto runlevel 5 (telinit 5) the screen flickers, goes blank, and I have to reboot (ctrl-alt-del). I notice that in the Xfree86.0.log file the GLX and NVIDIA builds are for an earlier version (of XFree86?) than all of the other modules / drivers. Don't know if this has beans to do with the problem..

I have disabled the memory hole and disabled PNP O/S in my bios setup as well.

I've atttached my XFree86.0.log and XF86Config files (both have a .Joe extension -just ignore it) from my latest run - I have run the latest installer from Nvidia, which ran successfully. I am running RH 9.0, 2.4.20-8 on the following:

your video card : Asus Riva TNT2 Model 64 / Model 64 Pro NV5M64
- your driver version : 4363
- your distribution: RH 9.0
- your video bios revision (look in /proc/driver/nvidia/cards/0 while X is running) - I DON'T HAVE ANYTHING IN THIS PATH BEYOND DRIVER (OTHER THAN "RTC")- COULD THIS BE PART OF THE PROBLEM?
- your processor - PII-350
- your motherboard model (especially if you're having lockups) - Asus P2B (Circa '99)

I'm relatively new at Linux, but getting more dangerous by the day. Thanks for any help you can provide!
Attached Files
File Type: zip joe.zip (5.8 KB, 177 views)
jfgovern is offline   Reply With Quote
Old 04-29-03, 02:22 AM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Does disabling AGP help? You should add
Code:
Option "NvAgp" "0"
to the Device section of your XF86Config file. Alternatively, you can try using NVAGP instead of AGPGART - change the "0" to a "1" above.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-29-03, 11:19 PM   #3
jfgovern
Registered User
 
Join Date: Apr 2003
Posts: 2
Default no luck with AGP settings!

Thanks for the feedback Andy - I tried both settings (0 and then 1) and neither fixed the problem.. Any other ideas?
jfgovern is offline   Reply With Quote
Old 04-30-03, 01:42 PM   #4
briansladecek
Registered User
 
Join Date: Apr 2003
Location: United States
Posts: 21
Default

Howdy,

Joe, I used a Riva TNT2 PCI card, running XFree86 4.2, Redhat 8.0 with NVIDIA driver 3123. Everything loads fine, especially the proc entries in `/proc/drivers/nvidia..." are made, and with that said:

I checked your `XFree86.0.log' file and it seems incomplete. Is that the whole log file? I do not see where your keyboard or mouse extensions are loaded, nor do I see the "error" reported by X why it failed.

But, here is what I would...

I. In BIOS, make these settings (and they will vary slightly or not appear at all):

PCI/VGA Palette Snoop: Disabled

VGA BIOS sequence: PCI/AGP
- even though you have an AGP card, make this setting.

Video BIOS shadow: disabled

AGP Fast write: disabled

Assign IRQ to VGA: Yes
-very important one!

* this will minimize a lot of features and correct others. Later, when you get the NVIDIA driver working, you can come back and change these back (maybe just 1 at a time) and see if any of these settings are the offending culprit.

if step I. fails to correct the problem...

II. Downgrade to another NVIDIA driver release. I use 3123 on an older Linux box (and haven't had time to update yet), but it works for me.

Later, you can always upgrade to the newest drivers.

the following step can be done at any time to provide you valuable information...

III. Open a terminal, and type:

`lsmod'

Look for an entry like "nvidia" (post 4xxx version, I think), or "NVdriver" (which is from my 3123 version). If you have these entries, then at least the NVIDIA supplied drivers are being used. Although your XF86config file has the proper "nvidia" entry, there are some NVIDIA vendor entries listed in your `XF86Config', but I don't know if the regular "nv" X supplied driver will make those too. At least with the `lsmod' command you will know what driver is being used.

IV. Last but not least...

edit your `XF86Config' file and remove (comment out) the use of "fbdevhw" extension under section "modules". I'm not familiar with the intricacies of this X extension, but I guess it's just an interface to talk to the kernel framebuffer (if compiled in). In the past, some NVIDIA cards have had trouble with the kernel usage of framebuffer support. Hopefully, Redhat 9 did not compile in "framebuffer" support with their stock kernel.

Just a few thoughts, and I hope it helps...

thanks,

Brian Sladecek
briansladecek is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 09:30 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM

All times are GMT -5. The time now is 04:46 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.