Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-21-07, 11:31 AM   #1
David Marec
Registered User
 
Join Date: Nov 2006
Location: Toulouse, France
Posts: 22
Default X11: Failed to initialize the NVIDIA kernel module

First, the last week, I upgraded my freebsd box and portupgrade built an installed the new driver, 9746 that does not support my card:
GeForce2 MX/MX 400

I re-installed the 9631 driver but then, the following error occurs :

Code:
X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: FreeBSD 6.2 i386 [ELF] 
Current Operating System: FreeBSD david.dmarec.homeunix.net 6.2-STABLE FreeBSD 6.2-STABLE #3: Sat Jan 20 10:59:20 CET 2007     root@david.dmarec.homeunix.net:/usr/obj/usr/src/sys/KMirabelle i386
Build Date: 10 December 2006
[...]
II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.9631
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.9631
	Module class: X.Org Video Driver
[...]
(II) NVIDIA dlloader X Driver  1.0-9631  Thu Nov  9 17:40:39 PST 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
	compiled for 6.9.0, module version = 0.1.0
	ABI class: X.Org Video Driver, version 0.8
(II) resource ranges after xf86ClaimFixedResources() call:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[b](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[b]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[b]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[b]
	[5] -1	0	0xfeafac00 - 0xfeafafff (0x400) MX[b]E
	[6] -1	0	0xfeafc000 - 0xfeafffff (0x4000) MX[b]E
	[7] -1	0	0xfebff400 - 0xfebff7ff (0x400) MX[b]E
	[8] -1	0	0xfebff800 - 0xfebffbff (0x400) MX[b]E
	[9] -1	0	0xfebffc00 - 0xfebfffff (0x400) MX[b]E
	[10] -1	0	0xf8000000 - 0xf7ffffff (0x0) MX[b]EO
	[11] -1	0	0xfe9f0000 - 0xfe9fffff (0x10000) MX[b](B)
	[12] -1	0	0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
	[13] -1	0	0xfd000000 - 0xfdffffff (0x1000000) MX[b](B)
	[14] -1	0	0xfeafb000 - 0xfeafbfff (0x1000) MX[b]E
	[15] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[b]
	[16] -1	0	0x00000000 - 0x000000ff (0x100) IX[b]
	[17] -1	0	0x0000d000 - 0x0000d0ff (0x100) IX[b]E
	[18] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[b]E
	[19] -1	0	0x0000d800 - 0x0000d8ff (0x100) IX[b]E
	[20] -1	0	0x0000ee80 - 0x0000eeff (0x80) IX[b]E
	[21] -1	0	0x0000e800 - 0x0000e8ff (0x100) IX[b]E
	[22] -1	0	0x00000400 - 0x000004ff (0x100) IX[b]E
	[23] -1	0	0x0000fc00 - 0x0000fcff (0x100) IX[b]E
	[24] -1	0	0x0000ef80 - 0x0000efff (0x80) IX[b]E
	[25] -1	0	0x0000ef40 - 0x0000ef7f (0x40) IX[b]E
	[26] -1	0	0x0000ef20 - 0x0000ef3f (0x20) IX[b]E
	[27] -1	0	0x0000ef00 - 0x0000ef1f (0x20) IX[b]E
(II) resource ranges after probing:
	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[b](B)
	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[b]
	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[b]
	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[b]
	[5] -1	0	0xfeafac00 - 0xfeafafff (0x400) MX[b]E
	[6] -1	0	0xfeafc000 - 0xfeafffff (0x4000) MX[b]E
	[7] -1	0	0xfebff400 - 0xfebff7ff (0x400) MX[b]E
	[8] -1	0	0xfebff800 - 0xfebffbff (0x400) MX[b]E
	[9] -1	0	0xfebffc00 - 0xfebfffff (0x400) MX[b]E
	[10] -1	0	0xf8000000 - 0xf7ffffff (0x0) MX[b]EO
	[11] -1	0	0xfe9f0000 - 0xfe9fffff (0x10000) MX[b](B)
	[12] -1	0	0xe8000000 - 0xefffffff (0x8000000) MX[b](B)
	[13] -1	0	0xfd000000 - 0xfdffffff (0x1000000) MX[b](B)
	[14] -1	0	0xfeafb000 - 0xfeafbfff (0x1000) MX[b]E
	[15] 0	0	0x000a0000 - 0x000affff (0x10000) MS[b]
	[16] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[b]
	[17] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[b]
	[18] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[b]
	[19] -1	0	0x00000000 - 0x000000ff (0x100) IX[b]
	[20] -1	0	0x0000d000 - 0x0000d0ff (0x100) IX[b]E
	[21] -1	0	0x0000d400 - 0x0000d4ff (0x100) IX[b]E
	[22] -1	0	0x0000d800 - 0x0000d8ff (0x100) IX[b]E
	[23] -1	0	0x0000ee80 - 0x0000eeff (0x80) IX[b]E
	[24] -1	0	0x0000e800 - 0x0000e8ff (0x100) IX[b]E
	[25] -1	0	0x00000400 - 0x000004ff (0x100) IX[b]E
	[26] -1	0	0x0000fc00 - 0x0000fcff (0x100) IX[b]E
	[27] -1	0	0x0000ef80 - 0x0000efff (0x80) IX[b]E
	[28] -1	0	0x0000ef40 - 0x0000ef7f (0x40) IX[b]E
	[29] -1	0	0x0000ef20 - 0x0000ef3f (0x20) IX[b]E
	[30] -1	0	0x0000ef00 - 0x0000ef1f (0x20) IX[b]E
	[31] 0	0	0x000003b0 - 0x000003bb (0xc) IS[b]
	[32] 0	0	0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly. 
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
What should i do ?
David Marec is offline   Reply With Quote
Old 01-21-07, 11:56 AM   #2
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: X11: Failed to initialize the NVIDIA kernel module

Quote:
Originally Posted by David Marec
First, the last week, I upgraded my freebsd box and portupgrade built an installed the new driver, 9746 that does not support my card:
GeForce2 MX/MX 400

I re-installed the 9631 driver but then, the following error occurs :
According to nVidia's website, 9631 doesn't support your card either. The latest legacy driver would appear to be 7184. Try the following driver:

http://www.nvidia.com/object/freebsd_1.0-7184.html
adamk75 is offline   Reply With Quote
Old 01-21-07, 01:40 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: X11: Failed to initialize the NVIDIA kernel module

The 1.0-9631 FreeBSD graphics driver release does support this GPU, see ftp://download.nvidia.com/freebsd/1....ppendix-a.html; for more information on why the NVIDIA kernel module couldn't be initialized, please see the output of `dmesg` right after a failed attempt to start X.
zander is offline   Reply With Quote
Old 01-21-07, 02:34 PM   #4
David Marec
Registered User
 
Join Date: Nov 2006
Location: Toulouse, France
Posts: 22
Default Re: X11: Failed to initialize the NVIDIA kernel module

Zander,
Quote:
Originally Posted by zander
The 1.0-9631 FreeBSD graphics driver release does support this GPU, see ftp://download.nvidia.com/freebsd/1....ppendix-a.html;
Right, i was using this driver release for weeks.
Quote:
for more information on why the NVIDIA kernel module couldn't be initialized, please see the output of `dmesg` right after a failed attempt to start X.
Code:
Jan 21 21:02:54 david kernel: nvidia0: <GeForce2 MX/MX 400> mem 0xfd000000-0xfdffffff,0xe8000000-0xefffffff irq 16 at device 0.0 on pci1
Jan 21 21:02:54 david kernel: nvidia0: [GIANT-LOCKED]
Jan 21 21:03:08 david kernel: pid 1333 (Xorg), uid 0: exited on signal 6
Dmesg did not log anything else.


Thanks for your help.
David Marec is offline   Reply With Quote
Old 01-21-07, 02:57 PM   #5
David Marec
Registered User
 
Join Date: Nov 2006
Location: Toulouse, France
Posts: 22
Default Re: X11: Failed to initialize the NVIDIA kernel module

Hum,it was the glx module that was making X to abort.

After a new re-installation of the driver, it works.

I don't undestand what happened.
David Marec is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM

All times are GMT -5. The time now is 01:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.