Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-05-03, 04:51 AM   #1
wroemer
Registered User
 
Join Date: May 2003
Posts: 3
Send a message via AIM to wroemer
Unhappy Problem 4363 building kernel modul (2.4.20 SMP HIGHMEM)

On my system the nvidia installer (4363) tries to built a kernel module but this has unresolved symbols. Excerpt from my /var/log/nvidia-installer.log:

Kernel module load error: ./usr/src/nv/nvidia.o: unresolved symbol
remove_proc_entry_Rsmp_86f7070c
./usr/src/nv/nvidia.o: unresolved symbol create_proc_entry_Rsmp_ee3233d4
./usr/src/nv/nvidia.o: unresolved symbol __pollwait_Rsmp_b99999c7
./usr/src/nv/nvidia.o: unresolved symbol change_page_attr_Rsmp_da6e8366
./usr/src/nv/nvidia.o: unresolved symbol init_mm_Rsmp_8037974a
./usr/src/nv/nvidia.o: unresolved symbol register_chrdev_Rsmp_f2287ab3
./usr/src/nv/nvidia.o: unresolved symbol proc_root_driver_Rsmp_ef7a8833
./usr/src/nv/nvidia.o: unresolved symbol mem_map_Rsmp_a799f9ba
./usr/src/nv/nvidia.o: unresolved symbol irq_stat_Rsmp_eeebfc06


Any ideas?

Regards,

Wolfgang Roemer
wroemer is offline   Reply With Quote
Old 05-05-03, 07:53 AM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Looks like your kernel sources are configured for SMP, but your running kernel isn't.

Quote:
If you receive errors about unresolved symbols,
then the kernel module has most likely been built using header files
for a different kernel revision than what you are running.
-- from the README.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 05-05-03, 08:00 AM   #3
wroemer
Registered User
 
Join Date: May 2003
Posts: 3
Send a message via AIM to wroemer
Default 2.4.20 SMP HIGHMEM kernel

Hi,

I do run a SMP machine and the kernel headers do exactly match the kernel I am running.

Wolfgang
wroemer is offline   Reply With Quote
Old 05-05-03, 08:30 AM   #4
wroemer
Registered User
 
Join Date: May 2003
Posts: 3
Send a message via AIM to wroemer
Default Kernel rebuilt

Hello,

rebuilding the kernel with the exakt same configuration (using make config with keeping all answers, make dep, make bzImage) creates a kernel image with the same size and so I assume an exactly identical kernel. Nevertheless the unresolved symbols DISAPPEARED and so the nvidia driver now WORKS. I just have some strange artefacts I did not have with the 4191 driver. See green circled regions in attached screenshot.
Attached Thumbnails
Click image for larger version

Name:	snapshot4.png
Views:	132
Size:	79.7 KB
ID:	1787  
wroemer is offline   Reply With Quote
Old 05-05-03, 10:24 AM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Hmm... no idea on that artifacts problem, unfortunately.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 03:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.