Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-23-07, 12:40 PM   #1
javiersr
Registered User
 
Join Date: Nov 2005
Posts: 14
Default Poor bandwidth with 1.0-9746

I'm experiencing bandwidth problems with 1.0-9746 driver release. I'm measuring a transference time of 500x the transference time with 1.0-8776.

I'm attaching the log with an 8800GTX and a 7800GTX (of course, 8800GTX does not work at all with 1.0-8776, but 7800GTX does).

I don't know what the cause can be and I can't give any extra information but the logs. They were taken in two different PC with two different cards (just in case it could be helpful).

Thank you in advance.
Attached Files
File Type: gz nvidia-bug-report.7800GTX.log.gz (30.5 KB, 119 views)
File Type: gz nvidia-bug-report.8800GTX.log.gz (28.8 KB, 111 views)
javiersr is offline   Reply With Quote
Old 01-23-07, 12:52 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Poor bandwidth with 1.0-9746

How are you performing this measurement?
netllama is offline   Reply With Quote
Old 01-24-07, 05:06 AM   #3
javiersr
Registered User
 
Join Date: Nov 2005
Posts: 14
Default Re: Poor bandwidth with 1.0-9746

Something like:

gettimeofday(t0);
glTexSubImage2D( GL_TEXTURE_RECTANGLE_NV, 0, x, y, width, height, GL_RGBA, GL_FLOAT, (GLvoid*)data );
glFinish();
gettimeofday(t1);

and so on.

I'm writing and running more test right now to see if I can find something more concrete (may be something related to GL_NV_texture_rectangle, GL_NV_float_buffer, GLX_SGIX_pbuffer or any other of the extensions I'm using). I will post my result as soon as I get it.
javiersr is offline   Reply With Quote
Old 01-24-07, 10:52 AM   #4
javiersr
Registered User
 
Join Date: Nov 2005
Posts: 14
Default Re: Poor bandwidth with 1.0-9746

Hello,
I enclosed the problem a little bit more. If I transfer the whole chunk of data to the texture, bandwidth performance is good (indeed, it is sightly faster with 8776). But if I subdivide the transferences into blocks, the performance with 9xxx drops fast, and the performance with 8776 is just a bit lower.

I'm attaching a test code. It works as follows:
  1. It expects three parameters: width, height and tiling
  2. It allocates a (width x height) floating point RGBA texture
  3. It sequentially writes (tiles x tiles) blocks of data in the texture
  4. It reads the whole texture and checks that everything went well

So if you run the test this way:
./test 2000 2000 1
The program will write the whole texture in one transference.

If you run the test like this:
./test 2000 2000 2
The program will write (four) 1000x1000 blocks, performing four transferences to fill the texture.

I'm getting the following results:

1.0-8776

./test 2000 2000 1
Writing time: 139347
Reading time: 102771
Residue: 0
./test 2000 2000 2
Writing time: 145235
Reading time: 103051
Residue: 0
./test 2000 2000 4
Writing time: 158381
Reading time: 102603
Residue: 0
1.0-9746

./test 2000 2000 1
Writing time: 143069
Reading time: 103248
Residue: 0
./test 2000 2000 2
Writing time: 538755
Reading time: 102028
Residue: 0
./test 2000 2000 4
Writing time: 1.77387e+06
Reading time: 101770
Residue: 0
Regards.

PD: I'm using GLEW for managing extensions, so you need it to compile the test.
Attached Files
File Type: gz GPUTransferTest.tar.gz (4.2 KB, 146 views)
javiersr is offline   Reply With Quote
Old 01-24-07, 05:50 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Poor bandwidth with 1.0-9746

Thanks. I've reproduced the problem and opened bug 284530.
netllama is offline   Reply With Quote
Old 02-04-07, 12:29 PM   #6
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: Poor bandwidth with 1.0-9746

I just ran the attached test case and I also see the bandwidth problem.

Geforce 7900 GT
Fedora Core 6 x86_64
Intel Core 2 / i965 system
mooninite is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nouveau X.Org Driver Finally Releases Version 1.0 News Archived News Items 0 06-18-12 06:30 PM
Eurocom Monster 1.0: Clevo's Little Monster News Archived News Items 0 05-18-12 07:20 AM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM

All times are GMT -5. The time now is 07:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.