Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-04-07, 09:54 PM   #1
IgorC76
Registered User
 
Join Date: Feb 2007
Location: CT
Posts: 5
Angry NF-M2 nView / FC6 / Mythtv / Crash

I have an Abit NF-M2 nView motherboard (got it a few month ago). I've been trying to run FC6 / Mythtv on it. (Athlon64 Dual Core processor running 32 bit kernel, PVR-500, nothing else installed except on-board peripherals)


Here is what happens:

Installation of FC6 went fine, except that I keep getting MP-BIOS Bug, Timer not connected to APIC message

I did search through the forums and have used vairous combinations of acpi_skip_timer_override, acpi_use_timer_override, pci=nommconfig, acpi=off
The system will not boot with nosmp

No matter what I do, the result is the same - machine runs ok for a few hours and at some point at night it hangs. I have some shows scheduled to be recoded at night, so it looks like hangs in the middle of recording a show. In the morning, after reboot, there is a file with an unfinished recording. When the machine hangs, its a hard lock. When I look at the screen, I still see mythtv main screen, but the system in unresponsive. I even tried to recompile the kernel with a "magic sysreq" key enabled. Still hangs, sysreq does nothing.

Another interesting symptom is that sometimes when I try to play music or watch live tv, there is not sounds. All I have to do is restart a playback or exit and re-enter live tv. I have also noticed that network performance, using the built in network card (forcedeth drivers) is very poor

I do have the latest NVIDIA drivers installed, graphics seems to run ok. When I look at /proc/interrupts everything seems to be in order (listing below, this is with pci=nommconfig acpi_use_timer_override, if I dont use the last option, timer interrupt type turns to XT-PIC):


CPU0 CPU1
0: 98924 27117704 IO-APIC-edge timer
1: 12 20 IO-APIC-edge i8042
8: 0 1 IO-APIC-edge rtc
9: 5 1 IO-APIC-fasteoi acpi
12: 44 73 IO-APIC-edge i8042
14: 232242 8891 IO-APIC-edge ide0
15: 200 33 IO-APIC-edge ide1
16: 1482 2761794 IO-APIC-fasteoi ohci_hcd:usb1, eth0
17: 228 691 IO-APIC-fasteoi ehci_hcd:usb2, HDA Intel
18: 156390 15792 IO-APIC-fasteoi libata
19: 0 0 IO-APIC-fasteoi libata
20: 2 1 IO-APIC-fasteoi ohci1394, ivtv1
21: 1597937 51046 IO-APIC-fasteoi nvidia
22: 0 0 IO-APIC-fasteoi ivtv0
NMI: 0 0
LOC: 27218651 27218724
ERR: 0
MIS: 0


Any help would be much appreciated ! I am completely out of ideas.
IgorC76 is offline   Reply With Quote
Old 02-04-07, 09:59 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NF-M2 nView / FC6 / Mythtv / Crash

http://www.nvnews.net/vbulletin/showthread.php?t=58498
netllama is offline   Reply With Quote
Old 02-05-07, 05:46 PM   #3
IgorC76
Registered User
 
Join Date: Feb 2007
Location: CT
Posts: 5
Question Re: NF-M2 nView / FC6 / Mythtv / Crash

First of all - thank you for a quick reply ! I did read the thread mentioned above before posting a question - I should have made that clear in my earlier post.

I am running the system with pci=nommconfig all the time. I am running 32 bit kernel, not 64 bit. The only thing I did not try was idle=poll (I will try that tonight and report results), otherwise, the BIOS is flashed to 1.1 (which is the latest version on the ABIT site). I dont see how idle=poll will solve Timer / IOAPIC problem. Is it a problem ? That is, is the following ok :
..MP-BIOS bug: 8254 timer not connected to IOAPIC
...trying to set up timer (IRQ0) through the 8259A . failed.
...trying to set up timer as Virtual Wire IRQ... failed.
...trying to set up timer as ExtINT IRQ... works.

I get the above if I do anything but acpi_use_timer_override. Using acpi=off produces crashes repeatably within first 10 minutes of video playback.
IgorC76 is offline   Reply With Quote
Old 02-05-07, 06:31 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NF-M2 nView / FC6 / Mythtv / Crash

Part of that sticky post is the requirement that you provide an nvidia-bug-report.log if you believe that you're experiencing a graphics driver problem.

However, based on the dmesg output that you're reported, it sounds like the motherboard BIOS has a number of issues which need to be addressed.
netllama is offline   Reply With Quote
Old 02-06-07, 08:04 PM   #5
IgorC76
Registered User
 
Join Date: Feb 2007
Location: CT
Posts: 5
Red face Re: NF-M2 nView / FC6 / Mythtv / Crash

I completely agree - this does not appear to be a graphics driver bug. Keep in mind that this board has NVIDIA NFORCE 430 chipset, I was wondering if there is anything else I can do. I also would like to hear from other people with the same chipset if they had any luck with similar setup. Contacting ABIT provided no help ...

P.S. idle=poll did not help, the system still crahes in the middle of recording a show.
IgorC76 is offline   Reply With Quote
Old 02-06-07, 11:28 PM   #6
jmmcd
Registered User
 
Join Date: Apr 2006
Posts: 2
Default Re: NF-M2 nView / FC6 / Mythtv / Crash

I had been using MythDora 1.3.2 (FC5) on a dual-Opteron MB which was becoming semi-flaky. I just switched to an ABIT NF-M2 yesterday (w/Athlon 3800+ X2 (65w), PC5300 1GB RAM). I can't even get through the installer. Its failure path starts with:
Starting udev: Disabling IRQ #10
Wait timeout. Will continue in the background [FAILED].
(that's booting using acpi=off)

If I don't get it working quickly, it goes back to NewEgg.

HTH - Michael
jmmcd is offline   Reply With Quote
Old 02-07-07, 06:52 AM   #7
IgorC76
Registered User
 
Join Date: Feb 2007
Location: CT
Posts: 5
Thumbs down Re: NF-M2 nView / FC6 / Mythtv / Crash

Yeah, I've seen that. Using acpi=off or nosmp makes this board completely unusable. I still cant beleive how horrible abit support is ... Too bad I waited too long, so now I cant return the board.
IgorC76 is offline   Reply With Quote
Old 02-07-07, 02:57 PM   #8
kenyee
Registered User
 
Join Date: Jan 2006
Posts: 148
Default Re: NF-M2 nView / FC6 / Mythtv / Crash

Why do you have to turn ACPI off?
It seems to have a good DSDT (unlike the early incarnations of the Asus A8N-CSM board). At least Knoppix seems to detect its ACPI capabilities correctly...
kenyee is offline   Reply With Quote

Old 02-07-07, 07:59 PM   #9
IgorC76
Registered User
 
Join Date: Feb 2007
Location: CT
Posts: 5
Default Re: NF-M2 nView / FC6 / Mythtv / Crash

It's not a distribution problem. It seem that either NFORCE 430 has a broken ACPI implementation or ABIT did not implement ACPI BIOS support correctly (I think its the second one ...) When you turn ACPI off, you force the kernel to fall back on earlier methods of interrupt and device management - this sometimes helps ...
IgorC76 is offline   Reply With Quote
Old 02-10-07, 01:44 AM   #10
jmmcd
Registered User
 
Join Date: Apr 2006
Posts: 2
Default Re: NF-M2 nView / FC6 / Mythtv / Crash

Just an update.

I think the motherboard is OK. I am guessing that my problems must be sw (distro) related. I started using FC6 & setting up mythtv manually (rather than using MythDora or knoppmyth).

I haven't had *any* weirdness yet (strange errors, hangs, or reboots). mythtv is not fully setup; I am running mythtvsetup right now. But the ATSC card is finding QAM stations.
jmmcd is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
gf 6150se crash! oddhornedant NVIDIA Linux 2 05-05-12 06:30 AM
xvideo crash elanthis NVIDIA Linux 5 10-29-02 08:12 PM
Nview not starting?? can anyone please help? Cliff Pitt NVIDIA Windows Graphics Drivers 1 09-10-02 09:45 PM

All times are GMT -5. The time now is 08:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.