Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-02-03, 04:55 PM   #1
argm8e
Registered User
 
Join Date: May 2003
Posts: 4
Default trouble with agp on 7505 motherboards using RH 8/9 and 4349 NV drivers

I'm having trouble getting AGP activated on a 7505. I've read through related posts in a different thread (No AGP support for Quadro4 900 XGL on Dell 650?). The upshot of that thread seems to be that agpgart doesn't support the 7505 chipset, so we should be using NVAGP.

At this point, I have the Option "NvAGP" "1" in my XF86Config file, but glxinfo reports the renderer as "Quadro4 XGL/PCI/SSE2". The contents of /proc/driver/nvidia/agp files are:

status:
Disabled
card:
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: ....
host-bridge:
PCI device 8086:2550 (Intel Corp)
<other stuff like in the file 'card'>

The motherboard is a SuperMicro X5DAE, and I'm using a stock RH9 install (2.4.20-8bigmem kernel, but have also tried the SMP and UP
kernels).

The following is at the tail end of dmesg output:
mtrr: type mismatch for f0000000,8000000 old: uncachable new: write-combining
3: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4363 Sat Apr 19 17:46:46 PDT 2003
mtrr: type mismatch for e4000000,4000000 old: uncachable new: write-combining
3: nvidia: cannot write-combine 0xe4000000, 64M
mtrr: type mismatch for e4000000,4000000 old: uncachable new: write-combining
0: nvidia: cannot write-combine 0xe4000000, 64M
mtrr: type mismatch for e4000000,4000000 old: uncachable new: write-combining
3: nvidia: cannot write-combine 0xe4000000, 64M
3: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4363 Sat Apr 19 17:46:46 PDT 2003
mtrr: type mismatch for e4000000,4000000 old: uncachable new: write-combining
3: nvidia: cannot write-combine 0xe4000000, 64M

Thanks in advance for any pointers that will get me back on track to have AGP activated.

wes
__________________
Wes Bethel - R3vis Corporation
argm8e is offline   Reply With Quote
Old 05-03-03, 11:19 AM   #2
argm8e
Registered User
 
Join Date: May 2003
Posts: 4
Default

Some more data on this situation - a few weeks ago, the machine in question had 1GB of RAM, and AGP mode was working fine with the 4191 drivers and RH 8. Between then and now, I had to install more RAM to run some performance tests for a project. After the project was over, I tried out RH 9 and went back to RH 8 (a different story).

With 4GB of RAM, AGP mode will not work (RH 8 & RH 9), period. I pulled out 2GB of RAM, rebooted the machine and now AGP mode is working again (no changes to XF86Config).

This looks like a pretty harsh bug, but I'm not familiar enough with the innards of the kernel, XF86 or the NV drivers to know where to start finger-pointing. In the case of HPC scientific visualization, which is the application we're working on, having support for AGP with large amounts of memory is crucial.

thanks,
wes
__________________
Wes Bethel - R3vis Corporation
argm8e is offline   Reply With Quote
Old 05-04-03, 12:01 AM   #3
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

I'll try to reproduce this in house. Can you please also let linux-bugs@nvidia.com know about this?

Thanks!

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 05-06-03, 09:38 PM   #4
outabout
Registered User
 
Join Date: May 2003
Posts: 6
Default

Hi,

I have this problem also

We have Three dual Xenon 2.8Mhz with 4GB of memory and a Quadro4 900XGL on E7505 mother boards.
Running Redhat 8 2.4.18-27.8.0bigmem with nvidia driver NVIDIA-Linux-x86-1.0-4363.run

When cat /proc/driver/nvidia/agp/* we get
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x00000000
Host Bridge: PCI device 8086:2550 (Intel Corp.)
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f004217:0x00000000
Status: Disabled


Ie agp disabled.
And we get this error kernel: 0: nvidia: cannot write-combine 0xe0000000, 128M

Whe we run with only 2GB of memory AGP is fine.
And all works

Bye
Richard
outabout is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.