Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-07, 08:44 AM   #13
SirDice
Registered User
 
Join Date: Jul 2005
Posts: 79
Default Re: FreeBSD 7.0 Current with Xorg 7rc3 Modular and nvidia driver.

Do you have libGL installed? If so deinstall that port. LibGL and the nvidia-driver are mutually exclusive. They both do the same thing, X might be picking the libGL one instead of the nvidia one. Look at the logfile. I've attached mine so you can compare. GLcore should not be loaded. Only libglx and nvidia_drv should be loaded.

How did you install Xorg 7 btw? Did you use the instructions at http://wiki.freebsd.org/ModularXorg or did you do it by hand?
Attached Files
File Type: txt Xorg.0.log.txt (22.8 KB, 145 views)
SirDice is offline   Reply With Quote
Old 02-11-07, 09:03 AM   #14
roddierod
Registered User
 
Join Date: Sep 2005
Posts: 12
Default Re: FreeBSD 7.0 Current with Xorg 7rc3 Modular and nvidia driver.

libGL isn't installed I had to deinstall it to install nvidia although it doesn't look as if it was deinstall I do have a libGLu installed - not sure if that should be there.

Yes I followed the instruction from the wiki to install Xorg 7.

I'm going to triple check the libGL to see if it just unregistered the installation but not actually removed anything.

On a side note, it seems as though there are some issues with the patch and dual monitor usage, but I'll report those after I figure this one out to see if it stops those issues.
roddierod is offline   Reply With Quote
Old 02-11-07, 11:21 AM   #15
roddierod
Registered User
 
Join Date: Sep 2005
Posts: 12
Default Re: FreeBSD 7.0 Current with Xorg 7rc3 Modular and nvidia driver.

Well, I guess I'm just going to give up on GL.

I've removed libGLU and libGLw. Reinstalled the drive 3 or 4 times today and no matter what the nividia GL extension refuses to load.

It seemed to have loaded once according to the log, but then the X server just kept respawning...

Oh well maybe it will start working later.

Thanks for all the help...
roddierod is offline   Reply With Quote
Old 02-11-07, 12:03 PM   #16
SirDice
Registered User
 
Join Date: Jul 2005
Posts: 79
Default Re: FreeBSD 7.0 Current with Xorg 7rc3 Modular and nvidia driver.

If your portstree is up2date you'll see that the port is at version 1.0.9741_1 and it includes zander's patch. So you don't need to patch it by hand.

Quote:
- Add a patch by Christian Zander from nVidia that fixes crashes reported by
users on recent 6.X and -CURRENT systems. This applies to both versions,
9631 and 9746
http://www.freshports.org/x11/nvidia-driver/

LibGLU should be there btw. It's installed on my system.
SirDice is offline   Reply With Quote
Old 02-11-07, 04:47 PM   #17
roddierod
Registered User
 
Join Date: Sep 2005
Posts: 12
Default Re: FreeBSD 7.0 Current with Xorg 7rc3 Modular and nvidia driver.

well...good news and bad news....

I got the nvidia GL to load. But, it causes my X server to respawn so I can't use it. The re-spawning does not leave any errors anywhere so trying to figure this out seems tough.

Last edited by roddierod; 02-12-07 at 12:09 PM.
roddierod is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.