Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-23-06, 06:19 PM   #1
ColonelOops
Registered User
 
Join Date: Nov 2006
Posts: 3
Default 3D working but slow: AGP-Status disabled

I have two machines, one Duron 1600 with a Geforce 4 MX and another one with an AMD64 2GHz and a Geforce 6200, both Kubuntu Edgy and 1.0.9629.

The machine with the GF4 shows about 1300 fps with glxgears, the GF6 only 1100. That can't be right, right?

I noticed that AGP seems to be disabled on the GF6 machine:
Code:
# cat /proc/driver/nvidia/agp/status
Status:          Disabled

AGP initialization failed, please check the ouput
of the 'dmesg' command and/or your system log file
for additional information on this problem.
But it should be possible to enable it:
Code:
# cat /proc/driver/nvidia/agp/card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0xff000e1b:0x00000000
The GF4 machine shows this:
Code:
# cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        8x
Fast Writes:     Disabled
SBA:             Enabled
and:
Code:
# dmesg | grep -i agp
[17179590.820000] Linux agpgart interface v0.101 (c) Dave Jones
[17179590.832000] agpgart: Detected VIA KT400/KT400A/KT600 chipset
[17179590.840000] agpgart: AGP aperture is 64M @ 0xf8000000
[17179612.660000] agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
[17179612.660000] agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
[17179612.660000] agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
I think that my chipset is not recognized on the GF6 machine:
Code:
# dmesg | grep -i agp
[17179587.496000] Linux agpgart interface v0.101 (c) Dave Jones
Otherwise it should say something like: "agpgart: Detected VIA KT800 chipset", right?

I know that glxgears is not a proper benchmark, but the GF4 machine feels faster than the GF6 one playing UT2004.

Can anyone help me on this?

Cheers,
C.
ColonelOops is offline   Reply With Quote
Old 11-23-06, 08:55 PM   #2
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: 3D working but slow: AGP-Status disabled

well, your kernel does not have the necessary drivers.

Try an updated kernel for your distribution, go to their forums or open a bug about it.
energyman76b is offline   Reply With Quote
Old 11-24-06, 02:05 AM   #3
ColonelOops
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: 3D working but slow: AGP-Status disabled

It's the Kubuntu Edgy default kernel, there is no updated one
ColonelOops is offline   Reply With Quote
Old 11-24-06, 11:31 AM   #4
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: 3D working but slow: AGP-Status disabled

does it work, if you try to modprobe via-agp before starting X?
Or kill X, remove nvidia.ko, try modprobe via-agp and start X again?
energyman76b is offline   Reply With Quote
Old 11-24-06, 12:39 PM   #5
ColonelOops
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: 3D working but slow: AGP-Status disabled

No, that doesn't change anything.

I did a fresh edgy install on another harddrive, installed the latest Nvidia binary driver. Now I have AGP enabled (8x) and glxgears gives me about 1700 fps.

Is that OK? Still seems not very much to me compared to 1300 with a GF4.
Can anyone confirm this?
Is the Asus N6200 that slow?
I read about people posting scores around 5000 with a 6800 is that one that much faster or do I still have a problem?

Does anyone have a link to a page where all GF-cards are compared?
Because you can obviously not judge them by their numbers.
ColonelOops is offline   Reply With Quote
Old 11-24-06, 12:50 PM   #6
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: 3D working but slow: AGP-Status disabled

don't read to much into glxgears. It can only show you, if direct rendiring is working. Nothing else. Its fps are mostly dependent on the CPU, the X version, the windowmanager used...

type glxinfo and look for this:
direct rendering: Yes

and yes, the 6200 is slow.
energyman76b is offline   Reply With Quote
Old 02-15-07, 04:43 PM   #7
sumadartson
Registered User
 
Join Date: Feb 2007
Posts: 1
Default Re: 3D working but slow: AGP-Status disabled

The card's slow, but that slow is slower than the card is.

BTW, I have the exact same problem. No clue how to solve it.
sumadartson is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with configuring monitors and keeping them disabled with 302.17 Erosmith NVIDIA Linux 2 06-20-12 12:10 AM
Gainward GeForce4 Ti 4200 and overclocked AGP Prefect47 NVIDIA GeForce 7, 8, And 9 Series 6 09-16-02 03:50 PM
Gentoo and agp trouble john36 NVIDIA Linux 2 09-12-02 10:36 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM
Can't enable AGP mr_dinu NVIDIA Linux 7 07-31-02 02:32 AM

All times are GMT -5. The time now is 05:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.