Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-17-07, 05:37 AM   #1
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Mplayer NOT smooth on tv-out.

Hi,
I've a strange problem which is make me crazy.

If i play a movie using the output driver Xv and mplayer,
i get a very smooth playback on my first display device (CRT-0), but i get jerky motion if i play it on the Second One (TV-0, svideo).

If i use the output module GL it goes well, but you know, expecially for hdtv content, it requires a lot of cpu-power.

I've two separate X servers running on with no Xinerama, no twinview.
And, before you ask, i know composite is enabled in my xorg.conf, but i've no composite manager running on the secondary X server, also, disabling the composite option in xorg.conf makes no difference at all.
Aah, i remember the day i used overlay...

Please, help, Thanks.


(Gentoo 2.6 on amd64 venice 3200+ 7900GS)
Attached Files
File Type: log nvidia-bug-report.log (120.2 KB, 94 views)
File Type: txt .nvidia-settings-rc.txt (1.7 KB, 123 views)
kokoko3k is offline   Reply With Quote
Old 02-17-07, 06:46 AM   #2
Darkvater
Registered User
 
Join Date: Feb 2005
Posts: 57
Default Re: Mplayer NOT smooth on tv-out.

Perhaps unrelated but did you sync the refresh rate to your tv-out? My LCD is 60Hz the TV is 50Hz and if I don't set 'Sync to this display device' properly I get jerky playback on tv with tears and jumps.
Darkvater is offline   Reply With Quote
Old 02-17-07, 07:55 AM   #3
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: Mplayer NOT smooth on tv-out.

Thanks, here's my nvidia-settings:

Screen 0:


Screen 1:


...as you see, i cannot choose which display device to sync to (?).

The fun is that nothing changes (nor tears!) if i disable vsync from screen 0 or screen 1.
kokoko3k is offline   Reply With Quote
Old 02-20-07, 01:22 PM   #4
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: Mplayer NOT smooth on tv-out.

Quote:
Originally Posted by Darkvater
Perhaps unrelated but did you sync the refresh rate to your tv-out? My LCD is 60Hz the TV is 50Hz and if I don't set 'Sync to this display device' properly I get jerky playback on tv with tears and jumps.
Man you were right, it's nvidia-settings that doesn't work very well in loading settings, in fact if i open the gui and de/reselect all the voices it syncs fine...

But my ~/.nvidia-settings-rc is correct, i've:
Quote:
1/SyncToVBlank=1
1/XVideoTextureSyncToVBlank=1
1/XVideoBlitterSyncToVBlank=1
1/XVideoSyncToDisplay=256
And if i query them:
nvidia-settings -q all|grep -i Sync|grep Attribute
Quote:
Attribute 'SyncToVBlank' (klinux:0.0): 1.
Attribute 'XVideoTextureSyncToVBlank' (klinux:0.0): 1.
Attribute 'XVideoBlitterSyncToVBlank' (klinux:0.0): 1.
Attribute 'XVideoSyncToDisplay' (klinux:0.0): 0x00000001.
Attribute 'SyncToVBlank' (klinux:0.1): 1.
Attribute 'XVideoTextureSyncToVBlank' (klinux:0.1): 1.
Attribute 'XVideoBlitterSyncToVBlank' (klinux:0.1): 1.
Attribute 'XVideoSyncToDisplay' (klinux:0.1): 0x00000100.
...which should be correct too, but something has no effect on TV-0 (:0.1)

So i added:
Quote:
nvidia-settings -a :0.1/XVideoSyncToDisplay=256
nvidia-settings -a :0.1/XVideoTextureSyncToVBlank=1
nvidia-settings -a :0.1/XVideoBlitterSyncToVBlank=1
to my ~/.kde/Autostart/nvidia.sh
...And now everything 'seems' to work

Hope this will help someone.
kokoko3k is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 04:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.