Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-09-07, 06:16 PM   #1
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Multiseat problem

I'm trying to get a working multiseat, but I can't launch second configuration (seat1).

http://en.wikipedia.org/wiki/Multiseat

Xorg log and config attached. What is wrong?

Last edited by kriko; 05-31-11 at 01:35 PM.
kriko is offline   Reply With Quote
Old 03-10-07, 03:52 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Multiseat problem

What you want is not possible using a single videocard. You would need two Xservers both with their own videocard (a single card can't be used in two X servers).
Thunderbird is offline   Reply With Quote
Old 03-10-07, 05:47 AM   #3
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Multiseat problem

Ok, thanks. I'll try with to add an old sis (or s3).
kriko is offline   Reply With Quote
Old 03-10-07, 07:05 AM   #4
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Multiseat problem

I added one graphic card more.
Seat 0 works, but seat 1 doesn't. When I try to launch seat1 I get an error about missing screen 0.

Also I get a warning about no device at 02:10 PCI bus, but according to lspci it is correct:

Code:
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600/GeForce 6600 GT] (rev a2)
02:0a.0 VGA compatible controller: S3 Inc. ViRGE/DX or /GX (rev 01)
I rechecked xorg many times, but I cannot find problem.

Last edited by kriko; 05-31-11 at 01:35 PM.
kriko is offline   Reply With Quote
Old 03-10-07, 07:42 AM   #5
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Multiseat problem

Quote:
Originally Posted by Thunderbird
What you want is not possible using a single videocard. You would need two Xservers both with their own videocard (a single card can't be used in two X servers).
That is not really true. It can be done with Xephyr.
pe1chl is offline   Reply With Quote
Old 03-10-07, 08:08 AM   #6
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Multiseat problem

Xephyr? I'll take a look at it.

Edit:
On this how-to http://en.wikibooks.org/wiki/Multite..._configuration its described how to do this with two video cards. pe1chl, do you know how to do this with one card? I have geforce 6600 gt with dvi and vga connector.
kriko is offline   Reply With Quote
Old 03-10-07, 08:43 AM   #7
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Multiseat problem

The configuration will be very similar to that example, except the BusID lines for the different device sections are the same (and have the PCI ID of your video card), and you have one device section with "Screen 0" and the other with "Screen 1".
You can also add the "UseDisplayDevice" option to make sure the correct device section talks to the correct output.
Like this:

Section "Device"
BoardName "GeForce 6600 GT/AGP/SSE2"
VendorName "NVidia"
BusID "1:0:0"
Driver "nvidia"
Identifier "Video Card 1"
Option "UseDisplayDevice" "DFP-0"
Screen 0
EndSection

Section "Device"
BoardName "GeForce 6600 GT/AGP/SSE2"
VendorName "NVidia"
BusID "1:0:0"
Driver "nvidia"
Identifier "Video Card 2"
Option "UseDisplayDevice" "CRT-1"
Screen 1
EndSection
pe1chl is offline   Reply With Quote
Old 03-10-07, 10:22 AM   #8
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Multiseat problem

I didn't mention Xephyr because I don't see that as a real solution. You lose real hardware acceleration and extensions like GLX in the Xephyr display.
Thunderbird is offline   Reply With Quote

Old 03-10-07, 10:44 AM   #9
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Multiseat problem

@Thunderbird: You loose also basic opengl acceleration? All I need is acelleration on primary monitor. The second one will be for internet browsing and stuff.

pe1chl, thanks! I'll try that after a while.
kriko is offline   Reply With Quote
Old 03-10-07, 11:51 AM   #10
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Multiseat problem

Launching seat0, alltogether works. How can I start kde (startx) from console to use different credentials (different users) and different screens?
kriko is offline   Reply With Quote
Old 03-11-07, 04:54 AM   #11
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Multiseat problem

Quote:
Originally Posted by kriko
Launching seat0, alltogether works. How can I start kde (startx) from console to use different credentials (different users) and different screens?
Of course you need to configure the X display manager to start a login on all your different Xephyr instances.
This is the GDM part of the instructions you referred to.
It can also be a matter of editing /etc/X11/xdm/Xservers
This is also required to associate the different keyboard and mouses with the correct screen.

(not really related to the NVIDIA driver)
pe1chl is offline   Reply With Quote
Old 03-11-07, 05:30 AM   #12
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Multiseat problem

Mouse, keyboards are already correctly assigned to right screen, the problem is kdm, I cannot get it work right. One screen works, one is blank, I'll try with gdm (I saw there are more instructions for gdm on google).
kriko is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem connecting Pioneer VSX-S300 to Nvidia Ion - flat panel scaling solves it? wild_oscar NVIDIA Linux 3 06-17-12 07:18 AM
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
Ti4200 and Linux Install Problem ultrajava NVIDIA Linux 5 09-28-02 08:13 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 04:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.