Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-07, 05:49 AM   #1
quovadisza
Registered User
 
Join Date: Apr 2007
Posts: 2
Question 2x Nvidia Cards and Xorg Problem

Hi All

Operating System: OpenSuse 10.2
Graphics Cards: nVidia Quadro NVS 440 (256MB) PCIE 1x and nVidia Geforce 6500 (128MB) PCIE

Background: I have 6 LCD monitors (1,2,3,4,5,6) connected via Geforce PCI1:0:0 (1,2) and NVS 440 PCI4:0:0(3,4) and NVS 440 PCI5:0:0 (5,6).

I can get 1,2,3,4 operating under X but not all 6 simultaneously.

I keep on getting NVIDIA: could not open the device file /dev/nvidia2 (Input/Output error). However if i remove the Geforce from the xorg.conf file then 3,4,5,6 operate together.

I've double checked the existence and permissions of the /dev/nvidia2 and it does exist as well as trying various nvidia utilities and reinstallation of drivers.

It would appear that if the Geforce card is initialized then only ONE GPU of the NVS440 will initialize and the next will fail.

Any ideas?

I've attached the log files as needed.

Thanks
Attached Files
File Type: zip nvidia-bug-report.zip (28.6 KB, 106 views)
quovadisza is offline   Reply With Quote
Old 04-17-07, 10:40 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 2x Nvidia Cards and Xorg Problem

In your bug report I see:
allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
NVRM: RmInitAdapter failed! (0x23:0xffffffff:679)
NVRM: rm_init_adapter(2) failed

This issue is discussed in the driver README.
netllama is offline   Reply With Quote
Old 04-18-07, 01:18 AM   #3
quovadisza
Registered User
 
Join Date: Apr 2007
Posts: 2
Default Re: 2x Nvidia Cards and Xorg Problem

Thank you so much - that solved the problem!
quovadisza is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04 PenguinPower NVIDIA Linux 93 09-08-12 01:49 AM

All times are GMT -5. The time now is 03:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.