Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-20-07, 11:40 PM   #1
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Question Upgrade lots of packages today in Debian v4, and startx doesn't work.

Hi all!

I do apt-get upgrade and dist-ugprade daily on my Debian system. Today, it seem to have broken my X. I recall having like 90 MB of updates, a couple xorg packages (don't remember which ones), etc. I wished apt-get had a history of what it installed and stuff.

cat /var/log/messages (was recompiling and retrying) showed these NVIDIA stuff:
Apr 20 20:32:12 localhost kernel: NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007
Apr 20 20:43:04 localhost kernel: NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007
Apr 20 21:02:14 localhost kernel: NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9746 Fri Dec 15 09:54:45 PST 2006
Apr 20 21:12:09 localhost kernel: NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007

dmesg showed these NVIDIA lines (was recompiling drivers and retesting):
NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007
NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007
NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9746 Fri Dec 15 09:54:45 PST 2006
NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007

Attached are my Xorg logs and my configuration. For now, I will just use the slow poke nv driver which works but sucky. Also, I never had this problem in the past.

I am at a loss on what's the problem is. Any ideas? Thank you in advance.
Attached Files
File Type: log nvidia-installer.log (29.4 KB, 81 views)
File Type: log Xorg.0.log (12.9 KB, 84 views)
File Type: txt xorg.conf.txt (1.6 KB, 72 views)
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 04-21-07, 12:03 AM   #2
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Question Additional information if they help.

I am still puzzled. More information if they help at all. Based on http://us.download.nvidia.com/XFree8...ppendix-c.html ...

# ls -all /usr/X11R6/lib/modules/drivers/nvidia_drv.so
-rwxr-xr-x 1 root root 1396712 Apr 20 21:12 /usr/X11R6/lib/modules/drivers/nvidia_drv.so

# ls -all /usr/X11R6/lib/modules/extensions/libglx.so*
lrwxrwxrwx 1 root root 18 Apr 20 21:12 /usr/X11R6/lib/modules/extensions/libglx.so -> libglx.so.1.0.9755
-rwxr-xr-x 1 root root 691852 Apr 20 21:12 /usr/X11R6/lib/modules/extensions/libglx.so.1.0.9755

# ls -all /usr/X11R6/lib/modules/libnvidia-wfb.so*
lrwxrwxrwx 1 root root 25 Apr 20 21:12 /usr/X11R6/lib/modules/libnvidia-wfb.so.1 -> libnvidia-wfb.so.1.0.9755
-rwxr-xr-x 1 root root 279508 Apr 20 21:12 /usr/X11R6/lib/modules/libnvidia-wfb.so.1.0.9755

# ls -all /usr/X11R6/lib/modules/libwfb.so*
lrwxrwxrwx 1 root root 18 Apr 20 21:12 /usr/X11R6/lib/modules/libwfb.so -> libnvidia-wfb.so.1

# ls -all /usr/lib/libGL.so*
lrwxrwxrwx 1 root root 10 Apr 20 21:12 /usr/lib/libGL.so -> libGL.so.1
lrwxrwxrwx 1 root root 17 Apr 20 21:12 /usr/lib/libGL.so.1 -> libGL.so.1.0.9755
-rwxr-xr-x 1 root root 601720 Apr 20 21:12 /usr/lib/libGL.so.1.0.9755

# ls -all /usr/lib/libGLcore.so*
lrwxrwxrwx 1 root root 21 Apr 20 21:12 /usr/lib/libGLcore.so.1 -> libGLcore.so.1.0.9755
-rwxr-xr-x 1 root root 9918780 Apr 20 21:12 /usr/lib/libGLcore.so.1.0.9755

# ls -all /usr/X11R6/lib/libXvMCNVIDIA*
-r--r--r-- 1 root root 193966 Apr 20 21:12 /usr/X11R6/lib/libXvMCNVIDIA.a
-rwxr-xr-x 1 root root 178924 Apr 20 21:12 /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.9755
lrwxrwxrwx 1 root root 25 Apr 20 21:12 /usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1 -> libXvMCNVIDIA.so.1.0.9755

# ls -all /usr/X11R6/lib/libXvMCNVIDIA.so*
-rwxr-xr-x 1 root root 178924 Apr 20 21:12 /usr/X11R6/lib/libXvMCNVIDIA.so.1.0.9755

PROBLEM?
# ls -all /lib/modules/`uname -r`/video/nvidia.o
ls: /lib/modules/2.6.18-4-k7/video/nvidia.o: No such file or directory
# ls -all /lib/modules/`uname -r`/kernel/drivers/video/nvidia.o
ls: /lib/modules/2.6.18-4-k7/kernel/drivers/video/nvidia.o: No such file or directory

# ls -all /usr/include/GL/gl.h; ls -all /usr/include/GL/glext.h ; ls -all /usr/include/GL/glx.h ; ls -all /usr/include/GL/glext.h
-r--r--r-- 1 root root 72949 Apr 20 21:12 /usr/include/GL/gl.h
-r--r--r-- 1 root root 371483 Apr 20 21:12 /usr/include/GL/glext.h
-r--r--r-- 1 root root 14021 Apr 20 21:12 /usr/include/GL/glx.h
-r--r--r-- 1 root root 371483 Apr 20 21:12 /usr/include/GL/glext.h

# ls -all /usr/share/doc/NVIDIA_GLX-1.0/include/GL/
total 500
drwxr-xr-x 2 root root 4096 Apr 20 21:12 .
drwxr-xr-x 3 root root 4096 Jun 5 2005 ..
-r--r--r-- 1 root root 72949 Apr 20 21:12 gl.h
-r--r--r-- 1 root root 371483 Apr 20 21:12 glext.h
-r--r--r-- 1 root root 14021 Apr 20 21:12 glx.h
-r--r--r-- 1 root root 32000 Apr 20 21:12 glxext.h

# ls -all /usr/lib/libnvidia-tls.so* ; ls -all /usr/lib/tls/libnvidia-tls.so*
lrwxrwxrwx 1 root root 25 Apr 20 21:12 /usr/lib/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.9755
-rwxr-xr-x 1 root root 2352 Apr 20 21:12 /usr/lib/libnvidia-tls.so.1.0.9755
lrwxrwxrwx 1 root root 25 Apr 20 21:12 /usr/lib/tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.9755
-rwxr-xr-x 1 root root 2324 Apr 20 21:12 /usr/lib/tls/libnvidia-tls.so.1.0.9755

# ldd /usr/X11R6/bin/glxgears
linux-gate.so.1 => (0xffffe000)
libGL.so.1 => /usr/lib/libGL.so.1 (0xb7ed2000)
libc.so.6 => /lib/libc.so.6 (0xb7d91000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7ca5000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0xb7332000)
libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0xb7330000)
libm.so.6 => /lib/libm.so.6 (0xb730a000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xb72fc000)
libdl.so.2 => /lib/libdl.so.2 (0xb72f8000)
/lib/ld-linux.so.2 (0xb7f7c000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb72f5000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb72ef000)
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 04-21-07, 01:00 AM   #3
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Question Fixed, but...

I discovered http://www.nvnews.net/vbulletin/showthread.php?t=72490 but didn't think it would work (doesn't make any sense), but it did:

sh NVIDIA-Linux-version.run --x-module-path=`X -showDefaultModulePath 2>&1 | cut -d, -f1` --x-library-path=`X -showDefaultLibPath 2>&1`


$ dpkg -l | grep ^ii |grep xorg
ii libglu1-xorg-dev 7.1.0-18 transitional package for Debian etch
ii xorg 7.1.0-18 X.Org X Window System
ii xorg-dev 7.1.0-18 the X.Org X Window System development librar
ii xserver-xorg 7.1.0-18 the X.Org X server
ii xserver-xorg-core 1.3.0.0.dfsg-1 X.Org X server -- core server
ii xserver-xorg-dev 1.3.0.0.dfsg-1 X.Org X server -- development files
ii xserver-xorg-input-all 7.1.0-18 the X.Org X server -- input driver metapacka
ii xserver-xorg-input-evdev 1.1.2-6 X.Org X server -- evdev input driver
ii xserver-xorg-input-kbd 1.1.0-4 X.Org X server -- keyboard input driver
ii xserver-xorg-input-mouse 1.1.1-3 X.Org X server -- mouse input driver
ii xserver-xorg-input-synaptics 0.14.6-1 Synaptics TouchPad driver for X.Org/XFree86
ii xserver-xorg-input-wacom 0.7.4.1-6 X.Org X server -- wacom input driver
ii xserver-xorg-video-all 7.1.0-18 the X.Org X server -- output driver metapack
ii xserver-xorg-video-apm 1.1.1-3 X.Org X server -- APM display driver
ii xserver-xorg-video-ark 0.6.0-3 X.Org X server -- ark display driver
ii xserver-xorg-video-ati 6.6.3-2 X.Org X server -- ATI display driver
ii xserver-xorg-video-chips 1.1.1-4 X.Org X server -- Chips display driver
ii xserver-xorg-video-cirrus 1.1.0-3 X.Org X server -- Cirrus display driver
ii xserver-xorg-video-cyrix 1.1.0-4 X.Org X server -- Cyrix display driver
ii xserver-xorg-video-dummy 0.2.0-3 X.Org X server -- dummy display driver
ii xserver-xorg-video-fbdev 0.3.1-1 X.Org X server -- fbdev display driver
ii xserver-xorg-video-glint 1.1.1-3 X.Org X server -- Glint display driver
ii xserver-xorg-video-i128 1.2.0-3 X.Org X server -- i128 display driver
ii xserver-xorg-video-i740 1.1.0-3 X.Org X server -- i740 display driver
ii xserver-xorg-video-i810 2.0.0-1 X.Org X server -- Intel i8xx, i9xx display d
ii xserver-xorg-video-imstt 1.1.0-3 X.Org X server -- IMSTT display driver
ii xserver-xorg-video-intel 2.0.0-1 X.Org X server -- Intel i8xx, i9xx display d
ii xserver-xorg-video-mga 1.4.4.dfsg.1-2 X.Org X server -- MGA display driver
ii xserver-xorg-video-neomagic 1.1.1-5 X.Org X server -- Neomagic display driver
ii xserver-xorg-video-newport 0.2.0-3 X.Org X server -- Newport display driver
ii xserver-xorg-video-nsc 2.8.1-3 X.Org X server -- NSC display driver
ii xserver-xorg-video-nv 2.0.2-1 X.Org X server -- NV display driver
ii xserver-xorg-video-rendition 4.1.0.dfsg.1-4 X.Org X server -- Rendition display driver
ii xserver-xorg-video-s3 0.4.1-5 X.Org X server -- legacy S3 display driver
ii xserver-xorg-video-s3virge 1.9.1-3 X.Org X server -- S3 ViRGE display driver
ii xserver-xorg-video-savage 2.1.2-3 X.Org X server -- Savage display driver
ii xserver-xorg-video-siliconmotion 1.4.1-4 X.Org X server -- SiliconMotion display driv
ii xserver-xorg-video-sis 0.9.1-4 X.Org X server -- SiS display driver
ii xserver-xorg-video-sisusb 0.8.1-3 X.Org X server -- SiS USB display driver
ii xserver-xorg-video-tdfx 1.3.0-1 X.Org X server -- tdfx display driver
ii xserver-xorg-video-tga 1.1.0-3 X.Org X server -- TGA display driver
ii xserver-xorg-video-trident 1.2.3-1 X.Org X server -- Trident display driver
ii xserver-xorg-video-tseng 1.1.0-3 X.Org X server -- Tseng display driver
ii xserver-xorg-video-v4l 0.1.1-3 X.Org X server -- Video 4 Linux display driv
ii xserver-xorg-video-vesa 1.3.0-1 X.Org X server -- VESA display driver
ii xserver-xorg-video-vga 4.1.0-3 X.Org X server -- VGA display driver
ii xserver-xorg-video-via 0.2.1-6 X.Org X server -- VIA display driver
ii xserver-xorg-video-vmware 10.13.0-3 X.Org X server -- VMware display driver
ii xserver-xorg-video-voodoo 1.1.0-4 X.Org X server -- Voodoo display driver


The link said, "The 1.3 series of the X.org server has a bug where the version reported changed from 7.2.* to 1.*." Is NVIDIA installer confused with xserver-xorg-dev and xserver-xorg-core packages that say v1.3.0.0.dfsg-1? I am trying to understand the confusion. Also, will I have to do this workaround for future NVIDIA driver releases or will this issue be fixed?

Thank you in advance.
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 04-21-07, 01:28 AM   #4
gfxdrone
Registered User
 
Join Date: Feb 2007
Posts: 74
Default Re: Upgrade lots of packages today in Debian v4, and startx doesn't work.

sh NVIDIA-Linux-version.run --x-module-path=/usr/lib/xorg/modules --x-library-path=/usr/lib

will do it for any version of xorg. That's what we're using for debian sid, and we didn't see any problem at all when the xserver-xorg-core (1.3) stuff came in today.

Even the new beta installed with no problems at all.

Everything is also running on the new 2.6.21-rc stuff, no problems. Unlike ATI, whose drivers have completely failed now, they currently have no driver that works with this xorg 1.3 identifier. Zero.
gfxdrone is offline   Reply With Quote
Old 04-21-07, 01:34 AM   #5
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Question Re: Upgrade lots of packages today in Debian v4, and startx doesn't work.

Quote:
Originally Posted by gfxdrone
sh NVIDIA-Linux-version.run --x-module-path=/usr/lib/xorg/modules --x-library-path=/usr/lib

will do it for any version of xorg. That's what we're using for debian sid, and we didn't see any problem at all when the xserver-xorg-core (1.3) stuff came in today.

Even the new beta installed with no problems at all.

Everything is also running on the new 2.6.21-rc stuff, no problems. Unlike ATI, whose drivers have completely failed now, they currently have no driver that works with this xorg 1.3 identifier. Zero.
Ahh. So are you saying I don't need this workaround for the beta driver that came out today? If so, then is it stable enough? I rarely use beta drivers.
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 04-21-07, 01:37 AM   #6
gfxdrone
Registered User
 
Join Date: Feb 2007
Posts: 74
Default Re: Upgrade lots of packages today in Debian v4, and startx doesn't work.

No, I'm saying that's the syntax we are using for all driver installs, including the beta 100.xx that came out today. I'm running those betas now, as are many other testers today, no problems. Nobody else has reported issues either.
gfxdrone is offline   Reply With Quote
Old 04-21-07, 01:50 AM   #7
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Default Re: Upgrade lots of packages today in Debian v4, and startx doesn't work.

Quote:
Originally Posted by gfxdrone
No, I'm saying that's the syntax we are using for all driver installs, including the beta 100.xx that came out today. I'm running those betas now, as are many other testers today, no problems. Nobody else has reported issues either.
I just downloaded, compiled, installed, and installed the beta 100 driver that came out today. I didn't have to do anything fancy to compile and install. Thanks.
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Old 04-21-07, 02:58 AM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Upgrade lots of packages today in Debian v4, and startx doesn't work.

The beta driver has a workaround for that problem, so no extra options should be needed. 1.0-7185 has the same workaround.
AaronP is offline   Reply With Quote

Old 04-21-07, 04:43 AM   #9
ant
A GeForced Ant
 
ant's Avatar
 
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Default Re: Upgrade lots of packages today in Debian v4, and startx doesn't work.

Quote:
Originally Posted by AaronP
The beta driver has a workaround for that problem, so no extra options should be needed. 1.0-7185 has the same workaround.
Thank you.
__________________
Ant @ The Ant Farm (http://antfarm.ma.cx) and Ant's Quality Foraged Links (http://aqfl.net).
ant is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.