Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-26-07, 01:38 AM   #1
scatterlined
Guest
 
Posts: n/a
Default 9631 kernel module will not load in Feisty

I tried to install 9631 for my NV18 [GeForce4 MX - nForce GPU] under Ubuntu Feisty Fawn (2.6.20-15-generic). The install appears to complete okay, but running X fails. When I try to use 'modprobe -v nvidia' to load the kernel module it gives me the error:
install /sbin/lrm-video nvidia
FATAL: Error running install command for nvidia

Does anyone else have 9631 working with 2.6.20-15-generic?

Any ideas? I had the same hardware working under Edgy Eft, although I used the envy script to run the nvidia install for me (it doesn't work for me under Feisty).

I have attached my nvidia-bug-report.log

Thanks.
Attached Files
File Type: log nvidia-bug-report.log (111.4 KB, 179 views)
  Reply With Quote
Old 04-26-07, 03:49 AM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: 9631 kernel module will not load in Feisty

I found Ubuntu FF's nvidia-glx package installed version 9631 and it works quite well, just had to edit xorg.conf. Two ways to install nvidia drivers: the nvidia way or the distro way. Pros and cons each way, but don't mix them.
whig is offline   Reply With Quote
Old 04-26-07, 07:22 AM   #3
richo123
Registered User
 
Join Date: Jul 2005
Posts: 17
Default Re: 9631 kernel module will not load in Feisty

You have a number of references to the 9755 driver in your log suggesting that you may have used the nvidia-glx-new package at one stage. This has a bug in it because it dumps a flag file in /lib/linux-restricted-modules called .nvidia_new_installed

this flag file tells /sbin/lrm-video to load the 9755 driver. When this package is removed it does not remove the flag file hence the bug. If it exists on your system delete that file

i.e. /lib/linux-restricted-modules/.nvidia_new_installed

and reboot
richo123 is offline   Reply With Quote
Old 04-26-07, 04:41 PM   #4
scatterlined
Guest
 
Posts: n/a
Default Re: 9631 kernel module will not load in Feisty

Quote:
Originally Posted by richo123
If it exists on your system delete that file

i.e. /lib/linux-restricted-modules/.nvidia_new_installed

and reboot
Richo123, I owe you a beer. Upon removing the file, everything worked as expected. Thank you so much for your help!
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM

All times are GMT -5. The time now is 07:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.