Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-07, 06:08 PM   #1
x37v
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Quadro FX 3400 SLI Linux Stereo at 100Hz

I've been trying for a while to get my quadro fx 3400 SLI to run at 100Hz and
be in stereo [crystal glasses]. I cannot seem to get it to do either.
It is always running at 60hz. I need 100Hz for this projector I'm trying to
drive [a Christie Mirage S*2k].

Has anyone had success doing stereo with this (or a similar) card with linux
(and/or 100hz refresh rate?) Care to share your X config?

Thanks,
Alex Norman
x37v is offline   Reply With Quote
Old 04-17-07, 06:13 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Quadro FX 3400 SLI Linux Stereo at 100Hz

You'll need to generate a custom modeline to drive the projector at 100Hz.
netllama is offline   Reply With Quote
Old 04-19-07, 11:45 AM   #3
x37v
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Re: Quadro FX 3400 SLI Linux Stereo at 100Hz

can someone help me out with the modeline, i've tried one online generator and also tried an on line list of modlines with no luck, the last one i tired was:
# 1280x1024 @ 100Hz hsync: 108.5kHz
Modeline "1280x1024" 190.96 1280 1376 1520 1760 1024 1025 1028 1085 +hsync +vsync

thanks,
alex
x37v is offline   Reply With Quote
Old 04-19-07, 11:51 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Quadro FX 3400 SLI Linux Stereo at 100Hz

What does "no luck" mean?

Please start X with the following command:
startx -- -logverbose 6

and then generate and provide an nvidia-bug-report.log
netllama is offline   Reply With Quote
Old 04-23-07, 12:44 PM   #5
x37v
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Re: Quadro FX 3400 SLI Linux Stereo at 100Hz

oops, i got the refresh rate working, but stereo isn't working, i'm including my xorg.conf

I've got my xorg log down there too.

I'm trying to do "crystal eyes" stereo (stereo mode 3)

thanks for any help you can give,
Alex Norman

---

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Nvidia QudroFX 3400 SLI"
Driver "nvidia"
BusID "PCI:10:0:0"
Option "Stereo" "3"
Option "AllowDFPStereo" "True"
Option "NoFlip" "False"
Option "NoLogo" "True"
Option "PerformanceMonitorMode" "1"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Monitor"
Identifier "Christie Mirage S*2k"
Option "DPMS"
HorizSync 28-110
VertRefresh 43-110
# 1280x1024 @ 100Hz hsync: 108.5kHz
Modeline "1280x1024" 190.96 1280 1376 1520 1760 1024 1025 1028 1085 +hsync +vsync
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Nvidia QudroFX 3400 SLI"
Monitor "Christie Mirage S*2k"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
#Modes "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

--------

/var/log/Xorg.0.log (snipped)

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoFlip" "False"
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "Stereo" "3"
(**) NVIDIA(0): Option "AllowDFPStereo" "True"
(**) NVIDIA(0): Option "PerformanceMonitorMode" "1"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Onboard stereo requested (DIN connector)
(**) NVIDIA(0): Enabling RENDER acceleration
(WW) NVIDIA(0): Unable to read EDID for display device CRT-0
(II) NVIDIA(0): NVIDIA GPU Quadro FX 3400 at PCI:10:0:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.40.02.35.05
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on Quadro FX 3400 at PCI:10:0:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x1024"
(II) NVIDIA(0): "1024x768"
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(++) NVIDIA(0): DPI set to (100, 100); computed from -dpi X commandline option
(WW) NVIDIA(0): 32-bit ARGB GLX visuals require the Composite extension.
(II) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xf1000000 - 0xf1ffffff (0x1000000) MX[b]
[1] 0 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b]
[2] 0 0 0xf0000000 - 0xf0ffffff (0x1000000) MX[b]
[3] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[4] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[5] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[6] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[7] -1 0 0xf2000000 - 0xf2003fff (0x4000) MX[b]
[8] -1 0 0xf2004000 - 0xf20047ff (0x800) MX[b]
[9] -1 0 0xf2104000 - 0xf2104fff (0x1000) MX[b]
[10] -1 0 0xf2103000 - 0xf2103fff (0x1000) MX[b]
[11] -1 0 0xf2102000 - 0xf2102fff (0x1000) MX[b]
[12] -1 0 0xf2101000 - 0xf2101fff (0x1000) MX[b]
[13] -1 0 0xfebf0000 - 0xfebf00ff (0x100) MX[b]
[14] -1 0 0xf2100000 - 0xf2100fff (0x1000) MX[b]
[15] -1 0 0xf1000000 - 0xf1ffffff (0x1000000) MX[b](B)
[16] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[17] -1 0 0xf0000000 - 0xf0ffffff (0x1000000) MX[b](B)
[18] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b](OprD)
[19] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b](OprD)
[20] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b](OprD)
[21] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[22] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[23] -1 0 0x000028f0 - 0x000028f7 (0x8) IX[b]
[24] -1 0 0x000028c0 - 0x000028cf (0x10) IX[b]
[25] -1 0 0x00002c04 - 0x00002c07 (0x4) IX[b]
[26] -1 0 0x000028e8 - 0x000028ef (0x8) IX[b]
[27] -1 0 0x00002c00 - 0x00002c03 (0x4) IX[b]
[28] -1 0 0x000028e0 - 0x000028e7 (0x8) IX[b]
[29] -1 0 0x000028b0 - 0x000028bf (0x10) IX[b]
[30] -1 0 0x000028fc - 0x000028ff (0x4) IX[b]
[31] -1 0 0x000028d8 - 0x000028df (0x8) IX[b]
[32] -1 0 0x000028f8 - 0x000028fb (0x4) IX[b]
[33] -1 0 0x000028d0 - 0x000028d7 (0x8) IX[b]
[34] -1 0 0x000028a0 - 0x000028af (0x10) IX[b]
[35] -1 0 0x00002400 - 0x000024ff (0x100) IX[b]
[36] -1 0 0x00002000 - 0x000020ff (0x100) IX[b]
[37] -1 0 0x00002840 - 0x0000287f (0x40) IX[b]
[38] -1 0 0x00002800 - 0x0000283f (0x40) IX[b]
[39] -1 0 0x00002880 - 0x0000289f (0x20) IX[b]
[40] -1 0 0x0000fb00 - 0x0000fb00 (0x1) IX[b]
[41] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b](OprU)
[42] 0 0 0x000003c0 - 0x000003df (0x20) IS[b](OprU)
(II) NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX
error opening security policy file /usr/lib/xserver/SecurityPolicy
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Generic Keyboard: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Generic Keyboard: XkbLayout: "us"
(**) Option "XkbOptions" "lv3:ralt_switch"
(**) Generic Keyboard: XkbOptions: "lv3:ralt_switch"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ExplorerPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ExplorerPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(==) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
xkb_keycodes { include "xfree86+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compatibility { include "complete" };
xkb_symbols { include "pc(pc105)+us+level3(ralt_switch)" };
xkb_geometry { include "pc(pc105)" };
(II) Configured Mouse: ps2EnableDataReporting: succeeded
Could not init font path element /usr/share/fonts/X11/TTF/, removing from list!
Could not init font path element /usr/share/fonts/X11/OTF, removing from list!
Could not init font path element /usr/share/fonts/X11/CID/, removing from list!
x37v is offline   Reply With Quote
Old 04-23-07, 04:24 PM   #6
x37v
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Re: Quadro FX 3400 SLI Linux Stereo at 100Hz

oh, btw, here is my nvidia-bug-report.log
Attached Files
File Type: log nvidia-bug-report.log (99.2 KB, 94 views)
x37v is offline   Reply With Quote
Old 04-23-07, 08:54 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Quadro FX 3400 SLI Linux Stereo at 100Hz

What does "stereo isn't working" mean?

Also, 1.0-8776 is no longer supported. Please retest with 1.0-9755 or 100.14.03.
netllama is offline   Reply With Quote
Old 04-27-07, 11:19 AM   #8
x37v
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Re: Quadro FX 3400 SLI Linux Stereo at 100Hz

okay, i got stereo working at 100hz now, i upgraded to 1.0-9755 and it worked with the xorg.conf that i posted earlier. i have crystal glasses and now when i run an app that supports this type of stereo i can see stereo when i use these glasses. I was using the older driver because it is what came with my distro (ubuntu).

thanks
x37v is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Choosing The Right GPU To Take Adobe Workflows To The Max News Archived News Items 0 05-29-12 05:40 PM
Best Linux driver for Quadro FX2700M dclement NVIDIA Linux 0 05-07-12 06:58 AM
_which_ quadro cards have stereo support under driver 3123 codingfrenzy NVIDIA Linux 3 12-29-02 03:24 PM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM

All times are GMT -5. The time now is 10:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.