Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-21-07, 04:09 AM   #1
declan
Registered User
 
Join Date: Apr 2007
Posts: 2
Default Opensuse 10.2 NVIDIA driver problem with Geforce 7900 GS card

Hi,

I've searched exhaustively through other threads but to no avail. I've got a new AMD system with the following configuration

AMD ATHLON 4200+Dual Core AM2
Asus nForce AM2 ATX Motherboard
Silicon Power 2GB DDR2 800 Ram
Seagate 320GB 7200RPM SATA2 16MB HDD
Liteon 18X Dual DVDRW 8X D-Layer18A1P DVD Writer
Foxconn TSAA909 Case
7900GS 256MB Video Card
OpenSuse 10.2 (32 bit)

I tried installing the nvidia drivers using "The Easy Way" following the instructions on the following opensuse 10.2 wiki http://en.opensuse.org/NVIDIA

Then I installed opensuse's xgl settings available here http://www.kde-apps.org/content/show...?content=51201

To enable xgl I ran "gnome-xgl-switch --enable-xgl" (which should also work from KDE, which I am using).

Then I rebooted my machine; excited at the prospect of seeing this ***cube*** that everyone's on about...

Sadly, it never booted into a GUI, instead leaving me a command prompt to login to. When I hit Alt-F10 to get to the interesting error message it said the following

**************************
Mar 4 22:57:07 desktop kernel: nvidia: module license 'NVIDIA' taints kernel.
Mar 4 22:57:08 desktop kernel: NVRM: The NVIDIA probe routine was not called for 1 device(s).
Mar 4 22:57:08 desktop kernel: NVRM: This can occur when a driver such as rivafb, nvidiafb or
Mar 4 22:57:08 desktop kernel: NVRM: rivatv was loaded and obtained ownership of the NVIDIA
Mar 4 22:57:08 desktop kernel: NVRM: device(s).
Mar 4 22:57:08 desktop kernel: NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
Mar 4 22:57:08 desktop kernel: NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
Mar 4 22:57:08 desktop kernel: NVRM: support), then try loading the NVIDIA kernel module again.
Mar 4 22:57:08 desktop kernel: NVRM: No NVIDIA graphics adapter probed!
Mar 4 22:57:08 desktop kdm[3421]: X server died during startup
Mar 4 22:57:08 desktop kdm[3421]: X server for display :0 can't be started, session disabled
**************************

Here's some other things I've looked at. When I perform "lsmod |grep -i nv" I don't get any listing for anything to do with nvidia, only

**************************
sata_nv 15492 3
libata 119444 1 stat_nv
**************************

When I perform "lsmod |grep -i agp" I get

**************************
agpgart 35528 0
**************************

When I perform "rpm -qa|grep nvidia" I get

**************************
x11-video-nvidia-1.0.9631-0.1
nvidia-gfx-kmp-default-1.0.9631_2.6.18.2_34-0.1
**************************

Not sure what any of this means but does anyone have any ideas? I have read here that I would be better off to abandon "The Easy Way" and go back and do it "The Hard Way". Is this my only option left? If so, how do I get back to the stable system I had before I followed "The Easy Way".

There's a 2,000,000 Euro reward for any help :-)

Cheers,
Dec
declan is offline   Reply With Quote
Old 04-30-07, 05:29 AM   #2
declan
Registered User
 
Join Date: Apr 2007
Posts: 2
Default Re: Opensuse 10.2 NVIDIA driver problem with Geforce 7900 GS card

Here's the solution I've found http://www.suseforums.net/index.php?...4&#entry178724
declan is offline   Reply With Quote
Old 04-30-07, 05:20 PM   #3
djdoo
*BANNED*
 
djdoo's Avatar
 
Join Date: Jan 2007
Location: Athens, Hellas
Posts: 160
Lightbulb Re: Opensuse 10.2 NVIDIA driver problem with Geforce 7900 GS card

The RPM driver is not as accurate as the classic Nvidia .run driver file!
Uninstall the RPM driver (9631 is very old and probably unsupported for X 7.2) rpm -e 'and the package name'
Also then with this command (log as root) vi /etc/X11/xorg.conf change the nvidia in the device section to nv
Reboot and then...
My suggestion:
Install 9755 driver from Nvidia's site(Boot normally then in KDE Alt+Shift+F1,login root,init 3,cd /folder containing driver file, sh NVIDIA*,use xconfig to set your xorg.conf as driver suggests), disable that gnome switch for XGL, and also Uninstall both XGL and all of Compiz packages.
Then if everything went well go to this page http://en.opensuse.org/Beryl and see the section
"Beryl with nVidia drivers - no Xgl/AIGLX" follow the instructions and if everything goes well you will have the ultimate 3d desktop!!

Note: If X does not restart with the command given in the instructions for Beryl just reboot!
djdoo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
NVIDIA GeForce GTX 670 brings Kepler on a $399 budget (SlashGear) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM

All times are GMT -5. The time now is 05:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.