Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-12-03, 11:53 PM   #1
CRego3D
Registered User
 
Join Date: Jan 2003
Posts: 5
Default 4363 - After Install some Mozilla fonts are huge

After installing the nvidia drivers, the fonts on some sites (using mozilla) are HUGE .. that was not happening when usign the default "nv" driver (suse 8.2)

Any ideas ?
CRego3D is offline   Reply With Quote
Old 05-13-03, 09:16 AM   #2
shassard
Asus Geforce FX 5600
 
Join Date: May 2003
Location: Vancouver, Canada
Posts: 36
Default 100 DPI fonts == BAD

I've seen this problem before.

Basically, the 'nvidia' driver runs xf86 in 100DPI mode, instead of 75DPI mode.

What you need to do is comment out all instances of the 100DPI fonts in your "/etc/X11/XF86Config-4" configuration file.

The lines will look something like the following:
---
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
---

Just fire a '#' in front to comment them out.

Also, if you're running a font server ('xfs' or 'xfs-ttf') modify the "/etc/X11/fs/config" file and remove the 100dpi stuff there too ..

later,
Steve
shassard is offline   Reply With Quote
Old 05-13-03, 10:01 AM   #3
CRego3D
Registered User
 
Join Date: Jan 2003
Posts: 5
Default

ok .

I try that, but the result was the same .. the fonts are still big (a good example is kde-look.org .. the fonts there are huge for me)

any other ideas ?

Last edited by CRego3D; 05-13-03 at 10:10 AM.
CRego3D is offline   Reply With Quote
Old 05-14-03, 12:20 PM   #4
shassard
Asus Geforce FX 5600
 
Join Date: May 2003
Location: Vancouver, Canada
Posts: 36
Default

are you running XFS( X font server)?

maybe you could post your XF86Config ..
shassard is offline   Reply With Quote
Old 05-14-03, 02:32 PM   #5
CRego3D
Registered User
 
Join Date: Jan 2003
Posts: 5
Default

Quote:
Originally posted by shassard
are you running XFS( X font server)?

maybe you could post your XF86Config ..
I dont' knwo if I am .. (I heard it is good ot)

here is my config, hope it can help

Code:
# /.../
# SaX generated XFree86 config file
# Created on: 2003-05-13.
#
# Version: 4.7
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [SaX2] (4.7)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/local"
  FontPath     "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/URW"
  FontPath     "/usr/X11R6/lib/X11/fonts/Speedo"
  FontPath     "/usr/X11R6/lib/X11/fonts/PEX"
  FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/kwintv"
  FontPath     "/usr/X11R6/lib/X11/fonts/truetype"
  FontPath     "/usr/X11R6/lib/X11/fonts/uni:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/CID"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/xtest"
  InputDevices "/dev/ttyS0"
  InputDevices "/dev/ttyS1"
  InputDevices "/dev/ttyS2"
  InputDevices "/dev/ttyS3"
  InputDevices "/dev/ttyS4"
  InputDevices "/dev/ttyS5"
  InputDevices "/dev/ttyS6"
  InputDevices "/dev/ttyS7"
  InputDevices "/dev/ttyS8"
  InputDevices "/dev/psaux"
  InputDevices "/dev/logibm"
  InputDevices "/dev/sunmouse"
  InputDevices "/dev/atibm"
  InputDevices "/dev/amigamouse"
  InputDevices "/dev/atarimouse"
  InputDevices "/dev/inportbm"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/mouse"
  InputDevices "/dev/usbmouse"
  InputDevices "/dev/adbmouse"
  InputDevices "/dev/input/mice"
  InputDevices "/dev/input/event0"
  InputDevices "/dev/pointer0"
  InputDevices "/dev/pointer1"
  InputDevices "/dev/pointer2"
  InputDevices "/dev/pointer3"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "speedo"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "v4l"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail"
EndSection

Section "InputDevice"
  Driver       "Keyboard"
  Identifier   "Keyboard[0]"
  Option       "MapName" "Standard Keyboard [ pc104 ]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "pc104"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "ButtonNumber" "5"
  Option       "Device" "/dev/mouse"
  Option       "Name" "Autodetection"
  Option       "Protocol" "imps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  DisplaySize  400 300
  HorizSync    30-130
  Identifier   "Monitor[0]"
  ModelName    "CPD-G520"
  Option       "DPMS"
  VendorName   "SONY"
  VertRefresh  48-170
#  UseModes     "Modes[0]"
EndSection


#Section "Modes"
#  Identifier   "Modes[0]"
#  Modeline 	"1600x1200" 174.72 1600 1616 1968 2208 1200 1200 1213 1253
#  Modeline 	"1600x1200" 199.68 1600 1616 1968 2208 1200 1200 1215 1253
#  Modeline 	"1600x1200" 224.64 1600 1616 1968 2208 1200 1200 1216 1253
#  Modeline 	"1600x1200" 249.60 1600 1616 1968 2280 1200 1200 1218 1253
#  Modeline 	"1600x1200" 270.40 1600 1616 1968 2280 1200 1200 1221 1253
#  Modeline 	"1600x1200" 274.56 1600 1616 1968 2280 1200 1200 1221 1253
#  Modeline 	"1600x1200" 299.52 1600 1616 1968 2280 1200 1200 1225 1253
#  Modeline 	"1280x1024" 119.28 1280 1296 1552 1736 1024 1024 1035 1070
#  Modeline 	"1280x1024" 136.31 1280 1296 1552 1736 1024 1024 1036 1070
#  Modeline 	"1280x1024" 153.35 1280 1296 1552 1736 1024 1024 1039 1070
#  Modeline 	"1280x1024" 170.39 1280 1296 1552 1736 1024 1024 1040 1070
#  Modeline 	"1280x1024" 187.43 1280 1296 1552 1736 1024 1024 1042 1070
#  Modeline 	"1280x1024" 204.47 1280 1296 1552 1736 1024 1024 1042 1070
#  Modeline 	"1280x1024" 216.32 1280 1296 1552 1736 1024 1024 1045 1070
#  Modeline 	"1024x768" 71.39 1024 1040 1216 1400 768 768 776 802
#  Modeline 	"1024x768" 81.59 1024 1040 1216 1400 768 768 777 802
#  Modeline 	"1024x768" 91.79 1024 1040 1216 1400 768 768 778 802
#  Modeline 	"1024x768" 101.99 1024 1040 1216 1400 768 768 779 802
#  Modeline 	"1024x768" 112.19 1024 1040 1216 1400 768 768 781 802
#  Modeline 	"1024x768" 122.39 1024 1040 1216 1400 768 768 783 802
#  Modeline 	"1024x768" 132.59 1024 1040 1216 1400 768 768 789 802
#  Modeline 	"1024x768" 142.79 1024 1040 1216 1400 768 768 789 802
#  Modeline 	"800x600" 43.68 800 816 928 1072 600 600 606 626
#  Modeline 	"800x600" 49.92 800 816 928 1072 600 600 607 626
#  Modeline 	"800x600" 56.16 800 816 928 1072 600 600 608 626
#  Modeline 	"800x600" 62.40 800 816 928 1112 600 600 609 626
#  Modeline 	"800x600" 68.64 800 816 928 1112 600 600 610 626
#  Modeline 	"800x600" 74.88 800 816 928 1112 600 600 611 626
#  Modeline 	"800x600" 81.12 800 816 928 1112 600 600 616 626
#  Modeline 	"800x600" 87.36 800 816 928 1112 600 600 616 626
#  Modeline 	"640x480" 27.96 640 656 720 864 480 480 485 501
#  Modeline 	"640x480" 31.95 640 656 720 864 480 480 485 501
#  Modeline 	"640x480" 35.94 640 656 720 864 480 480 486 501
#  Modeline 	"640x480" 39.94 640 656 720 864 480 480 487 501
#  Modeline 	"640x480" 43.93 640 656 720 864 480 480 488 501
#  Modeline 	"640x480" 47.92 640 656 720 864 480 480 488 501
#  Modeline 	"640x480" 51.92 640 656 720 864 480 480 491 501
#  Modeline 	"640x480" 55.91 640 656 720 904 480 480 491 501
#EndSection


Section "Device"
  BoardName    "GeForce4 Ti 4600"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "NVidia"
Option "NvAGP" "3"
Option "DigitalVibrance" "0"
Option "TwinView" "1"
Option "SecondMonitorHorizSync" "30-130"
Option "SecondMonitorVertRefresh" "48-170"
Option "TwinViewOrientation" "RightOf"
Option "TVStandard" "NTSC-M"
Option "MetaModes" "1600x1200 @1600x1200,1600x1200 @1600x1200;1280x1024 @1280x1024,x @x;1024x768 @1024x768,x @x;800x600 @800x600,x @x;640x480 @640x480,x @x"
EndSection


Section "Screen"
  DefaultDepth 16
  SubSection "Display"
    Depth      15
    Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      32
    Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection
thanks for any help
CRego3D is offline   Reply With Quote
Old 05-15-03, 10:28 AM   #6
maxime
Registered User
 
Join Date: May 2003
Posts: 1
Default Twinview and font problems

It seems that the twinview option triggers some strange font problems.

( I am using SuSE 8.2, GForce 4 ti4200, nv-4363 )

Netscape and mozilla will show huge fonts in the Google search result page (bottom).
OpenOffice 1.0.2 will display all fonts as proportional fonts.

All problems disappear when you disable the twinview options.

Seems like a bug in the driver.
maxime is offline   Reply With Quote
Old 05-15-03, 09:11 PM   #7
CRego3D
Registered User
 
Join Date: Jan 2003
Posts: 5
Default Re: Twinview and font problems

Quote:
Originally posted by maxime
It seems that the twinview option triggers some strange font problems.

( I am using SuSE 8.2, GForce 4 ti4200, nv-4363 )

Netscape and mozilla will show huge fonts in the Google search result page (bottom).
OpenOffice 1.0.2 will display all fonts as proportional fonts.

All problems disappear when you disable the twinview options.

Seems like a bug in the driver.
Damm, that is bad .. it was runnign great with RH ..
CRego3D is offline   Reply With Quote
Old 05-19-03, 09:57 AM   #8
CRego3D
Registered User
 
Join Date: Jan 2003
Posts: 5
Default

yep, it is a Twinview isue .. does anybody knwo a worksround ? (widouth disabling twinview of course )
CRego3D is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM

All times are GMT -5. The time now is 01:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.