Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-26-05, 05:56 PM   #1
gerk
Registered User
 
Join Date: Aug 2005
Posts: 4
Default [nvsound] NForce4 -> Surround sound does not work

Hi,

I own a MSI K8N Neo4 board which uses the NForce4 chipset. Some days ago I bought a 5.1 surround system which I obviously want do use. Sound basically has been working all the time (using a headset) with the snd-intel8x0 driver.

However, when I tried to activate all of my speakers I had to notice that they would not work. After some messing around (changing Line-In to Rear Speakers etc.) with the alsa settings, I managed to get all but one speaker to work (despite the sound quality being rather bad when activating certain options).

So I decided to give NVidia's NForce drivers a try. I "downgraded" to OSS, respectively to nvsound and set up everything just as the Release Notes recommend it. Sound basically works but only with the two front speakers + the Subwoofer. The center speaker and the two rear speakers remain soundless.

nvmixer allows me to change the volume of each speaker, but that does not prevent them from remaining silent. Also changing the subwoofer's volume has no effect. What I also find strange is that the buttons "Surround Settings" and "Speaker Wizard" are greyed out. Messing around with the Swap Options and plugging the cables in the respective connector does not help at all.

Any ideas?
Regards,
Chris

P.S.: Just as usual everything works fine with some ominous operating system from Redmond.

/edit:
I almost forgot:
Kernel version is 2.6.11, Distro is Ubuntu (Hoary).
gerk is offline   Reply With Quote
Old 12-08-05, 08:31 AM   #2
engmex
Registered User
 
Join Date: Oct 2005
Posts: 3
Default Re: [nvsound] NForce4 -> Surround sound does not work

I have the exact same problem! Did you ever find a solution to this?
engmex is offline   Reply With Quote
Old 12-10-05, 10:55 AM   #3
mile10com
Registered User
 
Join Date: Nov 2005
Posts: 15
Default Re: [nvsound] NForce4 -> Surround sound does not work

This thread might help:

http://www.nvnews.net/vbulletin/showthread.php?t=60542
mile10com is offline   Reply With Quote
Old 12-11-05, 12:31 PM   #4
gerk
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: [nvsound] NForce4 -> Surround sound does not work

Quote:
Originally Posted by engmex
I have the exact same problem! Did you ever find a solution to this?
No, not yet. I switched back to alsa and upgraded to breezy in the meantime. At present all speakers but center work perfectly.
I'm afraid there's nothing we can do but wait for the next generation of alsa drivers.
gerk is offline   Reply With Quote
Old 05-29-07, 08:40 AM   #5
gerk
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: [nvsound] NForce4 -> Surround sound does not work

Generations of alsa drivers have passed and the problem still persists. The center box won't work, no matter whether it is activated or not via alsamixer.

Did anybody find a solution yet?

"Buy a fully supported sound card." should be the last alternative.
gerk is offline   Reply With Quote
Old 05-29-07, 03:57 PM   #6
Jason_25
Registered User
 
Join Date: Mar 2004
Location: Wilmington, NC
Posts: 25
Default Re: [nvsound] NForce4 -> Surround sound does not work

I think if you want more than stereo sound, you should switch to the digital coaxial or optical outputs. I have been using these reliably on my NF4 Ultra-Ds with the snd-intel8x0 for a while now.
Jason_25 is offline   Reply With Quote
Old 05-29-07, 06:09 PM   #7
gerk
Registered User
 
Join Date: Aug 2005
Posts: 4
Default Re: [nvsound] NForce4 -> Surround sound does not work

Spending like EUR 400,00+ for a new sound system also is not an option. Has anybody maybe been able get software-mixing to work?

Due to the fact that there is obviously no fix for the broken driver I am thinking of purchasing a soundcard.

Maybe somebody has got a suggestion.

Requirements:
- Fully linux-compatible.
- Value for money. (Read: Cheap, but no rubbish)
gerk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
If anyone needs a surround sound card... Laichzeit For Sale/Trade 2 09-16-02 10:53 PM

All times are GMT -5. The time now is 12:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.