Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-13-07, 02:49 PM   #1
someone100
Registered User
 
Join Date: Jun 2007
Posts: 3
Question NVRM: failed to register with the ACPI subsystem (black screen)

Hi

I'm currently having a black screen when starting X with the nvidia kernel module, when using the nv module everything shows up. I'ts not like an ordinary black screen I think, the screen looks like my laptop has been turned of. Also kde is starting up in the background. This is what I found in /var/log/messages when loading the module:
Code:
Jun 13 21:12:07 kurzweil kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 209
Jun 13 21:12:07 kurzweil kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  100.14.09  Sat May 26 00:43:07 PDT 2007
And this is what /var/log/messages shows when starting X:
Code:
Jun 13 21:12:27 kurzweil kernel: NVRM: failed to register with the ACPI subsystem!
Other interesting things:
I use suse 10.1, with the normal kernel, I installed the 100.14.09 version from command line, I also had this problem with other versions.
part of xorg.conf:
Code:
Section "Device"
  BoardName    "GeForce FX Go5700"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Option       "CRT"
  Option       "1024x768;1280x800"
  Screen       0
  VendorName   "NVidia"
EndSection
I also added the Xorg log, but I don't see anything special in it.
Attached Files
File Type: bz2 Xorg.0.log.bz2 (5.1 KB, 132 views)
someone100 is offline   Reply With Quote
Old 06-13-07, 03:00 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVRM: failed to register with the ACPI subsystem (black screen)

You'll need to generate and attach an nvidia-bug-report.log, per the forum sticky posts (and driver README).
netllama is offline   Reply With Quote
Old 06-13-07, 03:51 PM   #3
someone100
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Re: NVRM: failed to register with the ACPI subsystem (black screen)

Here's the nvidia bug report log, after starting X with startx -- -logverbose 6
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (34.5 KB, 184 views)
someone100 is offline   Reply With Quote
Old 06-13-07, 04:17 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVRM: failed to register with the ACPI subsystem (black screen)

Try adding the following option to the Device section of xorg.conf:
Option "UseDisplayDevice" "DFP"
netllama is offline   Reply With Quote
Old 06-13-07, 06:22 PM   #5
someone100
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Re: NVRM: failed to register with the ACPI subsystem (black screen)

thanks, that seems to have fixed this error.
someone100 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Screen freeze NVRM: Xid error ciancaroll NVIDIA Linux 0 06-05-12 01:05 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM

All times are GMT -5. The time now is 05:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.