Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-14-07, 11:09 AM   #1
jadams
Registered User
 
Join Date: Jun 2007
Posts: 1
Default 1080i via DVI support.

I for the life of me cannot get 1080i forced on my monitor. It always wants to use 1080p. I've read and read and read a lot about this, and it's always looking like some type of an nvidia issue. Has anyone had any luck forcing 1080i? If so, could you please report how you did it... like I said, when I try, it instead uses 1080p and the screen is off-center (shifted to the left a little bit).

Here is my xorg.conf file:

# VideoMode 1920x1080i FIXED SYNC DVI/VGA/HDMI
# XFree86 4 configuration created by Jason Adams
# patched to support PCI Express / ITOX jgj 0610006

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
Option "AllowMouseOpenFail" "true"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/null"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/null"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "SAMSUNG DLP"
Option "DPMS"
#DisplaySize 487 274
#HorizSync 15.0-46.0
#VertRefresh 23.967, 29.97, 59.94, 24, 25, 30, 50, 59-61
ModeLine "1920x1080i" 74.2 1920 2008 2052 2200 1080 1088 1091 1121 +hsync +vsync interlace
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "Nvidia GeForce 7600 GS"
Option "RenderAccel" "True"
Option "NoLogo" "True"
Option "NvAGP" "3"
Option "ModeValidation" "NoVertRefreshCheck"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Option "ModeValidation" "NoEdidMaxPclkCheck"
Option "ModeValidation" "NoHorizSyncCheck"
Option "ModeValidation" "NoMaxPClkcheck"
Option "ExactModeTimingsDVI" "FALSE"
Option "NoPredefinedModes"
Option "DPI" "100x100"


EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
#Option "IgnoreDisplayDevices" "TV"
#ption "TVStandard" "HD1080i"
SubSection "Display"
Depth 24
Modes "1920x1080i"
EndSubSection
EndSection

Additionally, I am using a GeForce 7600 GS card. I've tried a million different ModeLines, Modes, Options, etc, and and I just for the life of me cannot get DVI forced on 1080i (and yes, my TV supports it... component works on 1080i just not DVI).

I am using the latest nvidia driver (June 8th) for x86 linux. I have kernel 2.6.20 (FC6).

If anyone has gotten 1080i working, with the latest nvidia driver, using DVI, please post your xorg file or let me know what I'm doing wrong. Thanks in advance!

Attached are the logs, and the xorg.conf file in .log extension so it would actually post heh...

-Jason Adams
Attached Files
File Type: log Xorg.0.log (23.3 KB, 68 views)
File Type: log xorg.conf.log (3.9 KB, 79 views)
jadams is offline   Reply With Quote
Old 06-14-07, 02:41 PM   #2
crow
Registered User
 
Join Date: Jan 2004
Posts: 43
Default Re: 1080i via DVI support.

There are lots of people having problems with interlaced modes, even when using correct EDID information from the TV. Search for "1080i" and you'll find several other threads where this has already been discussed.
crow is offline   Reply With Quote
Old 06-15-07, 02:53 AM   #3
asdere
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: 1080i via DVI support.

Quote:
Originally Posted by jadams
I for the life of me cannot get 1080i forced on my monitor. It always wants to use 1080p. I've read and read and read a lot about this, and it's always looking like some type of an nvidia issue. Has anyone had any luck forcing 1080i? If so, could you please report how you did it... like I said, when I try, it instead uses 1080p and the screen is off-center (shifted to the left a little bit).

Here is my xorg.conf file:


Additionally, I am using a GeForce 7600 GS card. I've tried a million different ModeLines, Modes, Options, etc, and and I just for the life of me cannot get DVI forced on 1080i (and yes, my TV supports it... component works on 1080i just not DVI).

I am using the latest nvidia driver (June 8th) for x86 linux. I have kernel 2.6.20 (FC6).

If anyone has gotten 1080i working, with the latest nvidia driver, using DVI, please post your xorg file or let me know what I'm doing wrong. Thanks in advance!

Attached are the logs, and the xorg.conf file in .log extension so it would actually post heh...

-Jason Adams
Try increasing the verbosity of the log messages, ie: startx -- -logverbose 6 -verbose 6

Since you're not ignoring EDID information, the assumption is that the driver doesn't like something about your 1080i modeline and falling back to the highest resolution available thru EDID info, which is 1080p.

Also, I'm not sure if having multiple Option "ModeValidation" lines are additive, maybe it'll only use the last line and ignores anything previous. I suggest just putting all those on one line:
Option "ModeValidation" ""NoVertRefreshCheck,NoDFPNativeResolutionCheck,No EdidMaxPclkCheck,NoHorizSyncCheck,NoMaxPClkcheck"
asdere is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vizio's Co-Star: $99 Google TV box with OnLive gaming support News Archived News Items 0 06-26-12 11:40 AM
Canonical partners with Microsoft to support Ubuntu on Azure News Archived News Items 0 06-08-12 05:20 AM
Remastered Doom 3 BFG Edition Game Coming with Stereo 3D Support News Archived News Items 0 06-01-12 05:30 AM
Official Detonator 40.xx Feedback Thread pelly NVIDIA Windows Graphics Drivers 299 09-22-02 06:54 AM
LCD DVI support in Linux drivers? salobaas NVIDIA Linux 1 07-31-02 03:29 AM

All times are GMT -5. The time now is 08:16 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.