Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-06-07, 03:16 PM   #1
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Compiz-0.5 and white window bug

Hello,

I just recently tried running compiz 0.5 on my AMD-Athlon-64 / GF6600-PCIe system, did all the suggested modifications to xorg.conf:
- Enable Composite
- AddARGBVislual
- AllowGLXWithComposite

Composite works with "traditional" composition managers, like that one shipped with KDE:

When I start compiz with "compiz --replace;kde-window-decorator" I get a white screen - with the 9639-driver I can kill compiz with Strg+C and restart kwin, with the new series100 beta driver pressing String+C kills the system (I get not even numlock feedback).

In both cases a lot of:
Code:
trying /usr/$LIB/lib?????.so
Can bind redirected windows 0x??????? to texture
Any ideas what could be wrong?
Why does the series100 driver crash the system hard?

Thank you in advance, lg Clemens
Linuxhippy is offline   Reply With Quote
Old 06-10-07, 01:46 PM   #2
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Compiz-0.5 and white window bug

Does nobody have an idea where the problem could be?

I am curious why the system hangs with the new 100.xyz driver when I kill compiz, with 9755 I get the working system back.
Any where should I report this crash, since its really a crash - a userspace-app should be never ever be able to hard-crash (no ssh) the whole system!

Any help would be really appriciated.
Thank you in advance, lg Clemens
Linuxhippy is offline   Reply With Quote
Old 06-10-07, 03:14 PM   #3
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Compiz-0.5 and white window bug

can you post the output of glxinfo?
Dragoran is offline   Reply With Quote
Old 06-10-07, 03:39 PM   #4
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Compiz-0.5 and white window bug

Quote:
Originally Posted by Dragoran
can you post the output of glxinfo?
Yes, I can run it but I don't have access to that machine at the time of writing this post.
However glxinfo-output looks quite "normal", it shows that direct-rendering is enabled, that I am using the nvidia driver and so forth.
I also can use opengl games and applications without any problems (e.g. play quake3).

lg Clemens
Linuxhippy is offline   Reply With Quote
Old 06-11-07, 03:01 PM   #5
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Compiz-0.5 and white window bug

bump
Linuxhippy is offline   Reply With Quote
Old 06-17-07, 01:47 PM   #6
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: Compiz-0.5 and white window bug

the problem is the version compiz-build distributed by OpenSuse seems somehow biased towards XGL support.

I grabbed the official distribution and it works now - except that window-resizing is really painful :-/

lg Clemens
Linuxhippy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.