Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-22-07, 01:18 PM   #1
cindy
Registered User
 
Join Date: Apr 2007
Posts: 7
Red face NVIDIA and RandR

Hi,

I've been happily running my nVidia Corporation C51PV [GeForce 6150] with the NVIDIA driver (thanks!), but I want to take advantage of my HP L2045w widescreen monitor ... it rotates sideways and it's real long, I'd like to read the text like that ...

But anyway I used to be able to type "randr -o left" and the whole view would go sideways ... now it says I can't do that ... I do have this line in my xorg.conf:

Option "Rotate" "RandR"

Help!

Also, another help if you can:

I changed window managers today, and now the best mode for viewing everything isn't the first mode in the mode line, I think it's the second (I type CTRL-ALT-+ and it's the first one I switch to, it's great). So to make it come up first when I boot into X, do I just swap those two first modes???

And the only prob I have with this nice mode is that the screen's a little too long to the right, can I make the screen size smaller for just that mode???

Thank you all so much!!!
cindy is offline   Reply With Quote
Old 06-22-07, 01:28 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA and RandR

You're confusing two different options. There's a static Rotate option, and a separate, unrelated, RandRRotation option. See the driver README for details.

I can't answer your other question without seeing an nvidia-bug-report.log
netllama is offline   Reply With Quote
Old 06-22-07, 02:02 PM   #3
cindy
Registered User
 
Join Date: Apr 2007
Posts: 7
Default Re: NVIDIA and RandR

Quote:
Originally Posted by netllama
You're confusing two different options. There's a static Rotate option, and a separate, unrelated, RandRRotation option. See the driver README for details.
O.k., got it. I took out the Rotate option and instead put this:

Option "RandRRotation"

But when I do "xrandr -q" it says I just have "normal" and when I try to rotate left it doesn't work ...


Quote:
I can't answer your other question without seeing an nvidia-bug-report.log
Got one comin' right up!
cindy is offline   Reply With Quote
Old 06-22-07, 02:14 PM   #4
cindy
Registered User
 
Join Date: Apr 2007
Posts: 7
Default Re: NVIDIA and RandR

Quote:
Originally Posted by cindy
O.k., got it. I took out the Rotate option and instead put this:

Option "RandRRotation"

But when I do "xrandr -q" it says I just have "normal" and when I try to rotate left it doesn't work ...
Yes it does ... I get the doofus of the day award ... what you have to do is RESTART THE XDM SERVER ...

So xrandr works great ...

HOWEVER, I still am not sure how to configure my video modes ... I have a few favorite modes ... obviously different ones for normal and for rotated ... but in all my favorite modes, the X server screen is virtually too large, so the cursor swoops over to the left of the screen, or down below the bottom ... is there an easy way (or any way at all) to make it so my modes work to fill the physical screen, and that's all?


cindy

(this is me trying to figure all this out)
cindy is offline   Reply With Quote
Old 06-22-07, 03:22 PM   #5
cindy
Registered User
 
Join Date: Apr 2007
Posts: 7
Default Re: NVIDIA and RandR

Ok, here's my bug report log.

I guess my whole problem is how to figure out the video modes so that I don't have a virtual desktop. One mode is too wide (the mouse pans over to the right) and one mode is too long (the mouse drops way down below the bottom of the monitor). Can't these modes just fit the right size of the monitor?

Thanks for your help!
Attached Files
File Type: log nvidia-bug-report.log (135.0 KB, 303 views)
cindy is offline   Reply With Quote
Old 06-22-07, 03:33 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA and RandR

The order that your modes are listed is the problem. You need to have the largest (height & width) mode listed first, or you'll end up with a virtual desktop. If all that you care about is getting the largest native mode, then remove all the modes, and just replace them with "nvidia-auto-select" and you should be all set (after restarting X).
netllama is offline   Reply With Quote
Old 06-22-07, 03:45 PM   #7
cindy
Registered User
 
Join Date: Apr 2007
Posts: 7
Default Re: NVIDIA and RandR

Quote:
Originally Posted by netllama
The order that your modes are listed is the problem. You need to have the largest (height & width) mode listed first, or you'll end up with a virtual desktop. If all that you care about is getting the largest native mode, then remove all the modes, and just replace them with "nvidia-auto-select" and you should be all set (after restarting X).


I'm doing the "nvidia is awesome" dance!

My screen looks fabulous now!!!!!

Sometimes I'd like to zoom in with other modes but I guess I'll figure that one out when the time comes ... right now I am happpay!
cindy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.17 for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-16-12 04:12 PM
NVIDIA Releases Its Stable 302 Driver w/ RandR 1.3 News Archived News Items 0 06-16-12 07:20 AM
302.11 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-19-12 10:21 AM
Dear Nvidia , Its to close 10 years, and still TwinView,Rotate, and SLI dont work shay1680 NVIDIA Linux 16 05-04-12 09:38 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM

All times are GMT -5. The time now is 03:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.