Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-28-07, 03:39 PM   #1
nmn
Registered User
 
Join Date: Jun 2007
Posts: 2
Question nVidia GeForce Go 7600 on Linux

Hello all!

A friend of mine has been trying to switch to Linux for a while, and he's been without 3D acceleration for just as long. It seems that there are no nVidia drivers for his card! I've had him try to build the new and old versions, but i went nearly insane trying to get the kernel source to work without having direct access to the terminal. (Closest we got was that it "couldn't reconize the version of the kernel source in /usr/src/linux" from a clean install of the kernel-source + kernel-syms packages.)

That said, he was running SuSE Linux 10.2 so he had also tried installing via YaST. Neither worked. YaST got the closest, with a driver that showed nothing but a blank screen and a white horizontal line that represented the cursor. (For those of you who have played UT 2004 on Linux, its like when your connecting to the server on the black screen except with out the white text that says "Connecting to " and the URL.)

He has been using a nVidia GeForce Go 7600 with his laptop. Apparently it works fine with Windows and its Linux or its drivers causing the problems. When trying Sabayon's Live CD, the regular boot and graphical install modes do not show the X11 Server - It leaves him with a blank console (Same for all other options - Since its an X driver problem).

I know the Linux drivers work. I've been using them a lot, and they are in general easy to install (I've never had the same problems as him with the kernel source, and i even prefer compiling it over using YaST on SuSE because i actually think its easier.) but he can't get anything more than nv and vesa working. Which brings up another issue - though it doesn't support 3D acceleration - is the nv driver more compatible than the nvidia driver? (In my honest opinion it seems about the same speed for 2D - but I'm probably wrong.)

Thanks in advance. And if anyone knows please tell me why I can't find this particular card in the nVidia driver finder tool thing - Its almost like it doesn't exist (even though it has a homepage at the nVidia website)
nmn is offline   Reply With Quote
Old 06-28-07, 03:42 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nVidia GeForce Go 7600 on Linux

This GPU should work fine with 100.14.11. If its not, please generate and attach an nvidia-bug-report.log.
netllama is offline   Reply With Quote
Old 06-28-07, 06:16 PM   #3
nmn
Registered User
 
Join Date: Jun 2007
Posts: 2
Default Re: nVidia GeForce Go 7600 on Linux

Thanks for your reply! I really appreciate the help.

At the moment, i can't get the log. I'm telling him to get the system log for me though as soon as he can - i will bump the thread with it as soon as i can. For now, if anyone knows anything that could be causing this problem don't hesitate to tell me. Any info would help at this point, even if its obvious. After all, i haven't used SuSE in a while. (Then again i know that Sabayon is having the same problem.)

Also, i neglected to tell people that i know its not nVidia`s fault - It was me or my friend - because Mandriva has no problem with full 3D acceleration on the same computer. Yeah, sorry, i forgot about that XD
nmn is offline   Reply With Quote
Old 06-29-07, 02:01 AM   #4
phelin
Registered User
 
Join Date: Jan 2006
Posts: 30
Default Re: nVidia GeForce Go 7600 on Linux

Quote:
Originally Posted by nmn
Hello all!

A friend of mine has been trying to switch to Linux for a while, and he's been without 3D acceleration for just as long. It seems that there are no nVidia drivers for his card! ...
He has been using a nVidia GeForce Go 7600 with his laptop.
I have been using that card almost nine months now without problems with Ubuntu Dapper, Edgy and Feisty.

Code:
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7600] (rev a1) (prog-if 00 [VGA])
        Subsystem: COMPAL Electronics Inc Unknown device 0020
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at d1000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Region 3: Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
        Region 5: I/O ports at 2000 [size=128]
        Capabilities: <access denied>
phelin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
NVIDIA GeForce GTX 670 brings Kepler on a $399 budget (SlashGear) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM

All times are GMT -5. The time now is 07:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.