Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-01-07, 11:26 AM   #1
bldgengineer
Registered User
 
Join Date: Jun 2007
Posts: 24
Default can't get SLI enabled with 2 8600gts'

now I can't get sli going.

This is what I get when I "cat /proc/driver/nvidia/cards/*" in terminal:
Code:
Model:           GeForce 8600 GTS
IRQ:             21
Video BIOS:      60.84.18.00.25
Card Type:       PCI-E
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    01.00.0
Model:           GeForce 8600 GTS
IRQ:             21
Video BIOS:      ??.??.??.??.??
Card Type:       PCI-E
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    03.00.0
Last time I was able to get it going with "nvidia-xconfig --enable-all-gpus" in command prompt after stopping x.

So far I've tried that, --multigpu, --sli=auto, and --sli=AFR

Is there a command I'm missing? included the bug report
Attached Files
File Type: zip nvidialog.zip (35.5 KB, 76 views)
bldgengineer is offline   Reply With Quote
Old 07-01-07, 12:43 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: can't get SLI enabled with 2 8600gts'

[ 303.083589] allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
[ 303.083717] NVRM: RmInitAdapter failed! (0x25:0xffffffff:1014)

This is covered in the driver README.
netllama is offline   Reply With Quote
Old 07-01-07, 02:03 PM   #3
bldgengineer
Registered User
 
Join Date: Jun 2007
Posts: 24
Default Re: can't get SLI enabled with 2 8600gts'

I can't seem to get vmalloc to increase. I've type vmalloc=512mb,vmalloc=512m, vmalloc=512, sudo vmalloc=512(etc) and whenever I do $ cat /proc/meminfo its always the same.


so how do you get it to increase?
bldgengineer is offline   Reply With Quote
Old 07-01-07, 02:16 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: can't get SLI enabled with 2 8600gts'

You'll need to contact whomever built your kernel, as this is a kernel limitation.
netllama is offline   Reply With Quote
Old 07-01-07, 03:48 PM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: can't get SLI enabled with 2 8600gts'

@bldgengineer: I wouldn't expect the vmalloc parameter to change the MemTotal reported via /proc/meminfo, since you're using a HIGHMEM enabled kernel; does the initialization problem persist if you use e.g. vmalloc=192M or vmalloc=256M?
zander is offline   Reply With Quote
Old 07-03-07, 07:04 AM   #6
bldgengineer
Registered User
 
Join Date: Jun 2007
Posts: 24
Default Re: can't get SLI enabled with 2 8600gts'

but wouldn't the vmallocTotal change? Like near the bottom of the list
Code:
MemTotal:      2075068 kB
MemFree:       1108208 kB
Buffers:        488676 kB
Cached:         264828 kB
SwapCached:          0 kB
Active:         325068 kB
Inactive:       581728 kB
HighTotal:     1178560 kB
HighFree:       745012 kB
LowTotal:       896508 kB
LowFree:        363196 kB
SwapTotal:     1951888 kB
SwapFree:      1951888 kB
Dirty:             876 kB
Writeback:           0 kB
AnonPages:      153400 kB
Mapped:          55980 kB
Slab:            38436 kB
SReclaimable:    24860 kB
SUnreclaim:      13576 kB
PageTables:       1844 kB
NFS_Unstable:        0 kB
Bounce:              0 kB
CommitLimit:   2989420 kB
Committed_AS:   572388 kB
VmallocTotal:   114680 kB
VmallocUsed:     62696 kB
VmallocChunk:    46580 kB
bldgengineer is offline   Reply With Quote
Old 07-03-07, 12:11 PM   #7
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: can't get SLI enabled with 2 8600gts'

Does the vmalloc= addition to your kernel's command line show up in /proc/cmdline? If vmalloc= doesn't work, there are a few other options; please see the README for details.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTX670 Quad SLI issue candle_86 NVIDIA GeForce 600 Series 12 07-09-12 09:18 PM
680 GTX SLI + 560 Physx bench for those interested gerardfraser NVIDIA GeForce 600 Series 2 06-20-12 04:34 AM
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
AGP not being enabled on Geforce2 mx frankjr NVIDIA Linux 1 09-22-02 02:01 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 04:56 PM

All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.