Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-12-07, 08:25 AM   #1
billydv
Registered User
 
Join Date: Sep 2006
Posts: 88
Default Regular X Freezes , Please Help Nvidia

I am running an a8v-deluxe, nvidia evga 7800gs, gentoo amd64.

I get regular x freezes when agp is enabled, beryl being the window manager doesnt make any difference, x freezes after some time irregardless

1- My kernel config

#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.21-gentoo-r3
# Wed Jun 20 21:39:14 2007
#
CONFIG_X86_64=y
CONFIG_64BIT=y
CONFIG_X86=y
CONFIG_GENERIC_TIME=y
CONFIG_GENERIC_TIME_VSYSCALL=y
CONFIG_ZONE_DMA32=y
CONFIG_LOCKDEP_SUPPORT=y
CONFIG_STACKTRACE_SUPPORT=y
CONFIG_SEMAPHORE_SLEEPERS=y
CONFIG_MMU=y
CONFIG_ZONE_DMA=y
CONFIG_RWSEM_GENERIC_SPINLOCK=y
CONFIG_GENERIC_HWEIGHT=y
CONFIG_GENERIC_CALIBRATE_DELAY=y
CONFIG_X86_CMPXCHG=y
CONFIG_EARLY_PRINTK=y
CONFIG_GENERIC_ISA_DMA=y
CONFIG_GENERIC_IOMAP=y
CONFIG_ARCH_MAY_HAVE_PC_FDC=y
CONFIG_ARCH_POPULATES_NODE_MAP=y
CONFIG_DMI=y
CONFIG_AUDIT_ARCH=y
CONFIG_GENERIC_BUG=y
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
# CONFIG_ARCH_HAS_ILOG2_U64 is not set
CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config"

#
# Code maturity level options
#
CONFIG_EXPERIMENTAL=y
CONFIG_LOCK_KERNEL=y
CONFIG_INIT_ENV_ARG_LIMIT=32

#
# General setup
#
CONFIG_LOCALVERSION=""
# CONFIG_LOCALVERSION_AUTO is not set
CONFIG_SWAP=y
CONFIG_SYSVIPC=y
# CONFIG_IPC_NS is not set
CONFIG_SYSVIPC_SYSCTL=y
CONFIG_POSIX_MQUEUE=y
CONFIG_BSD_PROCESS_ACCT=y
CONFIG_BSD_PROCESS_ACCT_V3=y
# CONFIG_TASKSTATS is not set
# CONFIG_UTS_NS is not set
# CONFIG_AUDIT is not set
CONFIG_IKCONFIG=y
CONFIG_IKCONFIG_PROC=y
# CONFIG_CPUSETS is not set
# CONFIG_SYSFS_DEPRECATED is not set
# CONFIG_RELAY is not set
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE=""
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_SYSCTL=y
# CONFIG_EMBEDDED is not set
CONFIG_UID16=y
CONFIG_SYSCTL_SYSCALL=y
CONFIG_KALLSYMS=y
# CONFIG_KALLSYMS_EXTRA_PASS is not set
CONFIG_HOTPLUG=y
CONFIG_PRINTK=y
CONFIG_BUG=y
CONFIG_ELF_CORE=y
CONFIG_BASE_FULL=y
CONFIG_FUTEX=y
CONFIG_EPOLL=y
CONFIG_SHMEM=y
CONFIG_SLAB=y
CONFIG_VM_EVENT_COUNTERS=y
CONFIG_RT_MUTEXES=y
# CONFIG_TINY_SHMEM is not set
CONFIG_BASE_SMALL=0
# CONFIG_SLOB is not set

#
# Loadable module support
#
CONFIG_MODULES=y
CONFIG_MODULE_UNLOAD=y
CONFIG_MODULE_FORCE_UNLOAD=y
# CONFIG_MODVERSIONS is not set
# CONFIG_MODULE_SRCVERSION_ALL is not set
CONFIG_KMOD=y
CONFIG_STOP_MACHINE=y

#
# Block layer
#
CONFIG_BLOCK=y
# CONFIG_BLK_DEV_IO_TRACE is not set

#
# IO Schedulers
#
CONFIG_IOSCHED_NOOP=y
# CONFIG_IOSCHED_AS is not set
# CONFIG_IOSCHED_DEADLINE is not set
CONFIG_IOSCHED_CFQ=y
# CONFIG_DEFAULT_AS is not set
# CONFIG_DEFAULT_DEADLINE is not set
CONFIG_DEFAULT_CFQ=y
# CONFIG_DEFAULT_NOOP is not set
CONFIG_DEFAULT_IOSCHED="cfq"

#
# Processor type and features
#
CONFIG_X86_PC=y
# CONFIG_X86_VSMP is not set
CONFIG_MK8=y
# CONFIG_MPSC is not set
# CONFIG_MCORE2 is not set
# CONFIG_GENERIC_CPU is not set
CONFIG_X86_L1_CACHE_BYTES=64
CONFIG_X86_L1_CACHE_SHIFT=6
CONFIG_X86_INTERNODE_CACHE_BYTES=64
CONFIG_X86_TSC=y
CONFIG_X86_GOOD_APIC=y
# CONFIG_MICROCODE is not set
CONFIG_X86_MSR=m
CONFIG_X86_CPUID=m
CONFIG_X86_IO_APIC=y
CONFIG_X86_LOCAL_APIC=y
CONFIG_MTRR=y
CONFIG_SMP=y
CONFIG_SCHED_SMT=y
CONFIG_SCHED_MC=y
CONFIG_PREEMPT_NONE=y
# CONFIG_PREEMPT_VOLUNTARY is not set
# CONFIG_PREEMPT is not set
CONFIG_PREEMPT_BKL=y
CONFIG_NUMA=y
CONFIG_K8_NUMA=y
CONFIG_NODES_SHIFT=6
CONFIG_X86_64_ACPI_NUMA=y
# CONFIG_NUMA_EMU is not set
CONFIG_ARCH_DISCONTIGMEM_ENABLE=y
CONFIG_ARCH_DISCONTIGMEM_DEFAULT=y
CONFIG_ARCH_SPARSEMEM_ENABLE=y
CONFIG_SELECT_MEMORY_MODEL=y
# CONFIG_FLATMEM_MANUAL is not set
CONFIG_DISCONTIGMEM_MANUAL=y
# CONFIG_SPARSEMEM_MANUAL is not set
CONFIG_DISCONTIGMEM=y
CONFIG_FLAT_NODE_MEM_MAP=y
CONFIG_NEED_MULTIPLE_NODES=y
# CONFIG_SPARSEMEM_STATIC is not set
CONFIG_SPLIT_PTLOCK_CPUS=4
CONFIG_MIGRATION=y
CONFIG_RESOURCES_64BIT=y
CONFIG_ZONE_DMA_FLAG=1
CONFIG_HAVE_ARCH_EARLY_PFN_TO_NID=y
CONFIG_OUT_OF_LINE_PFN_TO_PAGE=y
CONFIG_NR_CPUS=2
CONFIG_HOTPLUG_CPU=y
CONFIG_ARCH_ENABLE_MEMORY_HOTPLUG=y
CONFIG_HPET_TIMER=y
CONFIG_IOMMU=y
CONFIG_CALGARY_IOMMU=y
CONFIG_CALGARY_IOMMU_ENABLED_BY_DEFAULT=y
CONFIG_SWIOTLB=y
CONFIG_X86_MCE=y
# CONFIG_X86_MCE_INTEL is not set
CONFIG_X86_MCE_AMD=y
CONFIG_KEXEC=y
# CONFIG_CRASH_DUMP is not set
CONFIG_PHYSICAL_START=0x200000
CONFIG_SECCOMP=y
# CONFIG_CC_STACKPROTECTOR is not set
# CONFIG_HZ_100 is not set
# CONFIG_HZ_250 is not set
CONFIG_HZ_300=y
# CONFIG_HZ_1000 is not set
CONFIG_HZ=300
CONFIG_REORDER=y
CONFIG_K8_NB=y
CONFIG_GENERIC_HARDIRQS=y
CONFIG_GENERIC_IRQ_PROBE=y
CONFIG_ISA_DMA_API=y
CONFIG_GENERIC_PENDING_IRQ=y


2- My Xorg.conf


Section "ServerLayout"
Identifier "X.Org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "PS/2 Mouse" "AlwaysCore"
# Serial Mouse not detected
InputDevice "USB Mouse" "AlwaysCore"
#No Synaptics touchpad found
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "TRUE"
Option "AIGLX" "TRUE"
EndSection

Section "Files"
FontPath "/usr/share/fonts/util"
FontPath "/usr/share/fonts/encodings"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/corefonts"
FontPath "/usr/local/share/fonts"
FontPath "/usr/share/fonts/default"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/default/ghostscript"
EndSection

Section "Module"
Load "ddc"
Load "vbe"
#Load "GLcore"
Load "dbe"
#Load "dri"
Load "extmod"
Load "glx"
Load "bitmap"
Load "type1"
Load "freetype"
Load "record"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbOptions" "grp:toggle,grp_led:scroll"
Option "XkbVariant" ",winkeys"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/misc/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "evdev"
Option "Device" "/dev/input/event1"
Option "Buttons" "7"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

#Section "InputDevice"
# Identifier "Synaptics"
# Driver "synaptics"
# Option "Protocol" "event"
# Option "Device" ""
# Option "LeftEdge" "1900"
# Option "RightEdge" "5400"
# Option "TopEdge" "1900"
# Option "BottomEdge" "4000"
# Option "FingerLow" "25"
# Option "FingerHigh" "30"
# Option "MaxTapTime" "180"
# Option "MaxTapMove" "220"
# Option "VertScrollDelta" "100"
# Option "MinSpeed" "0.02"
# Option "MaxSpeed" "0.10"
# Option "AccelFactor" "0.0010"
# Option "SHMConfig" "on"
#EndSection

# Auto-generated by mkxf86config

Section "Monitor"
Identifier "Monitor0"
HorizSync 28.0 - 96.0
VertRefresh 43.0 - 160.0
Option "DPMS" "TRUE"
EndSection


Section "Device"
### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
#Option "sw_cursor"
#Option "hw_cursor" "off"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
Identifier "Card0"
# The following line is auto-generated by x11-misc/mkxf86config
Driver "nvidia"
#Option "NvAGP" "1"
VendorName "All"
BoardName "All"
# BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 24
#Option "RenderAccel" "false"
#Option "DamageEvents" "True"
Option "UseEvents" "False"
Option "DynamicTwinView" "FALSE"
#Option "TripleBuffer" "True"
#Option "BackingStore" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
#Option "DAMAGE" "Enable"
#Option "RENDER" "Enable"
Option "Composite" "Enable"
EndSection



3- My Grub Entry for boot

title Gentoo AMD64 2.6.21-gentoo-r3
root (hd2,1)
kernel /boot/kernel-2.6.21-gentoo-r3 root=/dev/ram0 init=/linuxrc ramdisk_size=16384 real_root=/dev/sdb2 idle=poll pci=nommconf vga=791 splash=verbose,theme:Emergance CONSOLE=/dev/tty1 quiet
initrd /boot/initramfs-2.6.21-gentoo-r3


This boot I am testing with the idle=poll for the first time, I hate to use this because it increases cpu temps to about 125f at idle and individual core temps are at 135f to 140f at idle but I am at least trying it

4-cat nvidia stuff

cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 8x
Fast Writes: Enabled
SBA: Enabled

cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 100.14.11 Wed Jun 13 16:33:22 PDT 2007
GCC version: gcc version 4.1.2 (Gentoo 4.1.2)

cat /proc/driver/nvidia/agp/card
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0xff000e1b:0x1f000312

cat /proc/driver/nvidia/agp/host-bridge
Host Bridge: PCI device 1106:0282
Fast Writes: Supported
SBA: Supported
AGP Rates: 8x 4x
Registers: 0x1f000a1b:0x00000b12

cat /proc/driver/nvidia/cards/0
Model: GeForce 7800 GS
IRQ: 16
Video BIOS: 05.71.22.21.06
Card Type: AGP
DMA Size: 32 bits
DMA Mask: 0xffffffff
Bus Location: 01.00.0




Please tell me what to do to fix this!!!!!
billydv is offline   Reply With Quote
Old 07-12-07, 09:39 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Regular X Freezes , Please Help Nvidia

Per the forum sticky posts, please generate and attach an nvidia-bug-report.log.
netllama is offline   Reply With Quote
Old 07-14-07, 04:14 PM   #3
epoxi
Registered User
 
Join Date: Jul 2007
Posts: 2
Exclamation Re: Regular X Freezes , Please Help Nvidia

Hi Team!

Hi have a similar situation. NV module crashes, making my XOrg to freeze

Motherboard: Asus M2N-E
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
GPU: GeForce 7300 GS (XFX PV-T72G-WANG)
RAM: 2 x 512 OCZ

OS:
Debian Lenny / 2.6.21-2-amd64 #1 SMP Mon Jun 25 22:01:38 CEST 2007 x86_64 GNU/Linux

Here's what DMESG says when the module crashes:

NVRM: Xid (0007:00): 26, Ch 000001ff M 00001ffc D ffffffff intr ffffffff
NVRM: Xid (0007:00): 1, Ch 000001ff M 00001ffc D ffffffff intr ffffffff
NVRM: Xid (0007:00): 16, Head 00000000 Count 00082597
NVRM: Xid (0007:00): 16, Head 00000000 Count 000825a2
NVRM: Xid (0007:00): 16, Head 00000000 Count 000825ab
NVRM: Xid (0007:00): 16, Head 00000000 Count 000825b2
NVRM: Xid (0007:00): 16, Head 00000000 Count 000825c7
NVRM: Xid (0007:00): 16, Head 00000000 Count 000825d2
BUG: soft lockup detected on CPU#0!

Call Trace:
<IRQ> [<ffffffff802a24f8>] softlockup_tick+0xd5/0xe7
[<ffffffff80284137>] update_process_times+0x42/0x68
[<ffffffff802693aa>] smp_local_timer_interrupt+0x34/0x55
[<ffffffff80269ab6>] smp_apic_timer_interrupt+0x44/0x5c
[<ffffffff80255d56>] apic_timer_interrupt+0x66/0x70
<EOI> [<ffffffff884fd046>] :nvidia:_nv003521rm+0x20/0x22
[<ffffffff88702241>] :nvidia:_nv007344rm+0x7c/0xa3
[<ffffffff8880920f>] :nvidia:_nv001531rm+0x2f/0x106
[<ffffffff88807ca7>] :nvidia:_nv001553rm+0xd8/0x1aa
[<ffffffff887047e0>] :nvidia:_nv007714rm+0xde/0x15d
[<ffffffff886e6543>] :nvidia:_nv010297rm+0x12d/0x1c9
[<ffffffff886e6911>] :nvidia:_nv008698rm+0x10a/0x1aa
[<ffffffff886cd960>] :nvidia:_nv008558rm+0x77/0x191
[<ffffffff884ddea7>] :nvidia:_nv002734rm+0x3e0/0x40c
[<ffffffff884dd123>] :nvidia:_nv002735rm+0x110/0x2ac
[<ffffffff884d90e8>] :nvidia:_nv004588rm+0x68/0x95
[<ffffffff88507ed5>] :nvidia:_nv002683rm+0x1c5/0x6d9
[<ffffffff88504bc4>] :nvidia:rm_ioctl+0x2f/0x67
[<ffffffff888433a9>] :nvidia:nv_kern_ioctl+0x347/0x3c3
[<ffffffff88843464>] :nvidia:nv_kern_unlocked_ioctl+0x1c/0x23
[<ffffffff8023c1dc>] do_ioctl+0x21/0x6b
[<ffffffff8022cdc7>] vfs_ioctl+0x24e/0x267
[<ffffffff8022ce01>] __up_write+0x21/0x10d
[<ffffffff80245e24>] sys_ioctl+0x59/0x78
[<ffffffff8025511e>] system_call+0x7e/0x83



NVIDIA bug report log files is attached below.

Please, any suggestion will be well received

BRegards.-
ePoxi
Attached Files
File Type: zip nvidia-bug-report.zip (26.9 KB, 81 views)
epoxi is offline   Reply With Quote
Old 07-14-07, 09:02 PM   #4
billydv
Registered User
 
Join Date: Sep 2006
Posts: 88
Default Re: Regular X Freezes , Please Help Nvidia

See my post here, I think I might have found the problem that at least some of us are experiencing


http://www.nvnews.net/vbulletin/show...t=93110&page=4
billydv is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
rh7.3 and nvidia vcrispo NVIDIA Linux 11 07-31-02 08:57 PM

All times are GMT -5. The time now is 08:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.