Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-15-07, 07:34 PM   #1
OraDBA1
Registered User
 
Join Date: Jul 2007
Location: Atlanta
Posts: 1
Default Help Please!: Device eth0 has different MAC address than expected

Can someone please help me out here. I am bogged down with getting the lan interface to work.

My system details are:
HP Pavilion a6042n-b, AMD64, Motherboard MCP61
nVidia 6150SE, nForce 430
Linux distro: RHEL Update 5 (provided by Oracle)
kernel 2.6.9-55.0.0.0.2.ELsmp

Earlier, I was able to successfully configure it (using forcedeth in the file NFORCE-Linux-x86-1.21.zip) on RHEL4-U4 kernel 2.6.9-42.0.0.0.1.ELsmp. It was a piece of cake.

But then, I was forced to upgrade to RHEL4-U5 (because some other firewire drivers were not supported on U4), and forcedeth quit working. Tried both an in-place kernel upgrade, as well as a fresh install. Neither works.

On RHEL4-U5, after going through all the motions, when I finally try to bring up the device, I get the error:

Device eth0 has different MAC address than expected, ignoring

After "googling" for hours, I have tried a bunch of things but none worked.

The card shows up in lspci output as

00.07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)


1. I have tried to remove the HWADDR line, as suggested in some forums, didn't work and gave another error

2. Tried the command-line configuration as well as using the GNome based GUI, still no luck.

3. I have deleted the device, stopped the network, reloaded the driver using modprobe as well as insmod, followed by depmod -a, then all the ifconfig motions, nothing is working.

Now, the interesting thing is, that while on RHEL4-U4 the driver was not even included in the distro, I had to download it from nVidia, and the install was a breeze. Yet, the driver came included with the RHEL4-U5 distro, but is just not working.

Can some please help me here.

Thanks
OraDBA1
OraDBA1 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Undefined Device Error - Can't startx linuxdave NVIDIA Linux 2 08-07-02 03:28 PM

All times are GMT -5. The time now is 06:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.