Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-14-07, 03:37 PM   #1
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default RAID Failure - Please Help (mdadm)

Guys - I have a problem on my home PC. I am posting from it now however something is wrong with one of my two mirrors.

I have 2 Western Digital S-ATA drives on my PC. Exactly identical models.

I partitioned them so that

/dev/sda3 & /dev/sdb3 = /dev/md0

/dev/md0 is mounted on /

/dev/sda4 & /dev/sdb4 = /dev/md1

/dev/md1 is mounted on /home

However the problem is this...

Code:
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md1 : active raid1 sda4[0]
      135275264 blocks [2/1] [U_]

md0 : active raid1 sdb4[2](S) sdb3[1] sda3[0]
      19534976 blocks [2/2] [UU]

unused devices: <none>
It appears I am running on 1/2 a mirror on /home and although I can still use my system perfectly, I would like to repair this problem. I know the disk is fully functional and works perfectly - I think I somehow just messed or mixed things up and I don't have any RAID experience to resolve this so I am asking for any help on resolving this.
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Old 07-15-07, 09:15 AM   #2
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default Re: RAID Failure - Please Help (mdadm)

Yeah - this was not a Ubuntu / Beryl question so I assumed not much help here.

Self Resolved

Code:
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sdb4[2] sda4[0]
      135275264 blocks [2/1] [U_]
      [==============>......]  recovery = 70.5% (95456512/135275264) finish=17.7min speed=37391K/sec

unused devices: <none>
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sdb4[1] sda4[0]
      135275264 blocks [2/2] [UU]
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Old 07-15-07, 03:10 PM   #3
Bman212121
Registered User
 
Join Date: Jan 2006
Posts: 6,726
Default Re: RAID Failure - Please Help (mdadm)

Could you post how you fixed it as it might help someone else out in the future?
Bman212121 is offline   Reply With Quote
Old 07-15-07, 09:16 PM   #4
evilghost
Registered User
 
Join Date: Jul 2005
Posts: 3,606
Default Re: RAID Failure - Please Help (mdadm)

Just found this thread, I was going to chime in about the arrays not being uniform. You can make them uniform by doing a:

raidhotadd /dev/md1 /dev/sda4
evilghost is offline   Reply With Quote
Old 07-16-07, 07:31 AM   #5
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default Re: RAID Failure - Please Help (mdadm)

Code:
tunafish:/home/cwilliams# mdadm --remove /dev/md0 /dev/sdb4
mdadm: hot removed /dev/sdb4
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sda4[0]
      135275264 blocks [2/1] [U_]

unused devices: <none>
tunafish:/home/cwilliams# mdadm --re-add /dev/md1 /dev/sdb4
mdadm: added /dev/sdb4
tunafish:/home/cwilliams# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda3[0] sdb3[1]
      19534976 blocks [2/2] [UU]

md1 : active raid1 sdb4[2] sda4[0]
      135275264 blocks [2/1] [U_]
      [>....................]  recovery =  0.1% (259200/135275264) finish=34.7min speed=64800K/sec
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
$429.99 - areca ARC-1222 PCIe x8 SATA / SAS RAID Card News Newegg RSS Feed 0 06-28-12 04:38 AM
rm_init_adapter failure rizen NVIDIA Linux 9 11-09-02 09:33 PM
GeForce4 Ti 4400 problem with RAID motherboard hydr0 NVIDIA GeForce 7, 8, And 9 Series 10 10-26-02 01:06 AM
RAID question? MUYA CPUs, Motherboards And Memory 7 09-20-02 01:37 PM

All times are GMT -5. The time now is 03:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.