Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-15-07, 08:24 PM   #13
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Controlling the screen blanker

And why do you think that this is nvidia's fault?

Does the screen not go blank with the nv driver?

Have you tried if maybe HAL is the culprit? or acpid?

No?

So stop whining and do your homework!
energyman76b is offline   Reply With Quote
Old 07-15-07, 11:59 PM   #14
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Default Re: Controlling the screen blanker

Yes - it is the NV driver's fault. No doubt about that.
mperkel is offline   Reply With Quote
Old 07-16-07, 12:29 AM   #15
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Controlling the screen blanker

The driver only blanks the screen when Xorg tells it to. I'd be very surprised if this were a driver bug. It's much more likely that some component somewhere is requesting that the screen be blanked.
AaronP is offline   Reply With Quote
Old 07-20-07, 03:32 PM   #16
heyhello
Registered User
 
Join Date: Jul 2007
Posts: 2
Default Re: Controlling the screen blanker

I have the same problem, the settings must be in NVIDIA card
I cannot change it at all from Linux

Always after 20 min or so the signal from the card goes off - it is in dpms settings

I have the same card in Windows PC and I can modify it via power managament
either to never or to any time interval I want, and it works well.

but not in Linux (CentOS)... I can see it if I set my sw-screensaver(e.g. 5min),
that it first turns on screen saver(after5min), and after 20 min signal gets lost & screen goes black
So it is DPMS configuration.

If I change it in gnome - via power managament- to never or to 5 min, it is ignored - and it always turns off monitor after 20 min


And yes - I have all of the above
xorg.conf - I have had DPMS option there and I have removed/modified it but nothing has changed

I can see if it gets loaded or no in xorg.log
but xset -dpms nebver works, even if it gets loaded
the error message is
"server does not have extension for -dpms option"

I have tried everything so my guess is that it is some default manufacturer settings on board of the nvidia - or in the driver initialization routine

funny thing is that it only happpened when I have installed new CentOS and new drivers with it

so the question is -
how can I load the extension for DPMS - where can i find it ?

or the workaround for me would be also
how can I send the signal via joystick movement so the dpms will not turn off my screen,
can I add joystick device to xorg.conf - if yes ? how ?
what are the entries to put it there ?
Thanks
heyhello is offline   Reply With Quote
Old 07-20-07, 06:17 PM   #17
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Controlling the screen blanker

Add

Load "extmod"

to xorg.conf.
AaronP is offline   Reply With Quote
Old 07-21-07, 10:11 AM   #18
mperkel
Registered User
 
Join Date: Feb 2006
Posts: 13
Angry Re: Controlling the screen blanker

I'm sure something is telling it to turn off. But xset as no effect. It is as if the timeout is hard coded in the driver.
mperkel is offline   Reply With Quote
Old 07-21-07, 11:18 AM   #19
zivagolee
Registered User
 
Join Date: Aug 2004
Posts: 8
Default Re: Controlling the screen blanker

I believe there is an issue with latest xorg (i'm on Ubuntu). I had to add this to the ServerLayout in the xorg.conf so I can have Gnome control everything properly:

Section "ServerLayout"
.
.
.
Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection

Now the screen blanks with whatever I set in the gnome-power-manager.

I got this from here:

https://bugs.launchpad.net/ubuntu/+bug/66257
zivagolee is offline   Reply With Quote
Old 07-23-07, 12:13 PM   #20
heyhello
Registered User
 
Join Date: Jul 2007
Posts: 2
Default Re: Controlling the screen blanker

Bingo!
Thank you AaronP!

The

Load "extmod" in xorg.conf

has enabled the xset -dpms ,
and my monitor now stays ON

I haven't tried the Ubuntu solution yet , I'v been waiting now for 2 hours to see my screen go blank, unsuccesfully:-)
Thank You!!!
heyhello is offline   Reply With Quote

Old 07-23-07, 01:14 PM   #21
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Controlling the screen blanker

Quote:
Originally Posted by mperkel
Yes - it is the NV driver's fault. No doubt about that.
You are wrong. At work, with an ATI card, I see exactly the same issue.
pe1chl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5.6 .nvidia-settings-rc settings un-applied on screen lock bluziff NVIDIA Linux 1 06-14-12 05:12 AM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Stubborn screen res problem Alpsoandso NVIDIA Linux 6 05-03-12 06:00 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 03:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM

All times are GMT -5. The time now is 01:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.