Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-06-07, 07:59 AM   #1
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default NV-CONTROL Extension 1.6 too old for 1.0-7185? [solved]

Hello,
probably related to my other post:
After upgrading to 1.0-7185, nvidia-settings no longer works correctly, giving the message:
Code:
ERROR: NV-CONTROL extension version 1.6 is too old; the minimimum required version is 1.11.
ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.
ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.
ERROR: Unable to determine number of NVIDIA VCSCs on ':0.0'.
Is NV-CONTROL part of nvidia-glx or nvidia-driver?
Shouldn't it be matched to the driver release?

Andy
ahurst is offline   Reply With Quote
Old 08-06-07, 09:16 AM   #2
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: NV-CONTROL Extension 1.6 too old for 1.0-7185?

nvidia-bug-report.log is attached to other thread.
See http://www.nvnews.net/vbulletin/showthread.php?t=95945
ahurst is offline   Reply With Quote
Old 08-06-07, 11:20 AM   #3
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: NV-CONTROL Extension 1.6 too old for 1.0-7185?

You are using a too new version of nvidia-settings on your system. Nvidia-settings depends on NV-CONTROL which is build into the nvidia X driver.
Thunderbird is offline   Reply With Quote
Old 08-06-07, 11:26 AM   #4
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: NV-CONTROL Extension 1.6 too old for 1.0-7185? [solved]

Right,
it's a problem with Gentoo's ebuild, which uses the latest version of nvidia-settings, regardless of the driver version.

Andy
ahurst is offline   Reply With Quote
Old 08-07-07, 11:46 AM   #5
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: NV-CONTROL Extension 1.6 too old for 1.0-7185?

Which version of nvidia-settings can I use with driver 1.0-7185?

Andy
ahurst is offline   Reply With Quote
Old 08-07-07, 11:55 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NV-CONTROL Extension 1.6 too old for 1.0-7185?

The version that ships with the official driver package.
netllama is offline   Reply With Quote
Old 08-07-07, 03:08 PM   #7
ahurst
Registered User
 
Join Date: Aug 2007
Posts: 22
Default Re: NV-CONTROL Extension 1.6 too old for 1.0-7185? [solved]

Right, got it!
Sorry for being a bit slow on the uptake:
Gentoo package maintainers have decided to split the drivers and nvidia-settings into separate packages - hence problems..

Thanks for your help,

Andy
ahurst is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 02:44 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 09:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 01:14 PM

All times are GMT -5. The time now is 04:12 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.