Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-16-07, 02:20 PM   #1
mt1086
Registered User
 
Join Date: May 2007
Posts: 12
Default nvidia 7300 and ATI RS485/485C chipset incompatibilities (driver BUG)

I have an Nvidia 7300 GS and ATI RS485/485C chipset.
I've tried drivers 100.14.11 and previous ones with the same problem.

My computer locks up always (within seconds, if i'm lucky within a minute or two, I run any 3d aplication like beryl or google-earth). This is similar to the "nvidia 7300 and ATI RS480/482 chipset incompatibilities (driver BUG)" thread but it seems to happen more frequently.

I've done lots of things:

- Newer kernels: 2.6.20.10 (the driver doesn't compile in 2.6.21)
- Older kernels: 2.18.x
- Disabling ACPI, APM, APIC, SMP, everything.

My hardware:
AMD Athlon 64 X2 Dual Core Processor 3600+
1GB Ram DDR2
Mother MSI K9AGM, ATI RS485/485C based
Soutybridge SB600 (known to have problems when Message Signalled Interrupts are enabled, anyway the problem is still there if pci=nomsi is used)

Output of lspci -nn:

00:00.0 Host bridge [0600]: ATI Technologies Inc RS480 Host Bridge [1002:5950] (rev 10)
00:02.0 PCI bridge [0604]: ATI Technologies Inc RS480 PCI-X Root Port [1002:5a34]
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI0) [1002:4387]
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI1) [1002:4388]
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI2) [1002:4389]
00:13.3 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI3) [1002:438a]
00:13.4 USB Controller [0c03]: ATI Technologies Inc SB600 USB (OHCI4) [1002:438b]
00:13.5 USB Controller [0c03]: ATI Technologies Inc SB600 USB Controller (EHCI) [1002:4386]
00:14.0 SMBus [0c05]: ATI Technologies Inc SB600 SMBus [1002:4385] (rev 13)
00:14.1 IDE interface [0101]: ATI Technologies Inc SB600 IDE [1002:438c]
00:14.2 Audio device [0403]: ATI Technologies Inc SB600 Azalia [1002:4383]
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB600 PCI to LPC Bridge [1002:438d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SB600 PCI to PCI Bridge [1002:4384]
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:00.0 VGA compatible controller [0300]: nVidia Corporation G71 [GeForce 7300 GS] [10de:01df] (rev a1)
02:06.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet [10ec:8167] (rev 10)

I've tested my RAM using memtest and there where no errors reported.
I'm using a 32 bit version of ubuntu feisty, I've also tried 64 bit version of ubuntu edgy and debian etch for 32 bits and problem is in all of them. I think the problem might be in the nvidia driver, any help?
mt1086 is offline   Reply With Quote
Old 07-16-07, 02:54 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nvidia 7300 and ATI RS485/485C chipset incompatibilities (driver BUG)

Why do you believe this to be a driver bug rather than an issue with the motherboard?
netllama is offline   Reply With Quote
Old 07-18-07, 06:35 AM   #3
mt1086
Registered User
 
Join Date: May 2007
Posts: 12
Default Re: nvidia 7300 and ATI RS485/485C chipset incompatibilities (driver BUG)

Quote:
Originally Posted by netllama
Why do you believe this to be a driver bug rather than an issue with the motherboard?
Well, It just locks up in Linux. In Windows it works great and because there're similar problems related to the linux driver I think the problem may be similar. (http://www.nvnews.net/vbulletin/show...60#post1248560)

If it works on Window$ so I don't think my hardware is having problems.
What can I do to obtain information if its the driver or not??

Thanks for your reply.
Matias
mt1086 is offline   Reply With Quote
Old 08-12-07, 09:20 PM   #4
mt1086
Registered User
 
Join Date: May 2007
Posts: 12
Default Re: nvidia 7300 and ATI RS485/485C chipset incompatibilities (driver BUG)

Working good with the experimental patch submitted in http://www.nvnews.net/vbulletin/show...60#post1248560
mt1086 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.