Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-01-03, 01:29 PM   #1
FantasticRhino
Registered User
 
Join Date: Jun 2003
Posts: 2
Default A solution: Could not initialize NVIDIA kernel module problem...

I had been trying to get the latest driver to work on my box for a few days now trying just about all the "solutions" littered throughout this forum (frustrating to say the least). In my particular case, I had a look in the various system logs (I'm using RedHat9 and so I used the "System Logs" applet under System Tools).

The log entry I saw that tipped me off to the problem was:

nvidia: Can't find an IRQ for your NVIDIA card!
nvidia: Please check your BIOS settings.
nvidia: [Plug & Play OS ] should be set to NO
nvidia: [Assign IRQ to VGA] should be set to YES

In my case, the Assign IRQ to VGA was my problem. The thing is, this isn't mentioned anywhere in the README file.

Hope this helps.
FR
FantasticRhino is offline   Reply With Quote
Old 06-01-03, 03:39 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default Re: A solution: Could not initialize NVIDIA kernel module problem...

Quote:
Originally posted by FantasticRhino
The thing is, this isn't mentioned anywhere in the README file.
I beg to differ:

Quote:
Finally, the NVIDIA kernel module may print error messages indicating
a problem -- to view these messages please check /var/log/messages, or
wherever syslog is directed to place kernel messages. These messages
are prepended with "NVRM".
No, maybe it doesn't say "check your assign IRQ to VGA setting", but that bit of the FAQ about your error message points you right to your kernel logs. Which is where you found this message.

I've also posted hundreds of times that this BIOS setting is a likely culprit for messages like this...

In any case, it's good that you got it figured out.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM

All times are GMT -5. The time now is 04:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.