Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-14-07, 01:28 PM   #1
Cachinnum
Registered User
 
Join Date: Aug 2007
Posts: 3
Default help with legacy driver for a GFORCE MX440 on slackware 12.0, kernel 2.6.21.5

Hi everybody.
I really need help with this VGA. When I try to compile the driver I downloaded from the nvidia website (Legacy driver: NVIDIA-Linux-x86-1.0-9639-pkg1.run), it builds kernel module and then gives me an error in compiling kernel's interface.
There's a quote from nvidia-installer.log:

Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.21.5/source
SYSOUT=/lib/modules/2.6.21.5/build'...
sh ./conftest.sh "cc" "cc" /lib/modules/2.6.21.5/source /lib/modules/2.6.21.
5/build cc_sanity_check full_output
sh ./conftest.sh "cc" "cc" /lib/modules/2.6.21.5/source /lib/modules/2.6.21.
5/build select_makefile full_output
make --no-print-directory -f Makefile module

NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.21.5/build KBUILD_VERBOSE=1 -C /li
b/modules/2.6.21.5/source SUBDIRS=/tmp/selfgz16493/NVIDIA-Linux-x86-1.0-9755
-pkg1/usr/src/nv modules
make -C /lib/modules/2.6.21.5/build \
KBUILD_SRC=/usr/src/linux-2.6.21.5 \
KBUILD_EXTMOD="/tmp/selfgz16493/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv"
-f /usr/src/linux-2.6.21.5/Makefile modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \
echo; \
/bin/false)

If you need more information, please ask me.
Thanks !
Cachinnum is offline   Reply With Quote
Old 08-14-07, 01:31 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: help with legacy driver for a GFORCE MX440 on slackware 12.0, kernel 2.6.21.5

I dont' see any errors. Please attach the complete installer log.
netllama is offline   Reply With Quote
Old 08-14-07, 03:43 PM   #3
Cachinnum
Registered User
 
Join Date: Aug 2007
Posts: 3
Default Re: help with legacy driver for a GFORCE MX440 on slackware 12.0, kernel 2.6.21.5

Hi attached here is the complete log.

Bye
Attached Files
File Type: log nvidia-installer.log (24.2 KB, 111 views)
Cachinnum is offline   Reply With Quote
Old 08-14-07, 03:50 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: help with legacy driver for a GFORCE MX440 on slackware 12.0, kernel 2.6.21.5

nvidia: version magic '2.6.21.5-smp SMP mod_unload 686 ' should be '2.6.21.5
mod_unload 486 '

Your kernel source/headers do not match the kernel that you're running. You'll need to talk to the Slackware folks to resolve this.
netllama is offline   Reply With Quote
Old 08-14-07, 08:55 PM   #5
Cachinnum
Registered User
 
Join Date: Aug 2007
Posts: 3
Default Re: help with legacy driver for a GFORCE MX440 on slackware 12.0, kernel 2.6.21.5

ok, thanks!
Cachinnum is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 03:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.