Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-21-05, 07:53 AM   #1
tac
Registered User
 
Join Date: Mar 2005
Posts: 1
Question Asus A8N-SLI NForce4 sound problem

Hi,

I tried to install a mandrake 10.1 with nvidia 1.0-0301 driver.

But I haven't AC3 (or SPDIF) output working.
I test with the 2.6.11.3 kernel: same problem.
With alsa driver it's same too no digital output.

The analogical output works fine, the driver seems to be OK (no error with dmesg), nvmixer works well too. But I haven't any ac3 output...

I tried to change bios settings, no change...
Perhaps I have to flash the bios?

Is it a known problem?

Thx
T++
tac is offline   Reply With Quote
Old 05-24-05, 09:19 PM   #2
georgeandbungle
Registered User
 
Join Date: May 2005
Posts: 1
Default Re: Asus A8N-SLI NForce4 sound problem

I am using Windows Xp and I have the same problem, it is probably something simple but I have not sorted it yet.
georgeandbungle is offline   Reply With Quote
Old 05-30-05, 01:34 PM   #3
Dazz
"TOON ARMY!"
 
Join Date: Jul 2002
Location: Newcastle, United Kingdom
Posts: 5,138
Send a message via AIM to Dazz
Default Re: Asus A8N-SLI NForce4 sound problem

Yeah you MUST use realteks drivers sadly only Analog output works. Thats due to it not being a NV sound chip it's a REaltek codec. Luckly DFi does have have this issue it allows you to use either NV codec or Realteks codec via a jumper.
__________________
"Never interupt your enemy when he is making a mistake."

Processor: AMD Phenom II X6 1090T Black Edition @ 4.25GHz
Motherboard: Gigabyte GA-990FXA-UD3
Graphics: ASUS ENGTX470
Memory: 4GB Kingston HyperX Blu PC12800 DDR3
Monitor: LG E2260V-PN Full HD WLED 22" & DELL 20" 2005FPW,
Power: Coolermaster Silent Pro Modular 850w PSU
Sound: Logitech Z5500 Digital.
Cooling: Thermalright Silver Arrow.
1st Storage: Kingston V100 SSDNow128GB SSD
2nd Storage: Samsung Spinpoint F1 750GB
Dazz is offline   Reply With Quote
Old 06-02-05, 02:48 PM   #4
abatis
Registered User
 
Join Date: Jun 2005
Posts: 2
Default Re: Asus A8N-SLI NForce4 sound problem

Make sure you have the Audio97 enabled in the bios. That was my issue. Now sound works great with the Nvidia Realtek drivers.
abatis is offline   Reply With Quote
Old 07-01-05, 01:02 AM   #5
fpikus
Registered User
 
Join Date: Jun 2005
Posts: 2
Default Re: Asus A8N-SLI NForce4 sound problem

Got SPDIF-out to work with ALSA 1.0.9 (not NForce binary driver). The driver is snd-intel8x0, as alsa web page says. odules.conf or modprobe.conf from alsa web page, nothing fancy there, no module options. /etc/asound.conf or .asoundrc don't matter at all (for spdif out, that is), mine are empty.

Here is what matters: there are two settings in /etc/asound.state which must BOTH be correct for spdif out to work. Settings are:

name 'IEC958 Playback Switch'
value true
name 'IEC958 Playback AC97-SPSA'
value 0

I found only one mixer which has controls for them, gamix. The second one is controlled by a slider, values change from 0 to 3. Only 0 works.
fpikus is offline   Reply With Quote
Old 09-26-05, 06:59 AM   #6
nyback
Registered User
 
Join Date: Apr 2004
Posts: 2
Default Re: Asus A8N-SLI NForce4 sound problem

I had the same problem. Optical spdif on ASUS A8N-SLI Deluxe.
The information from fpikus together with last post in
https://bugtrack.alsa-project.org/al...ew.php?id=1083
And i got it to work.
Some clues if you use kde like me:
Get visible light on the optical. Then at least the output is active.
You should see the IEC958 Playback AC97-SPSA slider in kmix. Set it to "All the way down"=0=Off (If you turn the volume up on the slider the sound turns off !?!) Its the same thing as fpikus says about value=0 in asound.state)
In the third TAB in kmix (I dont know the name in english, i have swedish KDE, maybe "Switches") you should see a selector for IEC958, set it to PCM.
Only 48 khz works. So
mplayer -ao alsa:device=hw=0,2 -srate 48000 <file>
worked.
Set arts to use OSS and lock it on 48 khz.
SOUND!!!!
/Andreas
nyback is offline   Reply With Quote
Old 12-06-05, 04:26 AM   #7
Daryl
Registered User
 
Join Date: Dec 2005
Posts: 7
Default Re: Asus A8N-SLI NForce4 sound problem

I have a Fedora Core 4 (kernel Linux 2.6.14-1.1644) on a Athlon 64 4000+ and an ASUS A8N-SLI (nForce 4 SLI chipset) and I installed NFORCE-Linux-x86_64-1.0-0310-pkg1.run and configured my /etc/modprobe.conf as described in the NVidia instructions, but I hear no sound at all.
I cannot event start nvmixer because if I try to do that, I receive the following error message:
nvmixer: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

But I have all the legacy libstdc++ library installed, as shown below:

$ ll /usr/lib/libstdc++*
-rwxr-xr-x 1 root root 258288 8 mar 2005 /usr/lib/libstdc++-2-libc6.1-1-2.9.0.so
-rwxr-xr-x 1 root root 269388 8 mar 2005 /usr/lib/libstdc++-3-libc6.2-2-2.10.0.so
lrwxrwxrwx 1 root root 30 3 dic 17:18 /usr/lib/libstdc++-libc6.1-1.so.2 -> libstdc++-2-libc6.1-1-2.9.0.so
lrwxrwxrwx 1 root root 31 3 dic 17:18 /usr/lib/libstdc++-libc6.2-2.so.3 -> libstdc++-3-libc6.2-2-2.10.0.so
lrwxrwxrwx 1 root root 18 3 dic 17:18 /usr/lib/libstdc++.so.5 -> libstdc++.so.5.0.7
-rwxr-xr-x 1 root root 733520 9 mar 2005 /usr/lib/libstdc++.so.5.0.7
lrwxrwxrwx 1 root root 18 3 dic 17:07 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.4
-rwxr-xr-x 1 root root 933428 20 mag 2005 /usr/lib/libstdc++.so.6.0.4


Can someone help me?

Thank you very much.
Daryl is offline   Reply With Quote
Old 01-29-07, 11:11 AM   #8
nyback
Registered User
 
Join Date: Apr 2004
Posts: 2
Default Re: Asus A8N-SLI NForce4 sound problem

Update if someone reads this thread....

I seems nowadays you dont need to lock the rate to 48 khz. But you still need to select PCM and set the volumes in the mixer as stated above.
I finaly took the time to check why i only got it to work with oss and not alsa in the arts settings.
If i select alsa and add "plug:dmix" to override selected device it works.
So how make dmix default in alsa?
My /etc/asound.conf :

pcm.nforce-hw {
type hw
card 0
device 2
}

pcm.!default {
type plug
slave.pcm "dmix"
}

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "nforce-hw"
period_time 0
period_size 1024
buffer_size 32768
# rate 44100
}
bindings {
0 0
1 1
}
}

ctl.nforce {
type hw
card 0
device 2
}

ctl.nforce-hw {
type hw
card 0
device 2
}



I dont know if all is needed. I think only

pcm.!default {
type plug
slave.pcm "dmix"
}

is the important stuff. This makes dmix turned on for default device playback. Now i can select ALSA in all applications and i get SPDIF sound. I can also set arts to use plain ALSA and it works perfect. No extra settings needed in the arts config.



Quote:
Originally Posted by nyback
I had the same problem. Optical spdif on ASUS A8N-SLI Deluxe.
The information from fpikus together with last post in
https://bugtrack.alsa-project.org/al...ew.php?id=1083
And i got it to work.
Some clues if you use kde like me:
Get visible light on the optical. Then at least the output is active.
You should see the IEC958 Playback AC97-SPSA slider in kmix. Set it to "All the way down"=0=Off (If you turn the volume up on the slider the sound turns off !?!) Its the same thing as fpikus says about value=0 in asound.state)
In the third TAB in kmix (I dont know the name in english, i have swedish KDE, maybe "Switches") you should see a selector for IEC958, set it to PCM.
Only 48 khz works. So
mplayer -ao alsa:device=hw=0,2 -srate 48000 <file>
worked.
Set arts to use OSS and lock it on 48 khz.
SOUND!!!!
/Andreas
nyback is offline   Reply With Quote

Old 08-24-07, 02:20 AM   #9
arrrghhh
Registered User
 
Join Date: Aug 2007
Posts: 19
Default Re: Asus A8N-SLI NForce4 sound problem

how about for digital coax? i have the same board (a8n-sli premium) and i am trying to get my digital coax jack to work...

i'm using fesity fawn of ubuntu (7.04) and i have tried the drivers from asus and from realtek. i never found any audio drivers from nvidia for linux...
arrrghhh is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.