Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-14-07, 03:07 PM   #1
edhunterbg
Registered User
 
Join Date: Jun 2007
Posts: 28
Default cant get xorg to start at all

Hi guys

I have serious problem with the updated xorg.

Today I updated my /usr/src and recompiled my kerenel. I also made a big portupgrade -a, and now xorg and related ports are version 7.3. I reinstalled nvidia-driver from ports.
And rebooted. Gues what.... gdm cant start:
gdm[718]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
...

So I decided to test without nvidia-driver and deinstalled it, then i deleted /etc/X11/xorg.conf and I made new clean xorg.conf with xorgconfig.

But this didnt help, again i got errors:
from messages:
gdm[9048]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
gdm[9043]: Failed to start X server several times in a short time period; disabling display :0

from /var/log/xorg.0.log:
...
(II) Loading /usr/local/lib/xorg/modules/drivers//vga_drv.so
(II) Module vga: vendor="X.Org Foundation"
compiled for 7.2.0, module version = 4.1.0
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 1.1
(EE) module ABI major version (1) doesn't match the server's version (2)(II) UnloadModule: "vga"
(II) Unloading /usr/local/lib/xorg/modules/drivers//vga_drv.so
(EE) Failed to load module "vga" (module requirement mismatch, 0)
...

and now I dont have X at all (
need help!
10x in advance


p.s. specs: freebsd 6.2 i386, xorg 7.3, gnome 2.18.3
edhunterbg is offline   Reply With Quote
Old 09-14-07, 04:07 PM   #2
alexdupre
Registered User
 
Join Date: Apr 2007
Posts: 17
Default Re: cant get xorg to start at all

There are two temporary workarounds for this issue:
1) start X.org with --ignoreABI
2) use the bundled "nv" driver

Said so, I hope a new driver will be released soon.
alexdupre is offline   Reply With Quote
Old 09-15-07, 03:48 AM   #3
edhunterbg
Registered User
 
Join Date: Jun 2007
Posts: 28
Default Re: cant get xorg to start at all

Quote:
Originally Posted by alexdupre
There are two temporary workarounds for this issue:
1) start X.org with --ignoreABI
2) use the bundled "nv" driver

Said so, I hope a new driver will be released soon.
it didnt help much

but after portupgrade -f xf86-* i got it running with nv driver, i'll wait for updated nvidia-driver.
edhunterbg is offline   Reply With Quote
Old 09-15-07, 04:41 AM   #4
rhurlin
FreeBSD in Science
 
rhurlin's Avatar
 
Join Date: Jan 2007
Location: Northeim, Germany
Posts: 22
Default Re: cant get xorg to start at all

Quote:
Originally Posted by edhunterbg
it didnt help much

but after portupgrade -f xf86-* i got it running with nv driver, i'll wait for updated nvidia-driver.

I had the same problems after xorg update. Recompiling x11/nvidia-driver and starting xorg with 'startx -- -ignoreABI' (pay attention to hyphens!) helps. For using gdm or xdm you can read something in /usr/ports/UPDATING ...

Rainer
rhurlin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft explained why they killed start button AthlonXP1800 Microsoft Windows 8 19 10-28-12 09:07 AM
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 12:23 PM
Problems with 173.14.35 and xorg 1.12 joedoe NVIDIA Linux 4 07-09-12 02:11 PM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 09:34 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.