Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-20-07, 06:11 AM   #1
erusul
Registered User
 
Join Date: Sep 2007
Posts: 15
Default Module of *.19 failed to build with 2.6.22.5-cfs

Last version of the nvidia driver failed to build for me.

I'm using a vanilla 2.6.22.5 linux version patched with the cfs[1] scheduler
Attached is the installation attemp log

[1] http://people.redhat.com/mingo/cfs-scheduler/

Last edited by erusul; 09-20-07 at 06:21 AM. Reason: Bad log file
erusul is offline   Reply With Quote
Old 09-20-07, 06:20 AM   #2
erusul
Registered User
 
Join Date: Sep 2007
Posts: 15
Default Re: Module of *.19 failed to build with 2.6.22.5-cfs

I messed up the error log...

here it's the correct one
Attached Files
File Type: log nvidia-installer.log (26.6 KB, 144 views)
erusul is offline   Reply With Quote
Old 09-20-07, 06:41 AM   #3
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Module of *.19 failed to build with 2.6.22.5-cfs

and that is the error:
make -f /home/alex/kernel/linux-2.6/scripts/Makefile.modpost
scripts/mod/modpost -m -i /home/alex/kernel/2.6.22/Module.symvers -I /tmp
/selfgz5197/NVIDIA-Linux-x86-100.14.19-pkg1/usr/src/nv/Module.symvers -o /tm
p/selfgz5197/NVIDIA-Linux-x86-100.14.19-pkg1/usr/src/nv/Module.symvers -w -s
scripts/mod/modpost: invalid option -- s
make[4]: *** [__modpost] Error 1
make[3]: *** [modules] Error 2
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2

which is not cfs 'fault' because I installed the latest driver with 2.6.22.5-cfs
energyman76b is offline   Reply With Quote
Old 09-20-07, 08:18 AM   #4
erusul
Registered User
 
Join Date: Sep 2007
Posts: 15
Default Re: Module of *.19 failed to build with 2.6.22.5-cfs

I failed to see any solution in the response you posted. Can you elaborate?
I have seen the error in the modpost fase but i do not why it happens or how to fix it

PS. I'm corrently using *.11 whithout problems and it allways built ok
erusul is offline   Reply With Quote
Old 09-20-07, 08:29 AM   #5
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Module of *.19 failed to build with 2.6.22.5-cfs

I tried to say that this should not be the fault of the cfs patch, but either the installer or some other change. And that I was able to install the drivers (via gentoo ebuild), despite using 2.6.22.5+cfs patch.
energyman76b is offline   Reply With Quote
Old 09-20-07, 11:56 AM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Module of *.19 failed to build with 2.6.22.5-cfs

At a first glance, this looks like a KBUILD problem of some sort. The -s option doesn't come from the NVIDIA KBUILD Makefile.
zander is offline   Reply With Quote
Old 09-22-07, 12:15 AM   #7
Bakked
Registered User
 
Join Date: Jan 2007
Posts: 13
Default Re: Module of *.19 failed to build with 2.6.22.5-cfs

I had this problem and it turned out to be an old version of scripts/mod/modpost. The new one had not been built. I removed it and ran kernel make and it was rebuilt using the newer scripts/mod/modpost.c
Bakked is offline   Reply With Quote
Old 09-24-07, 05:36 AM   #8
erusul
Registered User
 
Join Date: Sep 2007
Posts: 15
Default Re: Module of *.19 failed to build with 2.6.22.5-cfs

Quote:
Originally Posted by Bakked
I had this problem and it turned out to be an old version of scripts/mod/modpost. The new one had not been built. I removed it and ran kernel make and it was rebuilt using the newer scripts/mod/modpost.c
Thank you; I did a make mrproper and compiled again the custom kernel
After that the driver instaled without problems.
erusul is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
Diablo 3 build guide: Barbarian, Demon Hunter, Monk, Witch Doctor and Wizard News Archived News Items 0 05-12-12 12:00 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM

All times are GMT -5. The time now is 05:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.