Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-19-07, 04:21 AM   #1
Jarzebski
Registered User
 
Jarzebski's Avatar
 
Join Date: Apr 2006
Posts: 18
Default 100.14.19 and NVreg_SaveVBios (x86_64)

>modprobe nvidia

FATAL: Error inserting nvidia (/lib/modules/2.6.21.1/kernel/drivers/video/nvidia.ko): Unknown symbol in module, or unknown parameter (see dmesg)

>dmesg

nvidia: Unknown parameter `NVreg_SaveVBios'

-- Added

Sorry i have this param in modules.conf. Please moderator to delete this post
__________________
http://www.jarzebski.pl/
Jarzebski is offline   Reply With Quote
Old 09-19-07, 12:17 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 100.14.19 and NVreg_SaveVBios (x86_64)

The kernel module parameter was removed and the logic backing it enabled by default.
zander is offline   Reply With Quote
Old 09-26-07, 04:37 AM   #3
ukpbert
Registered User
 
Join Date: Sep 2007
Posts: 2
Default Re: 100.14.19 and NVreg_SaveVBios (x86_64)

so, is there a fix or work around for this lil issue? cos right now i'm stuck using metacity and the nv driver...

sorry zander but your explaination is a little vague, is this an NV prob or an issue with a recent kernel change?
ukpbert is offline   Reply With Quote
Old 09-26-07, 11:18 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 100.14.19 and NVreg_SaveVBios (x86_64)

@ukpbert: if you're referring to the load failure, you can solve it by removing NVreg_SaveVBios from your modprobe configuration file(s).
zander is offline   Reply With Quote
Old 09-27-07, 03:49 AM   #5
ukpbert
Registered User
 
Join Date: Sep 2007
Posts: 2
Default Re: 100.14.19 and NVreg_SaveVBios (x86_64)

i had my modified nvidia module file backed up as nvidia.tweak, which was where the conflict was. i thought files in /etc/modprobe.d/ were only loaded if there was an exact match with the .ko that was being loaded...

nvm, it's all working now,

cheers
ukpbert is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.