Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-13-03, 11:00 PM   #1
gcain
Registered User
 
Join Date: Jun 2003
Posts: 9
Send a message via ICQ to gcain
Default Problem with GLX.

Hi Guys,

I have just installed the Nvidia drivers (1.0-4363) onto my Debian 3.0 2.4.18-k7 box with very sad results.

Firstly if I include the Load "glx" section in my XF86Config-4 file the whole system crashes (Log file here )

If I remove that line, all appears to load well, except that I get a screen full of ASCII. Kinda hard to use a GUI you can't see! ;P

X does, however, work if I remove the GLX line and change the drivers from nvidia to nv.
This doesn't help me though. Although it does mean I have a working config.

Please find my XF86Config-4 file here

Any suggestions will be greatly appreciated!

Hardware:
Asus board.
XP1800 Chip
GeForce2 MX440 (Soon to be a Ti4600 when my power supply arrives)

Anything else you need to know just ask!
I fear this may be an easy fix, although I have googled till me fingers bled and read every FAQ in sight.
So far nothing has helped.

Thanks in advance,
Garreth.
gcain is offline   Reply With Quote
Old 06-14-03, 02:24 AM   #2
SnapIT
Registered User
 
Join Date: Jun 2003
Posts: 154
Default Re: Problem with GLX.

Quote:
Originally posted by gcain
Hi Guys,

I have just installed the Nvidia drivers (1.0-4363) onto my Debian 3.0 2.4.18-k7 box with very sad results.

Firstly if I include the Load "glx" section in my XF86Config-4 file the whole system crashes (Log file here )

If I remove that line, all appears to load well, except that I get a screen full of ASCII. Kinda hard to use a GUI you can't see! ;P

X does, however, work if I remove the GLX line and change the drivers from nvidia to nv.
This doesn't help me though. Although it does mean I have a working config.

Please find my XF86Config-4 file here

Any suggestions will be greatly appreciated!

Hardware:
Asus board.
XP1800 Chip
GeForce2 MX440 (Soon to be a Ti4600 when my power supply arrives)

Anything else you need to know just ask!
I fear this may be an easy fix, although I have googled till me fingers bled and read every FAQ in sight.
So far nothing has helped.

Thanks in advance,
Garreth.
Your .conf loads the nv driver but should load the nvidia driver...

just replace nv with nvidia, under section device...
SnapIT is offline   Reply With Quote
Old 06-14-03, 05:52 PM   #3
gcain
Registered User
 
Join Date: Jun 2003
Posts: 9
Send a message via ICQ to gcain
Default

Hi SnapIT,

I must have put up the wrong config. I have already changed the driver to nvidia.

One thing I have noticed though is this.

If I start my machine (power on) as soon as it loads KDM the screen turns to ASCII. I can still press Ctrl+Alt+Del to reboot, so it hasnt crashed.
However, if I log in from a remote terminal and kill KDM and X, then restart it I get the Nvidia splash screen and all works fine. It seems taht the drivers have to crash before they will work.
I have put up the new Config, and the log doesnt show anything, as far as its concerned, all has worked fine.

Any ideas? Im trying to write a script to crash X and then restart it for me, although this is obviously less than perfect.

Rregards,
Garreth
gcain is offline   Reply With Quote
Old 06-15-03, 12:15 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

According to the log that's there now, you're still using the "nv" driver...

The log also says "Using config file: /etc/X11/XF86Config-4", so are you sure that's the file you're editing? It sounds like it is, but you never know.

According to the log, you're also using driver version 4191. Is there any specific reason for this, or might upgrading to 4363 help?

The fact that it sig11's right after initializing the GLX extension (which is provided by nVidia) while using the "nv" driver (which is not), makes this part of the setup sound like a good candidate...

If this log isn't the current one, could you post that?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 06-15-03, 05:32 PM   #5
gcain
Registered User
 
Join Date: Jun 2003
Posts: 9
Send a message via ICQ to gcain
Default

Bwkaz,

Im definatly not using the nv drivers, as when X finaly does start, I do get the Nvidia screen showing.
Im using the older drivers because of the problem I am having, I thought it might be a bug with the newer ones.... So I started working my way back until I found drivers that worked.
I get the same problem with every version of the drivers.
Originaly I changed the driver but somehow it was being changed back. (No ****! I swear I changed it!!) although thats err, stopped now! ;P

I have posted the current log.

Thanks for yout help!

Garreth

Ps. If the file isnt attached, check the link in my first post.
gcain is offline   Reply With Quote
Old 06-16-03, 09:10 PM   #6
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Hmm... strange.

Just about the only thing that *might* be helpful is the "failed to verify AGP" warning. I would think that that would automatically set NvAGP to 0, but maybe if you try it yourself?

Option "NvAGP" "0"

in your Device section.

Just as a test, does lowering the res to 1024x768 help?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 06-16-03, 09:58 PM   #7
gcain
Registered User
 
Join Date: Jun 2003
Posts: 9
Send a message via ICQ to gcain
Default

I tend to run in a res of 800x600 untill everything is setup.

The problem still occurs at that res so its not that.

Ill give the AGP option a whirl as soon as I get home (currently at work)

Garreth.
gcain is offline   Reply With Quote
Old 06-17-03, 02:30 AM   #8
gcain
Registered User
 
Join Date: Jun 2003
Posts: 9
Send a message via ICQ to gcain
Default Its Working!!!!

Firstly



OK here's what I did.

I recompiled my Kernel and left out the Direct Rendering Manager (DRI) under Character Devices.

Then I did your NvAGP fix below.

Only thing is, my box has to recompile the kernel at every boot. Not a bad thing though, Ive got that setup with a script already.

Beauty!!

Im off for a game of UT2 followed by TuxRacer, and then maybe some QuakeIII!!

Thanks all for your help!


Garreth
gcain is offline   Reply With Quote

Old 06-17-03, 07:19 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

You probably don't have to recompile the kernel stuff on every boot. It would probably help to just /sbin/modprobe nvidia in your script instead.

Or, since Debian uses either /etc/modules (a list of modules to load at boot) or /etc/rc.modules (a script that gets run) at bootup, either put nvidia in the /etc/modules file, or put /sbin/modprobe nvidia in rc.modules, and that should help too.

Glad it works.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 09:58 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Problem with GLX(?) Nykolas NVIDIA Linux 4 08-12-02 02:24 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 03:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.