Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-07, 12:18 PM   #1
jernst
Registered User
 
Join Date: Nov 2007
Posts: 2
Default Ethernet has Alzheimer's

This is about the "dual NVIDIA Gigabit Ethernet" that's on the abit KN9 SLI motherboard. Running under Debian Etch 2.6.18-5-xen-amd64.

Summary: if the eth1 interface is not talked to for some period of time, it forgets the IP address that was assigned to it. It will only remember once a broadcast message is sent (such as an ARP lookup on that IP address). (eth0 is Firewire on this motherboard, we haven't tried with eth2)

Longer version: It was started by the following observation/problem. The box runs several XEN virtual machines. If XEN dom0 is not being talked to for some time (happens often, it is only used for XEN administration), it fails to respond to any and all network traffic that isn't originating on the local subnet. However, it does respond to local traffic, AFTER WHICH is responds to remote traffic as well and continues responding as long as it is being talked to continuously. Hours worth of packet-level debugging led to the observation that the ARP lookup wakes it back up from non-responsive mode.

The really funny thing about is that while all DOM0 and DOMU run over the same physical ethernet card, DOMUs that are active continue to work well, while the DOM0 goes silent. (And vice versa, any DOMU might go silent while DOM0 stays up) The Linux kernel never sees incoming packets. So the problem is somewhere between the card and the kernel.

Any ideas?
jernst is offline   Reply With Quote
Old 11-20-07, 01:17 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Ethernet has Alzheimer's

Do you use DHCP on eth1? Might pay to use static ips.
whig is offline   Reply With Quote
Old 11-21-07, 12:17 PM   #3
jernst
Registered User
 
Join Date: Nov 2007
Posts: 2
Default Re: Ethernet has Alzheimer's

It's all static IP addresses.
jernst is offline   Reply With Quote
Old 11-21-07, 02:00 PM   #4
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: Ethernet has Alzheimer's

Would you suspect your switch? Test this by connecting to another pc directly via a crossover cable. See if it 'forgets' after a while.

Also suspect your OS. Leave it running a different distro - or Windows - for sometime while you're doing something else.
whig is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
$22.99 - NETIS ST-3123 10/100/1000Mbps 8-Port Giga Ethernet Switch News Newegg RSS Feed 0 06-28-12 04:38 AM
$22.99 - NETIS ST-3123 10/100/1000Mbps 8-Port Giga Ethernet Switch News Archived News Items 0 06-23-12 04:30 AM
MSI K7N420Pro embedded ethernet not responding to pings rupertshocking NVIDIA Linux 6 08-15-02 04:50 PM
Problem with Ethernet (nvnet) driver for RH 7.3 bernz NVIDIA Linux 4 08-05-02 10:18 AM

All times are GMT -5. The time now is 08:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.