Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-20-03, 05:17 PM   #1
Vishruth
Registered User
 
Join Date: Apr 2003
Location: India
Posts: 121
Send a message via ICQ to Vishruth Send a message via Yahoo to Vishruth
Default Problem with Debian 3.0 (GeForce4 MX 440)

I am trying to install the NVIDIA driver for Linux on Debian 3.0 (I use GeForce4 MX 440 graphics card and my kernel version is 2.4.18-bf2.4).

I have installed the header files for my kernel and I did specify the 'include' directory of my kernel header files to the driver installation program. I when I tried to run the program, I got this message:

No precompiled kernel interface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from NVIDIA ftp site (ftp://download.nvidia.com)?

Unfortunately, I can't connect to the internet from Debian.

The rest of the installation program went smoothly and I edited the XF86config file as instructed. But the X server didn't start up. I have attached the XF86 config file and the log file in zip format.

Could somebody please help me here?

Thanks.
Attached Files
File Type: zip vm-deb-xserver-prob.zip (4.8 KB, 98 views)
__________________
http://freeshell.in/~vish/

|Dell Inspiron 8600 Laptop - Pentium-M 1.8 GHz CPU 2M L2 cache (Dothan), 400 MHz FSBUS, Intel 855PM chipset, 512MB RAM (DDR333/256x2), 60GB Hitachi PATA HDD (5400 RPM), Nvidia GeForceFX Go 5200 GPU (64MB DDR/AGP 4x), 15.4" WUXGA Display|

|Desktop Machine - AMD Athlon64 X2 4400+ CPU, ASUS A8N SLI Premium MB, 2x1GB RAM (Corsair XMS Twinx2048 3200C2PT), 200GB Seagate PATA HDD (7200 RPM), BFG 7800GTX OC GPU, ViewSonic VX1932wm 19" LCD, Antec P160 case|
Vishruth is offline   Reply With Quote
Old 06-21-03, 11:52 AM   #2
Vishruth
Registered User
 
Join Date: Apr 2003
Location: India
Posts: 121
Send a message via ICQ to Vishruth Send a message via Yahoo to Vishruth
Default

um... help?

The same post over at JustLinux.Com
__________________
http://freeshell.in/~vish/

|Dell Inspiron 8600 Laptop - Pentium-M 1.8 GHz CPU 2M L2 cache (Dothan), 400 MHz FSBUS, Intel 855PM chipset, 512MB RAM (DDR333/256x2), 60GB Hitachi PATA HDD (5400 RPM), Nvidia GeForceFX Go 5200 GPU (64MB DDR/AGP 4x), 15.4" WUXGA Display|

|Desktop Machine - AMD Athlon64 X2 4400+ CPU, ASUS A8N SLI Premium MB, 2x1GB RAM (Corsair XMS Twinx2048 3200C2PT), 200GB Seagate PATA HDD (7200 RPM), BFG 7800GTX OC GPU, ViewSonic VX1932wm 19" LCD, Antec P160 case|
Vishruth is offline   Reply With Quote
Old 06-21-03, 09:50 PM   #3
Martin_95
Registered User
 
Join Date: Jun 2003
Location: Bulgaria
Posts: 5
Send a message via ICQ to Martin_95
Default

try in console (as root):
modprobe nvidia
than run the installer.... prompt - download - no
if error occure again... you should recompile your kernel
first getting kernel-source from debian cd or from www.kernel.org
than put this source in the /usr/src folder , exttract the source and folder linux-2.x.x occured than:
cd /usr/src
ln -s linux-2.x.x linux
cd /linux
make menuconfig

put supports for everything you probably use read through the menus than push "Exit"

make dep bzImage modules modules_install

reboot

modprobe nvidia

run the installera for more details ask some your friend

the most important is to be sure that after you recompile kernel you run it not other kernel ( for that also should ask friend cause it is too long me to explain it...) i'll be watching you")_!
Martin_95 is offline   Reply With Quote
Old 06-22-03, 09:15 AM   #4
Vishruth
Registered User
 
Join Date: Apr 2003
Location: India
Posts: 121
Send a message via ICQ to Vishruth Send a message via Yahoo to Vishruth
Default

wow... that's a lot of stuff to do. I'll try them and will let you know what happened. Thanks very much.
__________________
http://freeshell.in/~vish/

|Dell Inspiron 8600 Laptop - Pentium-M 1.8 GHz CPU 2M L2 cache (Dothan), 400 MHz FSBUS, Intel 855PM chipset, 512MB RAM (DDR333/256x2), 60GB Hitachi PATA HDD (5400 RPM), Nvidia GeForceFX Go 5200 GPU (64MB DDR/AGP 4x), 15.4" WUXGA Display|

|Desktop Machine - AMD Athlon64 X2 4400+ CPU, ASUS A8N SLI Premium MB, 2x1GB RAM (Corsair XMS Twinx2048 3200C2PT), 200GB Seagate PATA HDD (7200 RPM), BFG 7800GTX OC GPU, ViewSonic VX1932wm 19" LCD, Antec P160 case|
Vishruth is offline   Reply With Quote
Old 06-22-03, 01:35 PM   #5
Vishruth
Registered User
 
Join Date: Apr 2003
Location: India
Posts: 121
Send a message via ICQ to Vishruth Send a message via Yahoo to Vishruth
Default

I did 'modprobe nvidia' and then added 'nvdia' to /etc/modules and everything works great now. Thanks for all the help.
__________________
http://freeshell.in/~vish/

|Dell Inspiron 8600 Laptop - Pentium-M 1.8 GHz CPU 2M L2 cache (Dothan), 400 MHz FSBUS, Intel 855PM chipset, 512MB RAM (DDR333/256x2), 60GB Hitachi PATA HDD (5400 RPM), Nvidia GeForceFX Go 5200 GPU (64MB DDR/AGP 4x), 15.4" WUXGA Display|

|Desktop Machine - AMD Athlon64 X2 4400+ CPU, ASUS A8N SLI Premium MB, 2x1GB RAM (Corsair XMS Twinx2048 3200C2PT), 200GB Seagate PATA HDD (7200 RPM), BFG 7800GTX OC GPU, ViewSonic VX1932wm 19" LCD, Antec P160 case|
Vishruth is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Problems with a GeForce4 MX 440 under Debian Iainuki NVIDIA Linux 1 09-24-02 09:27 PM
nVidia Geforce4 440 Go 1400x1050 problem moreinf NVIDIA Linux 10 09-16-02 12:25 PM
Riva TNT 2 - Debian (Woody) chipset problem sindra NVIDIA Linux 4 08-26-02 03:21 AM
nvidea drivers on 2.4.18 Debian (3.0 woody) thor NVIDIA Linux 2 08-20-02 02:51 PM

All times are GMT -5. The time now is 10:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.