Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-01-07, 11:03 AM   #1
namakemono456
Registered User
 
Join Date: Nov 2007
Posts: 16
Default If we are supposed to uninstall nvidia-glx-new...

What should we use instead, and what should be under the module section of the xorg.conf?
(using 169.04)
namakemono456 is offline   Reply With Quote
Old 12-01-07, 01:14 PM   #2
Euphoria
--- ephor ---
 
Euphoria's Avatar
 
Join Date: Sep 2002
Posts: 197
Default Re: If we are supposed to uninstall nvidia-glx-new...

Quote:
Originally Posted by namakemono456
What should we use instead, and what should be under the module section of the xorg.conf?
(using 169.04)
See my Previous Post
Euphoria is offline   Reply With Quote
Old 12-01-07, 02:06 PM   #3
namakemono456
Registered User
 
Join Date: Nov 2007
Posts: 16
Default Re: If we are supposed to uninstall nvidia-glx-new...

Didnt break anything but didnt fix anything...heres mt xorg
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:29:35 PDT 2007


Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    Option         "aiglx" "true"
EndSection

Section "Files"
EndSection

Section "Module"

#    Load           "glx"
    Load           "v4l"
#    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "Monitor"
    Identifier     "Generic Monitor"
    VendorName     "Samsung"
    ModelName      "Samsung SyncMaster 930B"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Gamma           1
    ModeLine       "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
    ModeLine       "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
    ModeLine       "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
    ModeLine       "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
    ModeLine       "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
    ModeLine       "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
    ModeLine       "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    ModeLine       "832x624@75" 57.3 832 864 928 1152 624 625 628 667 -hsync -vsync
    ModeLine       "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
    ModeLine       "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
    ModeLine       "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
    ModeLine       "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
    ModeLine       "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
    ModeLine       "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
    ModeLine       "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    ModeLine       "1280x960@75" 129.9 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
    ModeLine       "1400x1050@60" 122.6 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
    ModeLine       "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    ModeLine       "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
EndSection

Section "Monitor"

 # 
    Identifier     "monitor1"
    Gamma           1
EndSection

Section "Device"
    Identifier     "nVidia Corporation G71 [GeForce 7300 GS]"
    Driver         "nvidia"
    BoardName      "nv"
    BusID          "PCI:2:0:0"
    Screen          0
EndSection

Section "Device"

 # 
    Identifier     "device1"
    Driver         "nvidia"
    BoardName      "nv"
    BusID          "PCI:2:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation G71 [GeForce 7300 GS]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Virtual     1600 1200
        Depth       24
        Modes      "1280x1024@75" "1280x960@60" "1152x864@75" "1280x1024@60" "1024x768@60" "1280x960@75" "1024x768@70" "1400x1050@60" "1024x768@75" "1600x1200@65" "832x624@75" "1600x1200@60" "800x600@60" "800x600@75" "800x600@72" "800x600@56" "640x480@75" "640x480@72" "640x480@60"
    EndSubSection
EndSection

Section "Screen"

 # 
    Identifier     "screen1"
    Device         "device1"
    Monitor        "monitor1"
    DefaultDepth    24
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
namakemono456 is offline   Reply With Quote
Old 12-01-07, 02:33 PM   #4
Euphoria
--- ephor ---
 
Euphoria's Avatar
 
Join Date: Sep 2002
Posts: 197
Default Re: If we are supposed to uninstall nvidia-glx-new...

Ok here is my xorg.conf


I don't think my .conf file is correct... I just SSHed to my PC and copied the code, but I am seeing that I am loading under Modules XGL and AIXGL...
It worked when I restarted the Xsrever last night...

I'll check this later tonight when I get home....



Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Wed Sep 12 14:29:17 PDT 2007

# /.../
# SaX generated X11 config file
# Created on: 2007-11-20T10:56:26-0800.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[0]" 0 0
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"
    Option         "Clone" "off"
    Option         "Xinerama" "off"
#    Option         "aiglx" "true"
EndSection

Section "Files"
    InputDevices      "/dev/gpmdata"
    InputDevices      "/dev/input/mice"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/URW"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/PEX"
    FontPath        "/usr/share/fonts/cyrillic"
    FontPath        "/usr/share/fonts/latin2/misc:unscaled"
    FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/Type1"
    FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath        "/usr/share/fonts/baekmuk:unscaled"
    FontPath        "/usr/share/fonts/japanese:unscaled"
    FontPath        "/usr/share/fonts/kwintv"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/uni:unscaled"
    FontPath        "/usr/share/fonts/CID"
    FontPath        "/usr/share/fonts/ucs/misc:unscaled"
    FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/misc:unscaled"
    FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/Type1"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/xtest"
    FontPath        "/opt/kde3/share/fonts"
EndSection

Section "Module"
    Load           "aiglx"
    Load           "type1"
    Load           "extmod"
    Load           "dbe"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "microsoftpro"
    Option         "XkbRules" "xfree86"
EndSection

Section "InputDevice"
    Identifier     "Mouse[1]"
    Driver         "mouse"
    Option         "Buttons" "10"
    Option         "Device" "/dev/input/mice"
    Option         "Name" "Logitech MX-700 Cordless Mouse Receiver"
    Option         "Protocol" "explorerps/2"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Modes"
    Identifier         "Modes[0]"
    ModeLine     "1440x900" 106.0 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
    ModeLine     "1024x768" 78.7 1024 1056 1184 1312 768 772 776 792
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "WDE"
    ModelName      "LCM-19W4"
    UseModes       "Modes[0]"
    DisplaySize     408    255
    HorizSync       30.0 - 82.0
    VertRefresh     43.0 - 76.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "EVGA Corporation"
    BoardName      "GeForce 7800 GT"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "default"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "default"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
Euphoria is offline   Reply With Quote
Old 12-01-07, 04:09 PM   #5
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: If we are supposed to uninstall nvidia-glx-new...

remove the # in front of Load glx.

And why all the modelines? modern displays should not need them. Especially if they are connected via dvi.
energyman76b is offline   Reply With Quote
Old 12-01-07, 10:36 PM   #6
namakemono456
Registered User
 
Join Date: Nov 2007
Posts: 16
Default Re: If we are supposed to uninstall nvidia-glx-new...

yeah the # there is there just for a test, i've run it w/o it, the comp wont run without the nvidia-glx-new package installed from repo. The display modes were automatically added by the display manager, so i prefer not to change stuff that works untill everything works.

i notices something strange, under the /lib/linux-restricted-modules/ folder i have nvidia, nvidia-legacy, and nvidia-new folders, should i? also i noticed in the disabled modules there was DISABLED_MODULES="nvidia nvidia-legacy" in there. w/ a 7300 is that right?

here the responce for glxinfo command
Code:
~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 16 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x39 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
namakemono456 is offline   Reply With Quote
Old 12-01-07, 11:14 PM   #7
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: If we are supposed to uninstall nvidia-glx-new...

yeah, sounds that you did not follow this steps:
http://www.nvnews.net/vbulletin/showthread.php?t=72490

and about the modelines: this is somthing that should have died 10 years ago. Why does ubuntu insists of using them?
energyman76b is offline   Reply With Quote
Old 12-01-07, 11:25 PM   #8
namakemono456
Registered User
 
Join Date: Nov 2007
Posts: 16
Default Re: If we are supposed to uninstall nvidia-glx-new...

thats whats so frustrating, i've followed those directions 7 times now off of a fresh install of gutsy... wth am i doing wrong O.o is there a way to script those commands to see if i forgot something....is the basic of the first step to delete everything with the words nvidia on your computer? i can do that easy at least lol
namakemono456 is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 07:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.